base-files: don't ship local build key when on buildbot
authorDaniel Golle <daniel@makrotopia.org>
Sun, 12 Apr 2020 19:28:49 +0000 (20:28 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 12 Apr 2020 19:35:00 +0000 (20:35 +0100)
Including the local build key in /etc/opkg/keys isn't feasible when
building on the buildbot: The included key collides with its copy
already in openwrt-keyring which breaks the ImageBuilder.
Not including a locally generated key also makes the base-files package
more reproducible.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/base-files/Makefile

index f0085e56905c5854d13a0dd7f6a063b0ebdf5732..156e7bc8b9d1277571d5f0f1fa45b1e79bdbbb94 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=217
+PKG_RELEASE:=218
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
@@ -118,12 +118,14 @@ ifdef CONFIG_SIGNED_PACKAGES
 
   endef
 
+ifndef CONFIG_BUILDBOT
   define Package/base-files/install-key
        mkdir -p $(1)/etc/opkg/keys
        $(CP) $(BUILD_KEY).pub $(1)/etc/opkg/keys/`$(STAGING_DIR_HOST)/bin/usign -F -p $(BUILD_KEY).pub`
 
   endef
 endif
+endif
 
 ifeq ($(CONFIG_NAND_SUPPORT),)
   define Package/base-files/nand-support