ramips: add kmod-usb-dwc2 to ZyXEL Keenetic image
authorAlexey Dobrovolsky <dobrovolskiy.alexey@gmail.com>
Sat, 9 May 2020 18:10:44 +0000 (21:10 +0300)
committerPetr Štetiar <ynezz@true.cz>
Wed, 3 Jun 2020 14:49:28 +0000 (16:49 +0200)
ZyXEL Keenetic has a USB port. Thus, DWC2 USB controller driver should
be in the default image for this device.

Fixes: a7cbf59e0e04 ("ramips: add new device ZyXEL Keenetic as kn")
Signed-off-by: Alexey Dobrovolsky <dobrovolskiy.alexey@gmail.com>
[fixed whitespace issue]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/ramips/image/rt305x.mk

index d66f0b3a7086d2c739c71300e22c72c6e877a1b1..3171646b8a8219d5a162c159c1b2452eafa13a78 100644 (file)
@@ -1187,7 +1187,8 @@ define Device/zyxel_keenetic
   IMAGE_SIZE := 7872k
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := Keenetic
   IMAGE_SIZE := 7872k
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := Keenetic
-  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ehci kmod-usb-ledtrig-usbport
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ehci kmod-usb-ledtrig-usbport \
+       kmod-usb-dwc2
   SUPPORTED_DEVICES += kn
 endef
 TARGET_DEVICES += zyxel_keenetic
   SUPPORTED_DEVICES += kn
 endef
 TARGET_DEVICES += zyxel_keenetic