oxnas: convert DEVICE_TITLE to new variables
authorDaniel Golle <daniel@makrotopia.org>
Sat, 6 Jul 2019 19:21:34 +0000 (21:21 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 10 Jul 2019 14:56:16 +0000 (16:56 +0200)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/oxnas/image/ox810se.mk
target/linux/oxnas/image/ox820.mk

index 52170a26fa1dd2f07a090610323eb8068b7b43f9..2cb61c5645bbbb8f4c98d8c05a20815959e3640b 100644 (file)
@@ -12,7 +12,9 @@ endef
 
 define Device/wd-mbwe
   DEVICE_DTS := ox810se-wd-mbwe
-  DEVICE_TITLE := Western Digital My Book World Edition
+  DEVICE_VENDOR := Western Digital
+  DEVICE_MODEL := My Book
+  DEVICE_VARIANT := World Edition
   KERNEL := kernel-bin | append-dtb | uImage none
 endef
 TARGET_DEVICES += wd-mbwe
index de1bfd19fb6974cf646aa74211ebeeb7ba05dafc..0c0301b1ecd5d6683bd03e651c738d1bd7635827 100644 (file)
@@ -39,7 +39,8 @@ define Build/encrypt-3des
 endef
 
 define Device/akitio_mycloud
-  DEVICE_TITLE := Akition myCloud (mini) / SilverStone DC01
+  DEVICE_VENDOR := Akition
+  DEVICE_MODEL := myCloud mini
   SUPPORTED_DEVICES += akitio
   DEVICE_PACKAGES := kmod-usb2-oxnas kmod-ata-oxnas-sata kmod-usb-ledtrig-usbport \
                      kmod-i2c-gpio kmod-rtc-ds1307
@@ -47,23 +48,25 @@ endef
 TARGET_DEVICES += akitio_mycloud
 
 define Device/cloudengines_pogoplugpro
-  DEVICE_TITLE := Cloud Engines PogoPlug Pro (with mPCIe)
+  DEVICE_VENDOR := Cloud Engines
+  DEVICE_MODEL := PogoPlug Pro (with mPCIe)
   SUPPORTED_DEVICES += pogoplug-pro
   DEVICE_PACKAGES := kmod-usb2-oxnas kmod-usb-ledtrig-usbport kmod-rt2800-pci wpad-basic
 endef
 TARGET_DEVICES += cloudengines_pogoplugpro
 
 define Device/cloudengines_pogoplug-series-3
-  DEVICE_TITLE := Cloud Engines PogoPlug Series V3 (without mPCIe)
+  DEVICE_VENDOR := Cloud Engines
+  DEVICE_MODEL := PogoPlug Series V3 (without mPCIe)
   SUPPORTED_DEVICES += cloudengines,pogoplugv3 pogoplug-v3
   DEVICE_PACKAGES := kmod-usb2-oxnas kmod-usb-ledtrig-usbport
 endef
 TARGET_DEVICES += cloudengines_pogoplug-series-3
 
 define Device/shuttle_kd20
-  DEVICE_TITLE := Shuttle KD20
+  DEVICE_VENDOR := Shuttle
+  DEVICE_MODEL := KD20
   SUPPORTED_DEVICES += kd20
-  KERNEL := kernel-bin | append-dtb | uImage none
   KERNEL_INITRAMFS_PREFIX = $$(IMAGE_PREFIX)-factory
   KERNEL_INITRAMFS_SUFFIX := .tar.gz
   KERNEL_INITRAMFS = kernel-bin | append-dtb | uImage none | omninas-factory | encrypt-3des sohmuntitnlaes
@@ -75,9 +78,9 @@ endef
 TARGET_DEVICES += shuttle_kd20
 
 define Device/mitrastar_stg-212
-  DEVICE_TITLE := MitraStar STG-212
+  DEVICE_VENDOR := MitraStar
+  DEVICE_MODEL := STG-212
   SUPPORTED_DEVICES += stg212
-  KERNEL := kernel-bin | append-dtb | uImage none
   DEVICE_PACKAGES := kmod-usb2-oxnas kmod-ata-oxnas-sata kmod-fs-ext4 kmod-fs-xfs \
                      kmod-usb-ledtrig-usbport
 endef