ramips: add support for ZIO FREEZIO
authorSungbo Eo <mans0n@gorani.run>
Mon, 11 Nov 2019 16:26:44 +0000 (01:26 +0900)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 13 Dec 2019 14:37:37 +0000 (15:37 +0100)
ZIO FREEZIO is a 2.4/5GHz band AC1200 router, based on MediaTek MT7621A.

Specifications:
- SoC: MT7621AT
- RAM: DDR3 128MB
- Flash: SPI NOR 16MB
- WiFi:
  - 2.4GHz: MT7603EN
  - 5GHz: MT7612EN
- Ethernet: 5x 10/100/1000Mbps
  - Switch: SoC internal
- USB: 1x 3.0
- UART:
  - J4: 3.3V, RX, TX, GND (3.3V is the square pad) / 57600 8N1

Notes:
- FREEZIO has almost the same board as WeVO W2914NS v2.
- Stock firmware is based on OpenWrt BB.

MAC addresses in factory partition:
0x0004: WiFi 2.4GHz (label_mac-8)
0x002e: WAN (label_mac)
0x8004: WiFi 5GHz (label_mac-4)
0xe000: LAN (label_mac+1)

Installation via web interface:
1.  Access web admin page and turn on "OpenWrt UI mode".
2.  Flash sysupgrade image through LuCI, with the "Keep settings" option
    OFF.

Revert to stock firmware:
1.  Perform sysupgrade with stock image.
    Make sure to NOT preserve settings.

Signed-off-by: Sungbo Eo <mans0n@gorani.run>
[rebase, use mt7621_wevo_w2914ns-v2.dtsi]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ramips/dts/mt7621_zio_freezio.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk
target/linux/ramips/mt7621/base-files/etc/board.d/02_network

diff --git a/target/linux/ramips/dts/mt7621_zio_freezio.dts b/target/linux/ramips/dts/mt7621_zio_freezio.dts
new file mode 100644 (file)
index 0000000..dce1c4b
--- /dev/null
@@ -0,0 +1,20 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7621_wevo_w2914ns-v2.dtsi"
+
+/ {
+       compatible = "zio,freezio", "mediatek,mt7621-soc";
+       model = "ZIO FREEZIO";
+
+       leds {
+               compatible = "gpio-leds";
+
+               usb {
+                       label = "freezio:green:usb";
+                       gpios = <&gpio0 27 GPIO_ACTIVE_LOW>;
+                       trigger-sources = <&xhci_ehci_port1>;
+                       linux,default-trigger = "usbport";
+               };
+       };
+};
index d663aa29dae8a6232f1dfcae67ec834475a90dca..0b2b74800af9a71272b568bf7bd81a9bae8ab354 100644 (file)
@@ -910,3 +910,12 @@ define Device/zbtlink_zbt-wg3526-32m
   SUPPORTED_DEVICES += ac1200pro zbt-wg3526-32M
 endef
 TARGET_DEVICES += zbtlink_zbt-wg3526-32m
+
+define Device/zio_freezio
+  MTK_SOC := mt7621
+  IMAGE_SIZE := 16064k
+  DEVICE_VENDOR := ZIO
+  DEVICE_MODEL := FREEZIO
+  DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+endef
+TARGET_DEVICES += zio_freezio
index 2447ff8a8dde7ba5dc166c42c6e54c2feebe77b9..c9e3cbb984471671c8ec1f61b8f5aa8dee9197af 100755 (executable)
@@ -45,7 +45,8 @@ ramips_setup_interfaces()
        netgear,wndr3700-v5|\
        netis,wf-2881|\
        wevo,11acnas|\
-       wevo,w2914ns-v2)
+       wevo,w2914ns-v2|\
+       zio,freezio)
                ucidef_add_switch "switch0" \
                        "0:lan:4" "1:lan:3" "2:lan:2" "3:lan:1" "4:wan" "6@eth0"
                ;;
@@ -241,7 +242,8 @@ ramips_setup_macs()
                wan_mac=$(macaddr_add "$(mtd_get_mac_binary factory 0x22)" 1)
                ;;
        wevo,11acnas|\
-       wevo,w2914ns-v2)
+       wevo,w2914ns-v2|\
+       zio,freezio)
                wan_mac=$(mtd_get_mac_binary factory 0x2e)
                label_mac=$wan_mac
                ;;