kernel-build: ignore runtime config options during reconfig
[oweals/openwrt.git] / include / kernel-build.mk
index 684fbd34d3c033faea097ffffc471959408f7ab8..b1d3fc07fd233503901af2cb47f1125f5ee1c29c 100644 (file)
@@ -165,7 +165,9 @@ define BuildKernel
                $(if $(findstring Darwin,$(HOST_OS)),HOST_LOADLIBES="-L$(STAGING_DIR_HOST)/lib -lncurses") \
                YACC=$(STAGING_DIR_HOST)/bin/bison \
                $$@
-       $(LINUX_RECONF_DIFF) $(LINUX_DIR)/.config > $(LINUX_RECONFIG_TARGET)
+       $(LINUX_RECONF_DIFF) $(LINUX_DIR)/.config | \
+               grep -vE '(CONFIG_CC_(HAS_ASM_GOTO|IS_GCC|IS_CLANG)|GCC_VERSION)=' \
+               > $(LINUX_RECONFIG_TARGET)
 
   install: $(LINUX_DIR)/.image
        +$(MAKE) -C image compile install TARGET_BUILD=