Final pci ids pull for RHEL 7.2
[oweals/hwdata.git] / hwdata.spec
1 # This package is arch-specific just because of bundling different files for
2 # different architectures. No -debuginfo package is needed.
3 %global     debug_package %{nil}
4 %global     uprelease   8.0
5
6 Name:       hwdata
7 Summary:    Hardware identification and configuration data
8 Version:    0.252
9 Release:    %{uprelease}%{?dist}
10 License:    GPLv2+
11 Group:      System Environment/Base
12 Source0:    https://fedorahosted.org/releases/h/w/%{name}/%{name}-%{version}-%{uprelease}.tar.bz2
13 URL:        http://git.fedorahosted.org/git/hwdata.git
14
15 BuildRequires   : perl
16
17 Requires        : systemd
18 Requires(post)  : systemd
19 Requires(postun): systemd
20
21 %description
22 hwdata contains various hardware identification and configuration data,
23 such as the pci.ids and usb.ids databases.
24
25 %prep
26 %setup -q -n %{name}-%{version}-%{uprelease}
27 %ifarch ppc ppc64
28 patch -b -B nx_crypto -p1 < blacklist-nx_crypto.patch
29 %endif
30 %configure
31
32 %build
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_prefix}/lib
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %post
42 udevadm hwdb --update >/dev/null 2>&1 || :
43
44 %postun
45 udevadm hwdb --update >/dev/null 2>&1 || :
46
47 %files
48 %doc LICENSE COPYING
49 %dir %{_datadir}/%{name}
50 %{_prefix}/lib/modprobe.d/dist-blacklist.conf
51 %{_prefix}/lib/udev/hwdb.d/[0-9][0-9]-*.hwdb
52 %{_datadir}/%{name}/*
53
54 %changelog
55 * Fri Oct 23 2015 Michal Minar <miminar@redhat.com> 0.252-8.0
56 - Updated pci, usb and vendor ids.
57 - Resolves: rhbz#1236458
58 - Resolves: rhbz#1256004
59 - Resolves: rhbz#1266217
60 - Resolves: rhbz#1271797
61
62 * Mon Jun 29 2015 Michal Minar <miminar@redhat.com> 0.252-7.9
63 - Updated pci, usb and vendor ids.
64
65 * Tue Apr 14 2015 Michal Minar <miminar@redhat.com> 0.252-7.8
66 - Blacklisted module nx_crypto on PowerPCs.
67 - Resolves: rhbz#1211389
68 - Disable debuginfo build.
69
70 * Fri Apr 10 2015 Michal Minar <miminar@redhat.com> 0.252-7.6
71 - Blacklisted experimental module sha1-mb.
72 - Resolves: rhbz#1208120
73
74 * Fri Jan 30 2015 Michal Minar <miminar@redhat.com> 0.252-7.5
75 - Updated vendor, usb and pci ids.
76
77 * Mon Sep 22 2014 Michal Minar <miminar@redhat.com> 0.252-7.4
78 - Updated vendor, usb and pci ids.
79
80 * Thu Mar 27 2014 Michal Minar <miminar@redhat.com> 0.252-7.3
81 - Added few more hwdb files.
82 - Updated vendor and pci ids.
83
84 * Thu Mar 20 2014 Michal Minar <miminar@redhat.com> 0.252-7.1
85 - Bumped release to reflect rhel version.
86 - Fixed bogus dates in changelog.
87 - Generate and install hwdb.d/* files.
88
89 * Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 0.252-3
90 - Mass rebuild 2013-12-27
91
92 * Mon Aug 5 2013 Michal Minar <miminar@redhat.com> 0.252-2
93 - Changelog fix.
94
95 * Sun Jul 21 2013 Michal Minar <miminar@redhat.com> 0.252-1
96 - Data files update.
97
98 * Sat Jul 06 2013 Michal Minar <miminar@redhat.com> 0.250-1
99 - Data files update.
100
101 * Thu Jun 20 2013 Michal Minar <miminar@redhat.com> 0.249-1
102 - Data files update, pnp.ids included.
103
104 * Thu Apr 18 2013 Michal Minar <miminar@redhat.com> 0.248-1
105 - Data files update
106
107 * Wed Mar 27 2013 Michal Minar <miminar@redhat.com> 0.247-1
108 - Moved blacklist.conf from /etc/modprobe.d to /usr/lib/modprobe.d.
109 - Renamed it to dist-blacklist.conf.
110 - Data files update
111
112 * Mon Mar 18 2013 Michal Minar <miminar@redhat.com> 0.245-1
113 - Data files update
114
115 * Mon Feb 18 2013 Michal Minar <miminar@redhat.com> 0.244-1
116 - Data files updated
117
118 * Fri Jan 18 2013 Michal Minar <miminar@redhat.com> 0.243-1
119 - Data files updated
120
121 * Fri Dec 07 2012 Michal Minar <miminar@redhat.com> 0.242-1
122 - Update data files
123
124 * Wed Nov 07 2012 Michal Minar <miminar@redhat.com> 0.241-1
125 - Update data files
126
127 * Wed Sep 26 2012 Michal Minar <miminar@redhat.com> 0.240-1
128 - made use of configure script in prep
129
130 * Tue Sep 25 2012 Michal Minar <miminar@redhat.com> 0.239-1
131 - Update data files
132
133 * Thu Aug 23 2012 Adam Jackson <ajax@redhat.com> 0.238-1
134 - Fix reference specfile to current Fedora style
135
136 * Thu Aug 23 2012 Adam Jackson <ajax@redhat.com> 0.235-1
137 - Update data files
138 - Remove upgradelist, not needed since kudzu-ectomy
139
140 * Mon Aug 08 2011 Karsten Hopp <karsten@redhat.com> 0.233-7.3
141 - update pci.ids, usb. ids
142
143 * Mon May 02 2011 Karsten Hopp <karsten@redhat.com> 0.233-7.2
144 - update pci.ids with a fix for QLogic Infiniband adapter
145
146 * Wed Apr 27 2011 Karsten Hopp <karsten@redhat.com> 0.233-7.1
147 - update to latest pci.ids, usb.ids
148
149 * Fri Jan 28 2011 Karsten Hopp <karsten@redhat.com> 0.233-7
150 - bump release
151 - update oui.txt URL
152 - fix tarball name in spec file
153 - update usb.ids, out.txt and pci.ids
154
155 * Wed Aug 25 2010 Karsten Hopp <karsten@redhat.com> 0.233-1
156 - update usb.ids, out.txt and pci.ids
157
158 * Thu Aug 05 2010 Karsten Hopp <karsten@redhat.com> 0.232-1
159 - update usb.ids, out.txt and pci.ids (#550020, #611860)
160 - fix incorrect syntax doc/comment in blacklist.conf (Ville Skyttä, #532802)
161 - add Acer B243HL and BenQ G2420HDBL (Ville Skyttä, #590787)
162 - add HP LP2475w and Samsung 2494HM (Ville Skyttä, #595059)
163
164 * Tue May 25 2010 Phil Knirsch <pknirsch@redhat.com> 0.230-1
165 - update usb.ids, out.txt and pci.ids
166 - Resolves: #584788
167
168 * Mon Mar 29 2010 Karsten Hopp <karsten@redhat.com> 0.229-1
169 - update usb.ids, out.txt and pci.ids for F-13 (#571914)
170
171 * Wed Mar 17 2010 Phil Knirsch <pknirsch@redhat.com> 0.228-1
172 - Blacklist chsc_sch for s390x
173 - Resolves: #563228
174
175 * Tue Feb 23 2010 Dave Airlie <airlied@redhat.com> 0.227-1
176 - add viafb to blacklist
177
178 * Mon Feb 22 2010 Karsten Hopp <karsten@redhat.com> 0.227-1
179 - update usb.ids, pci.ids, oui.txt
180 - update license
181
182 * Fri Jan 15 2010 Karsten Hopp <karsten@redhat.com> 0.226-1
183 - update release number
184
185 * Fri Jan 15 2010 Karsten Hopp <karsten@redhat.com> 0.225-4
186 - update usb.ids pci.ids oui.txt
187
188 * Mon Nov 30 2009 Dennis Gregorovic <dgregor@redhat.com> - 0.225-3.1
189 - Rebuilt for RHEL 6
190
191 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.225-3
192 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
193
194 * Tue Jul 07 2009 Adam Jackson <ajax@redhat.com> 0.225-2
195 - pnp-dell.patch: Fix Dell's entry in pnp.ids
196
197 * Thu Apr 09 2009 Adam Jackson <ajax@redhat.com> 0.224-1
198 - Update pci.ids, usb.ids, and oui.txt
199 - Add pnp.ids
200
201 * Thu Mar 19 2009 Karsten Hopp <karsten@redhat.com> 0.223-1
202 - update usb.ids pci.ids oui.txt
203 - rename /etc/modprobe.d/blacklist to /etc/modprobe.d/blacklist.conf
204
205 * Wed Jan 28 2009 Karsten Hopp <karsten@redhat.com> 0.222-1
206 - update usb.ids pci.ids oui.txt and build for all current releases
207   Fixes p.e. #465440
208
209 * Wed Jan 21 2009 Karsten Hopp <karsten@redhat.com> 0.221-1
210 - update usb.ids pci.ids oui.txt
211
212 * Tue Dec 02 2008 Karsten Hopp <karsten@redhat.com> 0.220-1
213 - add new monitor entries from Mandriva hardware database (Thierry Vignaud)
214 - make generic entries have properly formated frequencies (Thierry Vignaud)
215 - remove duplicate Dell monitor entries (Thierry Vignaud)
216 - more vendor name fixes
217 - fix extra field in 'Compudyne KD-1500N' definition (Thierry Vignaud)
218 - make Dell monitors case consistent (Thierry Vignaud)
219 - make all GoldStar monitors have the same vendor name (Thierry Vignaud)
220 - add URL of git repository
221 - fix spacing (Thierry Vignaud)
222 - sort MonitorDB file with LANG=C sort -f -t ";" -k1,2
223 - add Samsung SyncMaster 2443BWX (Marc van den Dikkenberg)
224 - add some Lenovo monitors (Im Sza)
225
226 * Wed Jul 23 2008 Karsten Hopp <karsten@redhat.com> 0.220-1
227 - update pci.ids, usb.ids, oui.txt
228 - MonitorsDB: add some Samsung monitors (Ronald Warsow)
229 - MonitorsDB: add Dell E1609W (Matt Domsch)
230 - MonitorsDB: add 7 Dell monitors (Matt Domsch)
231 - MonitorsDB: add a bunch of Hyundai and ImageQuest monitors
232
233 * Mon Jun 09 2008 Karsten Hopp <karsten@redhat.com> 0.219-1
234 - add BenQ FP2091 monitor (Peter Williams)
235 - add a bunch of Hyundai and ImageQuest monitors
236
237 * Mon Jun 02 2008 Karsten Hopp <karsten@redhat.com> 0.219-1
238 - update pci.ids, usb.ids, oui.txt
239 - blacklist snd-pcsp (#448425)
240
241 * Mon May 19 2008 Karsten Hopp <karsten@redhat.com> 0.218-1
242 - add some Acer monitors (Im Sz)
243
244 * Tue Apr 01 2008 Karsten Hopp <karsten@redhat.com> 0.217-1
245 - update pci.ids, oui.txt
246 - update usb.ids, fixes #439963
247 - add HP w1907 LCD monitor, fixes #431359
248 - fix many monitor entries (Stanislav Ievlev, #430276)
249
250
251 * Mon Mar 03 2008 Karsten Hopp <karsten@redhat.com> 0.216-1
252 - update pci.ids, usb.ids (#431658)
253
254 * Tue Jan 29 2008 Phil Knirsch <pknirsch@redhat.com> 0.215-1
255 - Pull new upstream pci.ids
256
257 * Wed Jan 23 2008 Karsten Hopp <karsten@redhat.com> 0.215-1
258 - add HP W2207 monitor
259 - add oui.txt, a list of bluetooth device makers
260
261 * Fri Jan 18 2008 Karsten Hopp <karsten@redhat.com> 0.214-1
262 - remove MonitorsDB.generic as it isn't used anywhere
263 - drop RHEL-5 blacklist patch in -devel
264
265 * Tue Jan 15 2008 Karsten Hopp <karsten@redhat.com> 0.213-1
266 - add many monitor entries (Im Sza, #367111)
267
268 * Fri Jan 11 2008 Karsten Hopp <karsten@redhat.com> 0.212-1
269 - pull new upstream pci.ids, usb.ids
270 - Resolves: #300831
271 - added HP TFT5600 LCD Monitor
272 - Resolves: #250569
273 - added Acer AL1916W, Eizo L568/L568D, Samsung 795DF
274 - Resolves: #250582
275 - Add Samsung 205BW/206BW/225BW/226BW
276 - Resolves: #250584
277 - Add Samsung 931BF
278 - Resolves: #250587
279
280 * Sat Dec 22 2007 Karsten Hopp <karsten@redhat.com> 0.209-1
281 - add Proview 926w monitor (#363091)
282
283 * Sat Dec 22 2007 Karsten Hopp <karsten@redhat.com> 0.208-1
284 - new release
285 - drop dell-monitors patch, already included in tarball
286
287 * Thu Dec 13 2007 Karsten Hopp <karsten@redhat.com> 0.207-3
288 - fix License tag
289 - add empty %%build section for fedora-review
290
291 * Thu Oct 25 2007 Matt Domsch <Matt_Domsch@dell.com> 0.207-2
292 - MonitorsDB: add 20 new Dell monitors
293
294 * Wed Sep 26 2007 Karsten Hopp <karsten@redhat.com> 0.211-1
295 - pull new upstream pci.ids, usb.ids
296
297 * Thu Sep 20 2007 Karsten Hopp <karsten@redhat.com> 0.210-1
298 - add pci.id for Chelsio 10GbE Ethernet Adapter
299 - Resolves: bz #296811
300
301 * Wed Sep 19 2007 Karsten Hopp <karsten@redhat.com> 0.209-1
302 - pull new upstream pci.ids, usb.ids
303
304 * Wed Aug 29 2007 Karsten Hopp <karsten@redhat.com> 0.207-1
305 - update license tag
306
307 * Wed Aug 15 2007 Karsten Hopp <karsten@redhat.com> 0.207-1
308 - pull new upstream pci.ids and rebuild
309 - Resolves: bz #251732
310 - Resolves: bz #251734
311 - Resolves: bz #252195
312 - Resolves: bz #252196
313 - Resolves: bz #241274
314
315 * Tue Aug 14 2007 Karsten Hopp <karsten@redhat.com> 0.205-1
316 - add HP TFT5600        #229370
317
318 * Mon Jul 09 2007 Karsten Hopp <karsten@redhat.com> 0.205-1
319 - enable iwl4965 blacklist
320 - Resolves: bz#245379
321
322 * Mon Jun 25 2007 Karsten Hopp <karsten@redhat.com> 0.205-1
323 - really update pci.ids, update-pciids downloaded an old file
324 - disable iwl4965 blacklist as it is not approved yet (#245379)
325
326 * Mon Jun 25 2007 Karsten Hopp <karsten@redhat.com> 0.202-1
327 - don't load iwl4965 module automatically
328 - Resolves: #245379
329
330 * Tue Jun 19 2007 Karsten Hopp <karsten@redhat.com> 0.201-1
331 - add some monitors
332 - Resolves: #224511
333 - update pci.ids
334 - Related: #223105
335
336 * Tue Jan 02 2007 Karsten Hopp <karsten@redhat.com> 0.194-1
337 - Update to latest pci.ids/usb.ids for RHEL5
338 - Resolves: #220182
339   Add some Dell monitors to MonitorDB
340
341 * Mon Oct 09 2006 Phil Knirsch <pknirsch@redhat.com> - 0.191-1
342 - Update to latest pci.ids for RHEL5
343
344 * Thu Sep 21 2006 Adam Jackson <ajackson@redhat.com> - 0.190-1
345 - Add a description for the 'intel' driver.
346
347 * Mon Sep 18 2006 Phil Knirsch <pknirsch@redhat.com> - 0.189-1
348 - Updated usb.ids for FC6
349
350 * Mon Sep 11 2006 Phil Knirsch <pknirsch@redhat.com> - 0.188-1
351 - Update of pci.ids for FC6
352
353 * Thu Aug 31 2006 Adam Jackson <ajackson@redhat.com> - 0.187-1
354 - Fix sync ranges for Samsung SyncMaster 710N (#202344)
355
356 * Thu Aug 03 2006 Phil Knirsch <pknirsch@redhat.com> - 0.186-1
357 - Updated pci.ids once more.
358
359 * Tue Jul 25 2006 Phil Knirsch <pknirsch@redhat.com> - 0.185-1
360 - Added the 17inch Philips LCD monitor entry (#199828)
361
362 * Mon Jul 24 2006 Phil Knirsch <pknirsch@redhat.com> - 0.184-1
363 - Added one more entry for missing Philips LCD monitor (#199828)
364
365 * Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 0.183-1
366 - Updated pci.ids before FC6 final (#198994)
367 - Added several missing Samsung monitors (#197463)
368 - Included a new inf2mondb.py from Matt Domsch (#158723)
369
370 * Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> - 0.182-1
371 - Added ast driver description to videodrivers
372 - Numerous Dell monitor additions (#196734)
373 - Numerous Belinea monitor additions (#198087)
374
375 * Sat Jul  8 2006 Adam Jackson <ajackson@redhat.com> - 0.181-1
376 - Updated videodrivers to mention i945
377 - New monitors: Sony CPD-G420 (#145902), Compaq P1110 (#155120).
378
379 * Thu May 11 2006 Phil Knirsch <pknirsch@redhat.com> - 0.180-1
380 - Updated and added some MonitorsDB entries
381
382 * Tue May 02 2006 Phil Knirsch <pknirsch@redhat.com> - 0.179-1
383 - Updated PCI ids from upstream (#180402)
384 - Fixed missing monitor entry in MonitorsDB (#189446)
385
386 * Wed Mar 01 2006 Phil Knirsch <pknirsch@redhat.com> - 0.178-1
387 - Commented out the VT lines at the end of usb.ids as our tools don't handle
388   them properly.
389
390 * Fri Feb 24 2006 Bill Nottingham <notting@redhat.com> - 0.177-1
391 - remove stock videoaliases in favor of driver-specific ones in
392   the X driver packages
393
394 * Wed Feb 22 2006 Phil Knirsch <pknirsch@redhat.com> - 0.176-1
395 - More entries from Dell to MonitorsDB (#181008)
396
397 * Fri Feb 10 2006 Phil Knirsch <pknirsch@redhat.com> - 0.175-1
398 - Added a few more entries to MonitorsDB
399
400 * Wed Feb 01 2006 Phil Knirsch <pknirsch@redhat.com> - 0.174-1
401 - Some cleanup and adds to the MonitorDB which closes several db related bugs.
402
403 * Tue Dec 13 2005 Bill Nottingham <notting@redhat.com> - 0.173-1
404 - add some IDs to the generic display entries for matching laptops
405
406 * Fri Nov 18 2005 Bill Nottingham <notting@redhat.com> - 0.172-1
407 - ditto for radeon
408
409 * Fri Nov 18 2005 Jeremy Katz <katzj@redhat.com> - 0.171-1
410 - r128 -> ati.  should fix the unresolved symbol and kem says its more 
411   generally the "right" thing to do
412
413 * Wed Nov 16 2005 Bill Nottingham <notting@redhat.com> - 0.170-1
414 - handle mptsas for migration as well
415 - move videoaliases file to a subdir
416
417 * Fri Sep 16 2005 Bill Nottingham <notting@redhat.com>
418 - add Iiyama monitor (#168143)
419
420 * Tue Sep 13 2005 Bill Nottingham <notting@redhat.com>
421 - add IBM monitor (#168080)
422
423 * Thu Sep  8 2005 Bill Nottingham <notting@redhat.com> - 0.169-1
424 - remove Cards, pcitable. Add videodrivers
425
426 * Fri Sep  2 2005 Dan Williams <dcbw@redhat.com> - 0.168-1
427 - Add more Gateway monitors
428
429 * Fri Sep  2 2005 Dan Williams <dcbw@redhat.com> - 0.167-1
430 - Add some ADI monitors, one BenQ, and and DPMS codes for two Apples
431
432 * Fri Sep  2 2005 Bill Nottingham <notting@redhat.com> - 0.166-1
433 - add videoaliases file
434 - remove CardMonitorCombos, as nothing uses it
435
436 * Thu Aug 25 2005 Dan Williams <dcbw@redhat.com> - 0.165-1
437 - Add a bunch of Acer monitors
438
439 * Tue Aug  9 2005 Jeremy Katz <katzj@redhat.com> - 0.164-1
440 - migrate sk98lin -> skge
441
442 * Sat Jul 30 2005 Bill Nottingham <notting@redhat.com>
443 - migrate mpt module names (#161420)
444 - remove pcitable entries for drivers in modules.pcimap
445 - switch lone remaining 'Server' entry - that can't work right
446
447 * Tue Jul 26 2005 Bill Nottingham <notting@redhat.com>
448 - add Daytek monitor (#164339)
449
450 * Wed Jul 13 2005 Bill Nottingham <notting@redhat.com> - 0.162-1
451 - remove /etc/pcmcia/config, conflict with pcmcia-cs
452
453 * Thu Jul  7 2005 Bill Nottingham <notting@redhat.com> - 0.160-1
454 - move blacklist to /etc/modprobe.d, require new module-init-tools
455 - add LG monitors (#162466, #161734)
456 - add orinoco card (#161696)
457 - more mptfusion stuff (#107088)
458
459 * Thu Jun 23 2005 Bill Nottingham <notting@redhat.com>
460 - add Samsung monitor (#161013)
461
462 * Wed Jun 22 2005 Bill Nottingham <notting@redhat.com> - 0.159-1
463 - pcitable: make branding happy (#160047)
464 - Cards: add required blank line (#157972)
465 - add some monitors
466 - add JVC CD-ROM (#160907, <richard@rsk.demon.co.uk>)
467 - add hisax stuff to blacklist (#154799, #159068)
468
469 * Mon May 16 2005 Bill Nottingham <notting@redhat.com> - 0.158-1
470 - add a orinoco card (#157482)
471
472 * Thu May  5 2005 Jeremy Katz <katzj@redhat.com> - 0.157-1
473 - add 20" Apple Cinema Display
474
475 * Sun Apr 10 2005 Mike A. Harris <mharris@redhat.com> 0.156-1
476 - Update SiS entries in Cards/pcitable to match what Xorg X11 6.8.2 supports
477
478 * Wed Mar 30 2005 Dan Williams <dcbw@redhat.com> 0.155-1
479 - Add a boatload of BenQ, Acer, Sony, NEC, Mitsubishi, and Dell monitors
480
481 * Wed Mar 30 2005 Dan Williams <dcbw@redhat.com> 0.154-1
482 - Add Typhoon Speednet Wireless PCMCIA Card mapping to atmel_cs driver
483
484 * Mon Mar 28 2005 Bill Nottingham <notting@redhat.com> 0.153-1
485 - update the framebuffer blacklist
486
487 * Wed Mar  9 2005 Bill Nottingham <notting@redhat.com> 0.152-1
488 - fix qlogic driver mappings, add upgradelist mappings for the modules
489   that changed names (#150621)
490
491 * Wed Mar  2 2005 Mike A. Harris <mharris@redhat.com> 0.151-1
492 - Added one hundred billion new nvidia PCI IDs to pcitable and Cards to
493   synchronize it with X.Org X11 6.8.2.  (#140601)
494
495 * Tue Jan 11 2005 Dan Williams <dcbw@redhat.com> - 0.150-1
496 - Add Dell UltraSharp 1704FPV (Analog & Digital)
497
498 * Sun Nov 21 2004 Bill Nottingham <notting@redhat.com> - 0.148-1
499 - add Amptron monitors (#139142)
500
501 * Wed Nov 10 2004 Bill Nottingham <notting@redhat.com> - 0.147-1
502 - update usb.ids (#138533)
503 - migrate dpt_i2o to i2o_block (#138603)
504
505 * Tue Nov  9 2004 Bill Nottingham <notting@redhat.com> - 0.146-1
506 - update pci.ids (#138233)
507 - add Apple monitors (#138481)
508
509 * Wed Oct 20 2004 Bill Nottingham <notting@redhat.com> - 0.145-1
510 - remove ahci mappings, don't prefer it over ata_piix
511
512 * Tue Oct 19 2004 Kristian Høgsberg <krh@redhat.com> - 0.144-1
513 - update IDs for Cirrus, Trident, C&T, and S3
514
515 * Tue Oct 12 2004 Bill Nottingham <notting@redhat.com> - 0.143-1
516 - add ahci mappings to prefer it over ata_piix
517 - map davej's ancient matrox card to vesa (#122750)
518
519 * Thu Oct  7 2004 Dan Williams <dcbw@redhat.com> - 0.141-1
520 - Add Belkin F5D6020 ver.2 (802.11b card based on Atmel chipset)
521
522 * Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> - 0.140-1
523 - include /etc/hotplug/blacklist here
524
525 * Thu Sep 30 2004 Bill Nottingham <notting@redhat.com> - 0.136-1
526 - add S3 UniChrome (#131403)
527 - update pci.ids
528
529 * Thu Sep 23 2004 Bill Nottingham <notting@redhat.com> - 0.135-1
530 - megaraid -> megaraid_mbox
531
532 * Wed Sep 22 2004 Bill Nottingham <notting@redhat.com> - 0.134-1
533 - map ncr53c8xx to sym53c8xx (#133181)
534
535 * Fri Sep 17 2004 Bill Nottingham <notting@redhat.com> - 0.132-1
536 - fix 3Ware 9000 mapping (#132851)
537
538 * Tue Sep 14 2004 Kristian Høgsberg <krh@redhat.com> - 0.131-1
539 - Add python script to check sorting of pci.ids
540
541 * Thu Sep  9 2004 Kristian Høgsberg <krh@redhat.com> 0.131-1
542 - Add pci ids and cards for new ATI, NVIDIA and Intel cards
543
544 * Sat Sep  4 2004 Bill Nottingham <notting@redhat.com> 0.130-1
545 - trim pcitable - now just ids/drivers
546
547 * Wed Sep  1 2004 Bill Nottingham <notting@redhat.com> 0.125-1
548 - pci.ids updates
549 - remove updsftab.conf.*
550
551 * Sun Aug 29 2004 Mike A. Harris <mharris@redhat.com>  0.124-1
552 - Updates to pcitable/Cards for 'S3 Trio64 3D' cards. (#125866,59956)
553
554 * Fri Jul  9 2004 Mike A. Harris <mharris@redhat.com>  0.123-1
555 - Quick pcitable/Cards update for ATI Radeon and FireGL boards
556
557 * Mon Jun 28 2004 Bill Nottingham <notting@redhat.com>
558 - add Proview monitor (#125853)
559 - add ViewSonic monitor (#126324)
560 - add a Concord camera (#126673)
561
562 * Wed Jun 23 2004 Brent Fox <bfox@redhat.com> - 0.122-1
563 - Add Vobis monitor to MonitorsDB (bug #124151)
564
565 * Wed Jun 09 2004 Dan Williams <dcbw@redhat.com> - 0.121-1
566 - add Belkin F5D5020 10/100 PCMCIA card (#125581)
567
568 * Fri May 28 2004 Bill Nottingham <notting@redhat.com>
569 - add modem (#124663)
570
571 * Mon May 24 2004 Bill Nottingham <notting@redhat.com> - 0.120-1
572 - mainly:
573   fix upgradelist module for CMPci cards (#123647)
574 - also:
575   add another wireless card (#122676)
576   add wireless card (#122625)
577   add 1280x800 (#121548)
578   add 1680x1050 (#121148)
579   add IntelligentStick (#124313)
580
581 * Mon May 10 2004 Jeremy Katz <katzj@redhat.com> - 0.119-1
582 - veth driver is iseries_veth in 2.6
583
584 * Wed May  5 2004 Jeremy Katz <katzj@redhat.com> - 0.118-1
585 - add a wireless card (#122064)
586 - and a monitor (#121696)
587
588 * Fri Apr 16 2004 Bill Nottingham <notting@redhat.com> 0.117-1
589 - fix makefile
590
591 * Thu Apr 15 2004 Bill Nottingham <notting@redhat.com> 0.116-1
592 - move updfstab.conf here
593 - add wireless card (#116865)
594 - add laptop display panel (#117385)
595 - add clipdrive (#119928)
596 - add travelling disk (#119143)
597 - add NEXDISK (#106782)
598
599 * Thu Apr 15 2004 Brent Fox <bfox@redhat.com> 0.115-1
600 - replace snd-es1960 driver with snd-es1968 in pcitable (bug #120729)
601
602 * Mon Mar 29 2004 Bill Nottingham <notting@redhat.com> 0.114-1
603 - fix entries pointing to Banshee (#119388)
604
605 * Tue Mar 16 2004 Bill Nottingham <notting@redhat.com> 0.113-1
606 - add a Marvell sk98lin card (#118467, <64bit_fedora@comcast.net>)
607
608 * Fri Mar 12 2004 Brent Fox <bfox@redhat.com> 0.112-1
609 - add a Sun flat panel to MonitorsDB (bug #118138)
610
611 * Fri Mar  5 2004 Brent Fox <bfox@redhat.com> 0.111-1
612 - add Samsung monitor to MonitorsDB (bug #112112)
613
614 * Mon Mar  1 2004 Mike A. Harris <mharris@redhat.com> 0.110-1
615 - Added 3Dfx Voodoo Graphics and Voodoo II entries to the Cards database, both
616   pointing to Alan Cox's new "voodoo" driver which is now included in XFree86
617   4.3.0-62 and later builds in Fedora development.  Mapped their PCI IDs to
618   the new Cards entry in pcitable.
619 - Updated the entries for 3Dfx Banshee
620
621 * Mon Feb 23 2004 Bill Nottingham <notting@redhat.com> 0.109-1
622 - pci.ids and other updates
623
624 * Thu Feb 19 2004 Mike A. Harris <mharris@redhat.com> 0.108-1
625 - Added Shamrock C407L to MonitorsDB for bug (#104920)
626
627 * Thu Feb 19 2004 Mike A. Harris <mharris@redhat.com> 0.107-1
628 - Massive Viewsonic monitor update for MonitorsDB (#84882)
629
630 * Fri Feb 13 2004 John Dennis <jdennis@finch.boston.redhat.com> 0.106-1
631 - fix typo, GP should have been HP
632
633 * Thu Jan 29 2004 Bill Nottingham <notting@redhat.com> 0.105-1
634 - many monitor updates (#114260, #114216, #113993, #113932, #113782,
635   #113685, #113523, #111203, #107788, #106526, #63005)
636 - add some PCMCIA cards (#113006, #112505)
637
638 * Tue Jan 20 2004 Bill Nottingham <notting@redhat.com> 0.104-1
639 - switch sound module mappings to alsa drivers
640
641 * Mon Jan 19 2004 Brent Fox <bfox@redhat.com> 0.103-1
642 - fix tab spacing
643
644 * Fri Jan 16 2004 Brent Fox <bfox@redhat.com> 0.102-1
645 - added an entry for ATI Radeon 9200SE (bug #111306)
646
647 * Sun Oct 26 2003 Jeremy Katz <katzj@redhat.com> 0.101-1
648 - add 1920x1200 Generic LCD as used on some Dell laptops (#108006)
649
650 * Thu Oct 16 2003 Brent Fox <bfox@redhat.com> 0.100-1
651 - add entry for Sun (made by Samsung) monitor (bug #107128)
652
653 * Tue Sep 23 2003 Mike A. Harris <mharris@redhat.com> 0.99-1
654 - Added entries for Radeon 9600/9600Pro/9800Pro to Cards
655 - Fixed minor glitch in pcitable for Radeon 9500 Pro
656
657 * Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 0.98-1
658 - add VMWare display adapter pci id and map to vmware X driver
659
660 * Thu Sep 11 2003 Bill Nottingham <notting@redhat.com> 0.97-1
661 - bcm4400 -> b44
662
663 * Sun Sep  7 2003 Bill Nottingham <notting@redhat.com> 0.96-1
664 - fix provided Dell tweaks (#103892)
665
666 * Fri Sep  5 2003 Bill Nottingham <notting@redhat.com> 0.95-1
667 - Dell tweaks (#103861)
668
669 * Fri Sep  5 2003 Bill Nottingham <notting@redhat.com> 0.94-1
670 - add adaptec pci id (#100844)
671
672 * Thu Sep  4 2003 Brent Fox <bfox@redhat.com> 0.93-1
673 - add an SGI monitor for bug (#74870)
674
675 * Wed Aug 27 2003 Bill Nottingham <notting@redhat.com> 0.92-1
676 - updates from sourceforge.net pci.ids, update pcitable accordingly
677
678 * Mon Aug 18 2003 Mike A. Harris <mharris@redhat.com> 0.91-1
679 - Added HP monitors for bug (#102495)
680
681 * Fri Aug 15 2003 Brent Fox <bfox@redhat.com> 0.90-1
682 - added a sony monitor (bug #101550)
683
684 * Tue Jul 15 2003 Bill Nottingham <notting@redhat.com> 0.89-1
685 - updates from modules.pcimap
686
687 * Sat Jul 12 2003 Mike A. Harris <mharris@redhat.com> 0.88-1
688 - Update MonitorsDB for new IBM monitors from upstream XFree86 bugzilla:
689   http://bugs.xfree86.org/cgi-bin/bugzilla/show_bug.cgi?id=459
690
691 * Mon Jun  9 2003 Bill Nottingham <notting@redhat.com> 0.87-1
692 - fusion update
693
694 * Mon Jun  9 2003 Jeremy Katz <katzj@redhat.com> 0.86-1
695 - pci id for ata_piix
696
697 * Wed Jun  4 2003 Brent Fox <bfox@redhat.com> 0.85-1
698 - correct entry for Dell P991 monitor
699
700 * Tue Jun  3 2003 Bill Nottingham <notting@redhat.com> 0.84-1
701 - fix qla2100 mapping (#91476)
702 - add dell mappings (#84069)
703
704 * Mon Jun  2 2003 John Dennis <jdennis@redhat.com>
705 - Add new Compaq and HP monitors - bug 90570, bug 90707, bug 90575, IT 17231
706
707 * Wed May 21 2003 Brent Fox <bfox@redhat.com> 0.81-1
708 - add an entry for SiS 650 video card (bug #88271)
709
710 * Wed May 21 2003 Michael Fulbright <msf@redhat.com> 0.80-1
711 - Changed Generic monitor entries in MonitorsDB to being in LCD and CRT groups
712
713 * Tue May 20 2003 Bill Nottingham <notting@redhat.com> 0.79-1
714 - pci.ids and usb.ids updates
715
716 * Tue May  6 2003 Brent Fox <bfox@redhat.com> 0.78-1
717 - added a Samsung monitor to MonitorsDB
718
719 * Fri May  2 2003 Bill Nottingham <notting@redhat.com>
720 - add Xircom wireless airo_cs card (#90099)
721
722 * Fri Apr 18 2003 Jeremy Katz <katzj@redhat.com> 0.77-1
723 - add generic framebuffer to Cards
724
725 * Mon Mar 17 2003 Mike A. Harris <mharris@redhat.com> 0.76-1
726 - Updated MonitorsDb for Dell monitors (#86072)
727
728 * Tue Feb 18 2003 Mike A. Harris <mharris@redhat.com> 0.75-1
729 - Change savage MX and IX driver default back to "savage" for the 1.1.27t
730   driver update
731   
732 * Tue Feb 18 2003 Brent Fox <bfox@redhat.com> 0.74-1
733 - Use full resolution description for Dell laptop screens (bug #80398)
734
735 * Thu Feb 13 2003 Mike A. Harris <mharris@redhat.com> 0.73-1
736 - Updated pcitable and Cards database to fix Savage entries up a bit, and
737   change default Savage/MX driver to 'vesa' as it is hosed and with no sign
738   of working in time for 4.3.0.  Fixes (#72476,80278,80346,80423,82394)
739
740 * Wed Feb 12 2003 Brent Fox <bfox@redhat.com> 0.72-1
741 - slightly alter the sync rates for the Dell 1503FP (bug #84123)
742
743 * Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 0.71-1
744 - large pcitable and pci.ids updates
745 - more tg3, e100
746
747 * Mon Feb 10 2003 Mike A. Harris <mharris@redhat.com> 0.69-1
748 - Updated pcitable and Cards database for new Intel i852/i855/i865 support
749
750 * Mon Feb 10 2003 Mike A. Harris <mharris@redhat.com> 0.68-1
751 - Massive update of all ATI video hardware PCI IDs in pcitable and a fair
752   number of additions and corrections to the Cards database as well
753   
754 * Wed Jan 29 2003 Brent Fox <bfox@redhat.com> 0.67-1
755 - change refresh rates of sny0000 monitors to use a low common denominator
756
757 * Wed Jan 29 2003 Bill Nottingham <notting@redhat.com> 0.66-1
758 - don't force DRI off on R200 (#82957)
759
760 * Fri Jan 24 2003 Mike A. Harris <mharris@redhat.com> 0.65-1
761 - Added Card:S3 Trio64V2 (Unsupported RAMDAC) entry to pcitable, pci.ids, and
762   Cards database to default this particular variant to "vesa" driver (#81659)
763
764 * Thu Jan  2 2003 Bill Nottingham <notting@redhat.com> 0.64-1
765 - pci.ids and associated pcitable updates
766
767 * Sun Dec 29 2002 Mike A. Harris <mharris@redhat.com> 0.63-1
768 - Updates for GeForce 2 Go, GeForce 4 (#80209)
769
770 * Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.62-2
771 - fix Cards for NatSemi Geode
772
773 * Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.62-1
774 - use e100 instead of eepro100 for pcmcia
775
776 * Mon Nov 25 2002 Mike A. Harris <mharris@redhat.com>
777 - Complete reconstruction of all Neomagic hardware entries in Cards
778   database to reflect current XFree86, as well as pcitable update,
779   and submitted cleaned up entries to sourceforge
780
781 * Mon Nov  4 2002 Bill Nottingham <notting@redhat.com> 0.61-1
782 - move pcmcia config file here
783 - sort MonitorsDB, add some entries, remove dups
784 - switch some network driver mappings
785
786 * Tue Sep 24 2002 Bill Nottingham <notting@redhat.com> 0.48-1
787 - broadcom 5704 mapping
788 - aic79xx (#73781)
789
790 * Thu Sep  5 2002 Bill Nottingham <notting@redhat.com> 0.47-1
791 - pci.ids updates
792 - add msw's wireless card
793
794 * Tue Sep  3 2002 Jeremy Katz <katzj@redhat.com> 0.46-1
795 - Card entries in pcitable need matching in Cards
796
797 * Sun Sep  1 2002 Mike A. Harris <mharris@redhat.com> 0.45-1
798 - Update G450 entry in Cards
799
800 * Tue Aug 13 2002 Bill Nottingham <notting@redhat.com> 0.44-1
801 - fix some of the Dell entries
802 - add cardbus controller id (#71198)
803 - add audigy mapping
804 - add NEC monitor (#71320)
805
806 * Tue Aug 13 2002 Preston Brown <pbrown@redhat.com> 0.43-1
807 - pci.id for SMC wireless PCI card (#67346)
808
809 * Sat Aug 10 2002 Mike A. Harris <mharris@redhat.com> 0.42-1
810 - Change default driver for old S3 based "Miro" card for bug (#70743)
811
812 * Fri Aug  9 2002 Preston Brown <pbrown@redhat.com> 0.41-1
813 - fix tabs in pci.ids
814 - Change pci ids for the PowerEdge 4 series again...
815
816 * Tue Aug  6 2002 Preston Brown <pbrown@redhat.com> 0.39-1
817 - Dell PERC and SCSI pci.id additions
818
819 * Tue Aug  6 2002 Mike A. Harris <mharris@redhat.com> 0.38-1
820 - Removed and/or invalid entries from Cards database BLOCKER (#70802)
821
822 * Mon Aug  5 2002 Mike A. Harris <mharris@redhat.com> 0.37-1
823 - Changed Matrox G450 driver default options to fix bug (#66697)
824 - Corrected S3 Trio64V2 bug in Cards file (#66492)
825
826 * Tue Jul 30 2002 Bill Nottingham <notting@redhat.com> 0.36-1
827 - tweaks for Dell Remote Assisstant cards (#60376)
828
829 * Fri Jul 26 2002 Mike A. Harris <mharris@redhat.com> 0.35-1
830 - Updated Cards db for CT69000
831 - Various ATI cleanups and additions to Cards and pcitable
832 - Updated S3 Trio3D to default to "vesa" driver (#59956)
833
834 * Tue Jul 23 2002 Bill Nottingham <notting@redhat.com> 0.33-1
835 - Eizo monitor updates (#56080, <triad@df.lth.se>)
836 - pci.ids updates, corresponding pcitable updates
837 - pcilint for pcitable 
838
839 * Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 0.32-1
840 - switch de4x5 back to tulip
841
842 * Mon Jun 24 2002 Mike A. Harris <mharris@redhat.com> 0.31-1
843 - Modified ATI entries in pcitable to be able to autodetect the FireGL 8700
844   and FireGL 8800 which both have the same ID, but different subdevice ID's.
845   Added entries to Cards database for the 8700/8800 as well.
846
847 * Tue May 28 2002 Mike A. Harris <mharris@redhat.com> 0.30-1
848 - Reconfigured Cards database to default to XFree86 4.x for ALL video
849   hardware, since 3.3.6 support is being removed.  Video cards not
850   supported natively by 4.x will be changed to use the vesa or vga
851   driver, or completely removed as unsupported.
852
853 * Wed Apr 17 2002 Michael Fulbright <msf@redhat.com> 0.14-1
854 - another megaraid variant
855
856 * Mon Apr 15 2002 Michael Fulbright <msf@redhat.com> 0.13-1
857 - fix monitor entry for Dell 1600X Laptop Display Panel
858
859 * Fri Apr 12 2002 Bill Nottingham <notting@redhat.com> 0.13-1
860 - more aacraid
861
862 * Tue Apr  9 2002 Bill Nottingham <notting@redhat.com> 0.12-1
863 - another 3ware, another megaraid
864
865 * Fri Apr  5 2002 Mike A. Harris <mharris@redhat.com> 0.11-1
866 - Added commented out line for some Radeon 7500 cards to Cards database.
867
868 * Tue Apr  2 2002 Mike A. Harris <mharris@redhat.com> 0.10-1
869 - Fixed i830 entry to use driver "i810" not "i830" which doesn't exist
870
871 * Mon Apr  1 2002 Bill Nottingham <notting@redhat.com> 0.9-1
872 - fix rebuild (#62459)
873 - SuperSavage ids (#62101)
874 - updates from pci.ids
875
876 * Mon Mar 18 2002 Bill Nottingham <notting@redhat.com> 0.8-2
877 - fix errant space (#61363)
878
879 * Thu Mar 14 2002 Bill Nottingham <notting@redhat.com> 0.8-1
880 - nVidia updates
881
882 * Wed Mar 13 2002 Bill Nottingham <notting@redhat.com> 0.7-1
883 - lots of pcitable updates
884
885 * Tue Mar  5 2002 Mike A. Harris <mharris@redhat.com> 0.6-1
886 - Updated Cards database
887
888 * Mon Mar  4 2002 Mike A. Harris <mharris@redhat.com> 0.5-1
889 - Built new package with updated database files for rawhide.
890
891 * Fri Feb 22 2002 Bill Nottingham <notting@redhat.com> 0.3-1
892 - return of XFree86-3.3.x
893
894 * Wed Jan 30 2002 Bill Nottingham <notting@redhat.com> 0.1-1
895 - initial build