spec: added BR perl(Date::Format)
[oweals/hwdata.git] / hwdata.spec
1 # This package is arch-specific just because of bundling different files for
2 # different architectures. No -debuginfo package is needed.
3 %global     debug_package %{nil}
4 %global     uprelease   8.1
5
6 Name:       hwdata
7 Summary:    Hardware identification and configuration data
8 Version:    0.252
9 Release:    %{uprelease}%{?dist}
10 License:    GPLv2+
11 Group:      System Environment/Base
12 Source0:    https://fedorahosted.org/releases/h/w/%{name}/%{name}-%{version}-%{uprelease}.tar.bz2
13 URL:        http://git.fedorahosted.org/git/hwdata.git
14
15 BuildRequires   : perl
16 BuildRequires   : perl(Date::Format)
17
18 Requires        : systemd
19 Requires(post)  : systemd
20 Requires(postun): systemd
21
22 %description
23 hwdata contains various hardware identification and configuration data,
24 such as the pci.ids and usb.ids databases.
25
26 %prep
27 %setup -q -n %{name}-%{version}-%{uprelease}
28 %ifarch ppc ppc64
29 patch -b -B nx_crypto -p1 < blacklist-nx_crypto.patch
30 %endif
31 %configure
32
33 %build
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_prefix}/lib
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %post
43 udevadm hwdb --update >/dev/null 2>&1 || :
44
45 %postun
46 udevadm hwdb --update >/dev/null 2>&1 || :
47
48 %files
49 %doc LICENSE COPYING
50 %dir %{_datadir}/%{name}
51 %{_prefix}/lib/modprobe.d/dist-blacklist.conf
52 %{_prefix}/lib/udev/hwdb.d/[0-9][0-9]-*.hwdb
53 %{_datadir}/%{name}/*
54
55 %changelog
56 * Fri Oct 23 2015 Michal Minar <miminar@redhat.com> 0.252-8.1
57 - Updated pci, usb and vendor ids.
58 - Resolves: rhbz#1236458
59 - Resolves: rhbz#1256004
60 - Resolves: rhbz#1266217
61 - Resolves: rhbz#1271797
62
63 * Mon Jun 29 2015 Michal Minar <miminar@redhat.com> 0.252-7.9
64 - Updated pci, usb and vendor ids.
65
66 * Tue Apr 14 2015 Michal Minar <miminar@redhat.com> 0.252-7.8
67 - Blacklisted module nx_crypto on PowerPCs.
68 - Resolves: rhbz#1211389
69 - Disable debuginfo build.
70
71 * Fri Apr 10 2015 Michal Minar <miminar@redhat.com> 0.252-7.6
72 - Blacklisted experimental module sha1-mb.
73 - Resolves: rhbz#1208120
74
75 * Fri Jan 30 2015 Michal Minar <miminar@redhat.com> 0.252-7.5
76 - Updated vendor, usb and pci ids.
77
78 * Mon Sep 22 2014 Michal Minar <miminar@redhat.com> 0.252-7.4
79 - Updated vendor, usb and pci ids.
80
81 * Thu Mar 27 2014 Michal Minar <miminar@redhat.com> 0.252-7.3
82 - Added few more hwdb files.
83 - Updated vendor and pci ids.
84
85 * Thu Mar 20 2014 Michal Minar <miminar@redhat.com> 0.252-7.1
86 - Bumped release to reflect rhel version.
87 - Fixed bogus dates in changelog.
88 - Generate and install hwdb.d/* files.
89
90 * Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 0.252-3
91 - Mass rebuild 2013-12-27
92
93 * Mon Aug 5 2013 Michal Minar <miminar@redhat.com> 0.252-2
94 - Changelog fix.
95
96 * Sun Jul 21 2013 Michal Minar <miminar@redhat.com> 0.252-1
97 - Data files update.
98
99 * Sat Jul 06 2013 Michal Minar <miminar@redhat.com> 0.250-1
100 - Data files update.
101
102 * Thu Jun 20 2013 Michal Minar <miminar@redhat.com> 0.249-1
103 - Data files update, pnp.ids included.
104
105 * Thu Apr 18 2013 Michal Minar <miminar@redhat.com> 0.248-1
106 - Data files update
107
108 * Wed Mar 27 2013 Michal Minar <miminar@redhat.com> 0.247-1
109 - Moved blacklist.conf from /etc/modprobe.d to /usr/lib/modprobe.d.
110 - Renamed it to dist-blacklist.conf.
111 - Data files update
112
113 * Mon Mar 18 2013 Michal Minar <miminar@redhat.com> 0.245-1
114 - Data files update
115
116 * Mon Feb 18 2013 Michal Minar <miminar@redhat.com> 0.244-1
117 - Data files updated
118
119 * Fri Jan 18 2013 Michal Minar <miminar@redhat.com> 0.243-1
120 - Data files updated
121
122 * Fri Dec 07 2012 Michal Minar <miminar@redhat.com> 0.242-1
123 - Update data files
124
125 * Wed Nov 07 2012 Michal Minar <miminar@redhat.com> 0.241-1
126 - Update data files
127
128 * Wed Sep 26 2012 Michal Minar <miminar@redhat.com> 0.240-1
129 - made use of configure script in prep
130
131 * Tue Sep 25 2012 Michal Minar <miminar@redhat.com> 0.239-1
132 - Update data files
133
134 * Thu Aug 23 2012 Adam Jackson <ajax@redhat.com> 0.238-1
135 - Fix reference specfile to current Fedora style
136
137 * Thu Aug 23 2012 Adam Jackson <ajax@redhat.com> 0.235-1
138 - Update data files
139 - Remove upgradelist, not needed since kudzu-ectomy
140
141 * Mon Aug 08 2011 Karsten Hopp <karsten@redhat.com> 0.233-7.3
142 - update pci.ids, usb. ids
143
144 * Mon May 02 2011 Karsten Hopp <karsten@redhat.com> 0.233-7.2
145 - update pci.ids with a fix for QLogic Infiniband adapter
146
147 * Wed Apr 27 2011 Karsten Hopp <karsten@redhat.com> 0.233-7.1
148 - update to latest pci.ids, usb.ids
149
150 * Fri Jan 28 2011 Karsten Hopp <karsten@redhat.com> 0.233-7
151 - bump release
152 - update oui.txt URL
153 - fix tarball name in spec file
154 - update usb.ids, out.txt and pci.ids
155
156 * Wed Aug 25 2010 Karsten Hopp <karsten@redhat.com> 0.233-1
157 - update usb.ids, out.txt and pci.ids
158
159 * Thu Aug 05 2010 Karsten Hopp <karsten@redhat.com> 0.232-1
160 - update usb.ids, out.txt and pci.ids (#550020, #611860)
161 - fix incorrect syntax doc/comment in blacklist.conf (Ville Skyttä, #532802)
162 - add Acer B243HL and BenQ G2420HDBL (Ville Skyttä, #590787)
163 - add HP LP2475w and Samsung 2494HM (Ville Skyttä, #595059)
164
165 * Tue May 25 2010 Phil Knirsch <pknirsch@redhat.com> 0.230-1
166 - update usb.ids, out.txt and pci.ids
167 - Resolves: #584788
168
169 * Mon Mar 29 2010 Karsten Hopp <karsten@redhat.com> 0.229-1
170 - update usb.ids, out.txt and pci.ids for F-13 (#571914)
171
172 * Wed Mar 17 2010 Phil Knirsch <pknirsch@redhat.com> 0.228-1
173 - Blacklist chsc_sch for s390x
174 - Resolves: #563228
175
176 * Tue Feb 23 2010 Dave Airlie <airlied@redhat.com> 0.227-1
177 - add viafb to blacklist
178
179 * Mon Feb 22 2010 Karsten Hopp <karsten@redhat.com> 0.227-1
180 - update usb.ids, pci.ids, oui.txt
181 - update license
182
183 * Fri Jan 15 2010 Karsten Hopp <karsten@redhat.com> 0.226-1
184 - update release number
185
186 * Fri Jan 15 2010 Karsten Hopp <karsten@redhat.com> 0.225-4
187 - update usb.ids pci.ids oui.txt
188
189 * Mon Nov 30 2009 Dennis Gregorovic <dgregor@redhat.com> - 0.225-3.1
190 - Rebuilt for RHEL 6
191
192 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.225-3
193 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
194
195 * Tue Jul 07 2009 Adam Jackson <ajax@redhat.com> 0.225-2
196 - pnp-dell.patch: Fix Dell's entry in pnp.ids
197
198 * Thu Apr 09 2009 Adam Jackson <ajax@redhat.com> 0.224-1
199 - Update pci.ids, usb.ids, and oui.txt
200 - Add pnp.ids
201
202 * Thu Mar 19 2009 Karsten Hopp <karsten@redhat.com> 0.223-1
203 - update usb.ids pci.ids oui.txt
204 - rename /etc/modprobe.d/blacklist to /etc/modprobe.d/blacklist.conf
205
206 * Wed Jan 28 2009 Karsten Hopp <karsten@redhat.com> 0.222-1
207 - update usb.ids pci.ids oui.txt and build for all current releases
208   Fixes p.e. #465440
209
210 * Wed Jan 21 2009 Karsten Hopp <karsten@redhat.com> 0.221-1
211 - update usb.ids pci.ids oui.txt
212
213 * Tue Dec 02 2008 Karsten Hopp <karsten@redhat.com> 0.220-1
214 - add new monitor entries from Mandriva hardware database (Thierry Vignaud)
215 - make generic entries have properly formated frequencies (Thierry Vignaud)
216 - remove duplicate Dell monitor entries (Thierry Vignaud)
217 - more vendor name fixes
218 - fix extra field in 'Compudyne KD-1500N' definition (Thierry Vignaud)
219 - make Dell monitors case consistent (Thierry Vignaud)
220 - make all GoldStar monitors have the same vendor name (Thierry Vignaud)
221 - add URL of git repository
222 - fix spacing (Thierry Vignaud)
223 - sort MonitorDB file with LANG=C sort -f -t ";" -k1,2
224 - add Samsung SyncMaster 2443BWX (Marc van den Dikkenberg)
225 - add some Lenovo monitors (Im Sza)
226
227 * Wed Jul 23 2008 Karsten Hopp <karsten@redhat.com> 0.220-1
228 - update pci.ids, usb.ids, oui.txt
229 - MonitorsDB: add some Samsung monitors (Ronald Warsow)
230 - MonitorsDB: add Dell E1609W (Matt Domsch)
231 - MonitorsDB: add 7 Dell monitors (Matt Domsch)
232 - MonitorsDB: add a bunch of Hyundai and ImageQuest monitors
233
234 * Mon Jun 09 2008 Karsten Hopp <karsten@redhat.com> 0.219-1
235 - add BenQ FP2091 monitor (Peter Williams)
236 - add a bunch of Hyundai and ImageQuest monitors
237
238 * Mon Jun 02 2008 Karsten Hopp <karsten@redhat.com> 0.219-1
239 - update pci.ids, usb.ids, oui.txt
240 - blacklist snd-pcsp (#448425)
241
242 * Mon May 19 2008 Karsten Hopp <karsten@redhat.com> 0.218-1
243 - add some Acer monitors (Im Sz)
244
245 * Tue Apr 01 2008 Karsten Hopp <karsten@redhat.com> 0.217-1
246 - update pci.ids, oui.txt
247 - update usb.ids, fixes #439963
248 - add HP w1907 LCD monitor, fixes #431359
249 - fix many monitor entries (Stanislav Ievlev, #430276)
250
251
252 * Mon Mar 03 2008 Karsten Hopp <karsten@redhat.com> 0.216-1
253 - update pci.ids, usb.ids (#431658)
254
255 * Tue Jan 29 2008 Phil Knirsch <pknirsch@redhat.com> 0.215-1
256 - Pull new upstream pci.ids
257
258 * Wed Jan 23 2008 Karsten Hopp <karsten@redhat.com> 0.215-1
259 - add HP W2207 monitor
260 - add oui.txt, a list of bluetooth device makers
261
262 * Fri Jan 18 2008 Karsten Hopp <karsten@redhat.com> 0.214-1
263 - remove MonitorsDB.generic as it isn't used anywhere
264 - drop RHEL-5 blacklist patch in -devel
265
266 * Tue Jan 15 2008 Karsten Hopp <karsten@redhat.com> 0.213-1
267 - add many monitor entries (Im Sza, #367111)
268
269 * Fri Jan 11 2008 Karsten Hopp <karsten@redhat.com> 0.212-1
270 - pull new upstream pci.ids, usb.ids
271 - Resolves: #300831
272 - added HP TFT5600 LCD Monitor
273 - Resolves: #250569
274 - added Acer AL1916W, Eizo L568/L568D, Samsung 795DF
275 - Resolves: #250582
276 - Add Samsung 205BW/206BW/225BW/226BW
277 - Resolves: #250584
278 - Add Samsung 931BF
279 - Resolves: #250587
280
281 * Sat Dec 22 2007 Karsten Hopp <karsten@redhat.com> 0.209-1
282 - add Proview 926w monitor (#363091)
283
284 * Sat Dec 22 2007 Karsten Hopp <karsten@redhat.com> 0.208-1
285 - new release
286 - drop dell-monitors patch, already included in tarball
287
288 * Thu Dec 13 2007 Karsten Hopp <karsten@redhat.com> 0.207-3
289 - fix License tag
290 - add empty %%build section for fedora-review
291
292 * Thu Oct 25 2007 Matt Domsch <Matt_Domsch@dell.com> 0.207-2
293 - MonitorsDB: add 20 new Dell monitors
294
295 * Wed Sep 26 2007 Karsten Hopp <karsten@redhat.com> 0.211-1
296 - pull new upstream pci.ids, usb.ids
297
298 * Thu Sep 20 2007 Karsten Hopp <karsten@redhat.com> 0.210-1
299 - add pci.id for Chelsio 10GbE Ethernet Adapter
300 - Resolves: bz #296811
301
302 * Wed Sep 19 2007 Karsten Hopp <karsten@redhat.com> 0.209-1
303 - pull new upstream pci.ids, usb.ids
304
305 * Wed Aug 29 2007 Karsten Hopp <karsten@redhat.com> 0.207-1
306 - update license tag
307
308 * Wed Aug 15 2007 Karsten Hopp <karsten@redhat.com> 0.207-1
309 - pull new upstream pci.ids and rebuild
310 - Resolves: bz #251732
311 - Resolves: bz #251734
312 - Resolves: bz #252195
313 - Resolves: bz #252196
314 - Resolves: bz #241274
315
316 * Tue Aug 14 2007 Karsten Hopp <karsten@redhat.com> 0.205-1
317 - add HP TFT5600        #229370
318
319 * Mon Jul 09 2007 Karsten Hopp <karsten@redhat.com> 0.205-1
320 - enable iwl4965 blacklist
321 - Resolves: bz#245379
322
323 * Mon Jun 25 2007 Karsten Hopp <karsten@redhat.com> 0.205-1
324 - really update pci.ids, update-pciids downloaded an old file
325 - disable iwl4965 blacklist as it is not approved yet (#245379)
326
327 * Mon Jun 25 2007 Karsten Hopp <karsten@redhat.com> 0.202-1
328 - don't load iwl4965 module automatically
329 - Resolves: #245379
330
331 * Tue Jun 19 2007 Karsten Hopp <karsten@redhat.com> 0.201-1
332 - add some monitors
333 - Resolves: #224511
334 - update pci.ids
335 - Related: #223105
336
337 * Tue Jan 02 2007 Karsten Hopp <karsten@redhat.com> 0.194-1
338 - Update to latest pci.ids/usb.ids for RHEL5
339 - Resolves: #220182
340   Add some Dell monitors to MonitorDB
341
342 * Mon Oct 09 2006 Phil Knirsch <pknirsch@redhat.com> - 0.191-1
343 - Update to latest pci.ids for RHEL5
344
345 * Thu Sep 21 2006 Adam Jackson <ajackson@redhat.com> - 0.190-1
346 - Add a description for the 'intel' driver.
347
348 * Mon Sep 18 2006 Phil Knirsch <pknirsch@redhat.com> - 0.189-1
349 - Updated usb.ids for FC6
350
351 * Mon Sep 11 2006 Phil Knirsch <pknirsch@redhat.com> - 0.188-1
352 - Update of pci.ids for FC6
353
354 * Thu Aug 31 2006 Adam Jackson <ajackson@redhat.com> - 0.187-1
355 - Fix sync ranges for Samsung SyncMaster 710N (#202344)
356
357 * Thu Aug 03 2006 Phil Knirsch <pknirsch@redhat.com> - 0.186-1
358 - Updated pci.ids once more.
359
360 * Tue Jul 25 2006 Phil Knirsch <pknirsch@redhat.com> - 0.185-1
361 - Added the 17inch Philips LCD monitor entry (#199828)
362
363 * Mon Jul 24 2006 Phil Knirsch <pknirsch@redhat.com> - 0.184-1
364 - Added one more entry for missing Philips LCD monitor (#199828)
365
366 * Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 0.183-1
367 - Updated pci.ids before FC6 final (#198994)
368 - Added several missing Samsung monitors (#197463)
369 - Included a new inf2mondb.py from Matt Domsch (#158723)
370
371 * Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> - 0.182-1
372 - Added ast driver description to videodrivers
373 - Numerous Dell monitor additions (#196734)
374 - Numerous Belinea monitor additions (#198087)
375
376 * Sat Jul  8 2006 Adam Jackson <ajackson@redhat.com> - 0.181-1
377 - Updated videodrivers to mention i945
378 - New monitors: Sony CPD-G420 (#145902), Compaq P1110 (#155120).
379
380 * Thu May 11 2006 Phil Knirsch <pknirsch@redhat.com> - 0.180-1
381 - Updated and added some MonitorsDB entries
382
383 * Tue May 02 2006 Phil Knirsch <pknirsch@redhat.com> - 0.179-1
384 - Updated PCI ids from upstream (#180402)
385 - Fixed missing monitor entry in MonitorsDB (#189446)
386
387 * Wed Mar 01 2006 Phil Knirsch <pknirsch@redhat.com> - 0.178-1
388 - Commented out the VT lines at the end of usb.ids as our tools don't handle
389   them properly.
390
391 * Fri Feb 24 2006 Bill Nottingham <notting@redhat.com> - 0.177-1
392 - remove stock videoaliases in favor of driver-specific ones in
393   the X driver packages
394
395 * Wed Feb 22 2006 Phil Knirsch <pknirsch@redhat.com> - 0.176-1
396 - More entries from Dell to MonitorsDB (#181008)
397
398 * Fri Feb 10 2006 Phil Knirsch <pknirsch@redhat.com> - 0.175-1
399 - Added a few more entries to MonitorsDB
400
401 * Wed Feb 01 2006 Phil Knirsch <pknirsch@redhat.com> - 0.174-1
402 - Some cleanup and adds to the MonitorDB which closes several db related bugs.
403
404 * Tue Dec 13 2005 Bill Nottingham <notting@redhat.com> - 0.173-1
405 - add some IDs to the generic display entries for matching laptops
406
407 * Fri Nov 18 2005 Bill Nottingham <notting@redhat.com> - 0.172-1
408 - ditto for radeon
409
410 * Fri Nov 18 2005 Jeremy Katz <katzj@redhat.com> - 0.171-1
411 - r128 -> ati.  should fix the unresolved symbol and kem says its more 
412   generally the "right" thing to do
413
414 * Wed Nov 16 2005 Bill Nottingham <notting@redhat.com> - 0.170-1
415 - handle mptsas for migration as well
416 - move videoaliases file to a subdir
417
418 * Fri Sep 16 2005 Bill Nottingham <notting@redhat.com>
419 - add Iiyama monitor (#168143)
420
421 * Tue Sep 13 2005 Bill Nottingham <notting@redhat.com>
422 - add IBM monitor (#168080)
423
424 * Thu Sep  8 2005 Bill Nottingham <notting@redhat.com> - 0.169-1
425 - remove Cards, pcitable. Add videodrivers
426
427 * Fri Sep  2 2005 Dan Williams <dcbw@redhat.com> - 0.168-1
428 - Add more Gateway monitors
429
430 * Fri Sep  2 2005 Dan Williams <dcbw@redhat.com> - 0.167-1
431 - Add some ADI monitors, one BenQ, and and DPMS codes for two Apples
432
433 * Fri Sep  2 2005 Bill Nottingham <notting@redhat.com> - 0.166-1
434 - add videoaliases file
435 - remove CardMonitorCombos, as nothing uses it
436
437 * Thu Aug 25 2005 Dan Williams <dcbw@redhat.com> - 0.165-1
438 - Add a bunch of Acer monitors
439
440 * Tue Aug  9 2005 Jeremy Katz <katzj@redhat.com> - 0.164-1
441 - migrate sk98lin -> skge
442
443 * Sat Jul 30 2005 Bill Nottingham <notting@redhat.com>
444 - migrate mpt module names (#161420)
445 - remove pcitable entries for drivers in modules.pcimap
446 - switch lone remaining 'Server' entry - that can't work right
447
448 * Tue Jul 26 2005 Bill Nottingham <notting@redhat.com>
449 - add Daytek monitor (#164339)
450
451 * Wed Jul 13 2005 Bill Nottingham <notting@redhat.com> - 0.162-1
452 - remove /etc/pcmcia/config, conflict with pcmcia-cs
453
454 * Thu Jul  7 2005 Bill Nottingham <notting@redhat.com> - 0.160-1
455 - move blacklist to /etc/modprobe.d, require new module-init-tools
456 - add LG monitors (#162466, #161734)
457 - add orinoco card (#161696)
458 - more mptfusion stuff (#107088)
459
460 * Thu Jun 23 2005 Bill Nottingham <notting@redhat.com>
461 - add Samsung monitor (#161013)
462
463 * Wed Jun 22 2005 Bill Nottingham <notting@redhat.com> - 0.159-1
464 - pcitable: make branding happy (#160047)
465 - Cards: add required blank line (#157972)
466 - add some monitors
467 - add JVC CD-ROM (#160907, <richard@rsk.demon.co.uk>)
468 - add hisax stuff to blacklist (#154799, #159068)
469
470 * Mon May 16 2005 Bill Nottingham <notting@redhat.com> - 0.158-1
471 - add a orinoco card (#157482)
472
473 * Thu May  5 2005 Jeremy Katz <katzj@redhat.com> - 0.157-1
474 - add 20" Apple Cinema Display
475
476 * Sun Apr 10 2005 Mike A. Harris <mharris@redhat.com> 0.156-1
477 - Update SiS entries in Cards/pcitable to match what Xorg X11 6.8.2 supports
478
479 * Wed Mar 30 2005 Dan Williams <dcbw@redhat.com> 0.155-1
480 - Add a boatload of BenQ, Acer, Sony, NEC, Mitsubishi, and Dell monitors
481
482 * Wed Mar 30 2005 Dan Williams <dcbw@redhat.com> 0.154-1
483 - Add Typhoon Speednet Wireless PCMCIA Card mapping to atmel_cs driver
484
485 * Mon Mar 28 2005 Bill Nottingham <notting@redhat.com> 0.153-1
486 - update the framebuffer blacklist
487
488 * Wed Mar  9 2005 Bill Nottingham <notting@redhat.com> 0.152-1
489 - fix qlogic driver mappings, add upgradelist mappings for the modules
490   that changed names (#150621)
491
492 * Wed Mar  2 2005 Mike A. Harris <mharris@redhat.com> 0.151-1
493 - Added one hundred billion new nvidia PCI IDs to pcitable and Cards to
494   synchronize it with X.Org X11 6.8.2.  (#140601)
495
496 * Tue Jan 11 2005 Dan Williams <dcbw@redhat.com> - 0.150-1
497 - Add Dell UltraSharp 1704FPV (Analog & Digital)
498
499 * Sun Nov 21 2004 Bill Nottingham <notting@redhat.com> - 0.148-1
500 - add Amptron monitors (#139142)
501
502 * Wed Nov 10 2004 Bill Nottingham <notting@redhat.com> - 0.147-1
503 - update usb.ids (#138533)
504 - migrate dpt_i2o to i2o_block (#138603)
505
506 * Tue Nov  9 2004 Bill Nottingham <notting@redhat.com> - 0.146-1
507 - update pci.ids (#138233)
508 - add Apple monitors (#138481)
509
510 * Wed Oct 20 2004 Bill Nottingham <notting@redhat.com> - 0.145-1
511 - remove ahci mappings, don't prefer it over ata_piix
512
513 * Tue Oct 19 2004 Kristian Høgsberg <krh@redhat.com> - 0.144-1
514 - update IDs for Cirrus, Trident, C&T, and S3
515
516 * Tue Oct 12 2004 Bill Nottingham <notting@redhat.com> - 0.143-1
517 - add ahci mappings to prefer it over ata_piix
518 - map davej's ancient matrox card to vesa (#122750)
519
520 * Thu Oct  7 2004 Dan Williams <dcbw@redhat.com> - 0.141-1
521 - Add Belkin F5D6020 ver.2 (802.11b card based on Atmel chipset)
522
523 * Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> - 0.140-1
524 - include /etc/hotplug/blacklist here
525
526 * Thu Sep 30 2004 Bill Nottingham <notting@redhat.com> - 0.136-1
527 - add S3 UniChrome (#131403)
528 - update pci.ids
529
530 * Thu Sep 23 2004 Bill Nottingham <notting@redhat.com> - 0.135-1
531 - megaraid -> megaraid_mbox
532
533 * Wed Sep 22 2004 Bill Nottingham <notting@redhat.com> - 0.134-1
534 - map ncr53c8xx to sym53c8xx (#133181)
535
536 * Fri Sep 17 2004 Bill Nottingham <notting@redhat.com> - 0.132-1
537 - fix 3Ware 9000 mapping (#132851)
538
539 * Tue Sep 14 2004 Kristian Høgsberg <krh@redhat.com> - 0.131-1
540 - Add python script to check sorting of pci.ids
541
542 * Thu Sep  9 2004 Kristian Høgsberg <krh@redhat.com> 0.131-1
543 - Add pci ids and cards for new ATI, NVIDIA and Intel cards
544
545 * Sat Sep  4 2004 Bill Nottingham <notting@redhat.com> 0.130-1
546 - trim pcitable - now just ids/drivers
547
548 * Wed Sep  1 2004 Bill Nottingham <notting@redhat.com> 0.125-1
549 - pci.ids updates
550 - remove updsftab.conf.*
551
552 * Sun Aug 29 2004 Mike A. Harris <mharris@redhat.com>  0.124-1
553 - Updates to pcitable/Cards for 'S3 Trio64 3D' cards. (#125866,59956)
554
555 * Fri Jul  9 2004 Mike A. Harris <mharris@redhat.com>  0.123-1
556 - Quick pcitable/Cards update for ATI Radeon and FireGL boards
557
558 * Mon Jun 28 2004 Bill Nottingham <notting@redhat.com>
559 - add Proview monitor (#125853)
560 - add ViewSonic monitor (#126324)
561 - add a Concord camera (#126673)
562
563 * Wed Jun 23 2004 Brent Fox <bfox@redhat.com> - 0.122-1
564 - Add Vobis monitor to MonitorsDB (bug #124151)
565
566 * Wed Jun 09 2004 Dan Williams <dcbw@redhat.com> - 0.121-1
567 - add Belkin F5D5020 10/100 PCMCIA card (#125581)
568
569 * Fri May 28 2004 Bill Nottingham <notting@redhat.com>
570 - add modem (#124663)
571
572 * Mon May 24 2004 Bill Nottingham <notting@redhat.com> - 0.120-1
573 - mainly:
574   fix upgradelist module for CMPci cards (#123647)
575 - also:
576   add another wireless card (#122676)
577   add wireless card (#122625)
578   add 1280x800 (#121548)
579   add 1680x1050 (#121148)
580   add IntelligentStick (#124313)
581
582 * Mon May 10 2004 Jeremy Katz <katzj@redhat.com> - 0.119-1
583 - veth driver is iseries_veth in 2.6
584
585 * Wed May  5 2004 Jeremy Katz <katzj@redhat.com> - 0.118-1
586 - add a wireless card (#122064)
587 - and a monitor (#121696)
588
589 * Fri Apr 16 2004 Bill Nottingham <notting@redhat.com> 0.117-1
590 - fix makefile
591
592 * Thu Apr 15 2004 Bill Nottingham <notting@redhat.com> 0.116-1
593 - move updfstab.conf here
594 - add wireless card (#116865)
595 - add laptop display panel (#117385)
596 - add clipdrive (#119928)
597 - add travelling disk (#119143)
598 - add NEXDISK (#106782)
599
600 * Thu Apr 15 2004 Brent Fox <bfox@redhat.com> 0.115-1
601 - replace snd-es1960 driver with snd-es1968 in pcitable (bug #120729)
602
603 * Mon Mar 29 2004 Bill Nottingham <notting@redhat.com> 0.114-1
604 - fix entries pointing to Banshee (#119388)
605
606 * Tue Mar 16 2004 Bill Nottingham <notting@redhat.com> 0.113-1
607 - add a Marvell sk98lin card (#118467, <64bit_fedora@comcast.net>)
608
609 * Fri Mar 12 2004 Brent Fox <bfox@redhat.com> 0.112-1
610 - add a Sun flat panel to MonitorsDB (bug #118138)
611
612 * Fri Mar  5 2004 Brent Fox <bfox@redhat.com> 0.111-1
613 - add Samsung monitor to MonitorsDB (bug #112112)
614
615 * Mon Mar  1 2004 Mike A. Harris <mharris@redhat.com> 0.110-1
616 - Added 3Dfx Voodoo Graphics and Voodoo II entries to the Cards database, both
617   pointing to Alan Cox's new "voodoo" driver which is now included in XFree86
618   4.3.0-62 and later builds in Fedora development.  Mapped their PCI IDs to
619   the new Cards entry in pcitable.
620 - Updated the entries for 3Dfx Banshee
621
622 * Mon Feb 23 2004 Bill Nottingham <notting@redhat.com> 0.109-1
623 - pci.ids and other updates
624
625 * Thu Feb 19 2004 Mike A. Harris <mharris@redhat.com> 0.108-1
626 - Added Shamrock C407L to MonitorsDB for bug (#104920)
627
628 * Thu Feb 19 2004 Mike A. Harris <mharris@redhat.com> 0.107-1
629 - Massive Viewsonic monitor update for MonitorsDB (#84882)
630
631 * Fri Feb 13 2004 John Dennis <jdennis@finch.boston.redhat.com> 0.106-1
632 - fix typo, GP should have been HP
633
634 * Thu Jan 29 2004 Bill Nottingham <notting@redhat.com> 0.105-1
635 - many monitor updates (#114260, #114216, #113993, #113932, #113782,
636   #113685, #113523, #111203, #107788, #106526, #63005)
637 - add some PCMCIA cards (#113006, #112505)
638
639 * Tue Jan 20 2004 Bill Nottingham <notting@redhat.com> 0.104-1
640 - switch sound module mappings to alsa drivers
641
642 * Mon Jan 19 2004 Brent Fox <bfox@redhat.com> 0.103-1
643 - fix tab spacing
644
645 * Fri Jan 16 2004 Brent Fox <bfox@redhat.com> 0.102-1
646 - added an entry for ATI Radeon 9200SE (bug #111306)
647
648 * Sun Oct 26 2003 Jeremy Katz <katzj@redhat.com> 0.101-1
649 - add 1920x1200 Generic LCD as used on some Dell laptops (#108006)
650
651 * Thu Oct 16 2003 Brent Fox <bfox@redhat.com> 0.100-1
652 - add entry for Sun (made by Samsung) monitor (bug #107128)
653
654 * Tue Sep 23 2003 Mike A. Harris <mharris@redhat.com> 0.99-1
655 - Added entries for Radeon 9600/9600Pro/9800Pro to Cards
656 - Fixed minor glitch in pcitable for Radeon 9500 Pro
657
658 * Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 0.98-1
659 - add VMWare display adapter pci id and map to vmware X driver
660
661 * Thu Sep 11 2003 Bill Nottingham <notting@redhat.com> 0.97-1
662 - bcm4400 -> b44
663
664 * Sun Sep  7 2003 Bill Nottingham <notting@redhat.com> 0.96-1
665 - fix provided Dell tweaks (#103892)
666
667 * Fri Sep  5 2003 Bill Nottingham <notting@redhat.com> 0.95-1
668 - Dell tweaks (#103861)
669
670 * Fri Sep  5 2003 Bill Nottingham <notting@redhat.com> 0.94-1
671 - add adaptec pci id (#100844)
672
673 * Thu Sep  4 2003 Brent Fox <bfox@redhat.com> 0.93-1
674 - add an SGI monitor for bug (#74870)
675
676 * Wed Aug 27 2003 Bill Nottingham <notting@redhat.com> 0.92-1
677 - updates from sourceforge.net pci.ids, update pcitable accordingly
678
679 * Mon Aug 18 2003 Mike A. Harris <mharris@redhat.com> 0.91-1
680 - Added HP monitors for bug (#102495)
681
682 * Fri Aug 15 2003 Brent Fox <bfox@redhat.com> 0.90-1
683 - added a sony monitor (bug #101550)
684
685 * Tue Jul 15 2003 Bill Nottingham <notting@redhat.com> 0.89-1
686 - updates from modules.pcimap
687
688 * Sat Jul 12 2003 Mike A. Harris <mharris@redhat.com> 0.88-1
689 - Update MonitorsDB for new IBM monitors from upstream XFree86 bugzilla:
690   http://bugs.xfree86.org/cgi-bin/bugzilla/show_bug.cgi?id=459
691
692 * Mon Jun  9 2003 Bill Nottingham <notting@redhat.com> 0.87-1
693 - fusion update
694
695 * Mon Jun  9 2003 Jeremy Katz <katzj@redhat.com> 0.86-1
696 - pci id for ata_piix
697
698 * Wed Jun  4 2003 Brent Fox <bfox@redhat.com> 0.85-1
699 - correct entry for Dell P991 monitor
700
701 * Tue Jun  3 2003 Bill Nottingham <notting@redhat.com> 0.84-1
702 - fix qla2100 mapping (#91476)
703 - add dell mappings (#84069)
704
705 * Mon Jun  2 2003 John Dennis <jdennis@redhat.com>
706 - Add new Compaq and HP monitors - bug 90570, bug 90707, bug 90575, IT 17231
707
708 * Wed May 21 2003 Brent Fox <bfox@redhat.com> 0.81-1
709 - add an entry for SiS 650 video card (bug #88271)
710
711 * Wed May 21 2003 Michael Fulbright <msf@redhat.com> 0.80-1
712 - Changed Generic monitor entries in MonitorsDB to being in LCD and CRT groups
713
714 * Tue May 20 2003 Bill Nottingham <notting@redhat.com> 0.79-1
715 - pci.ids and usb.ids updates
716
717 * Tue May  6 2003 Brent Fox <bfox@redhat.com> 0.78-1
718 - added a Samsung monitor to MonitorsDB
719
720 * Fri May  2 2003 Bill Nottingham <notting@redhat.com>
721 - add Xircom wireless airo_cs card (#90099)
722
723 * Fri Apr 18 2003 Jeremy Katz <katzj@redhat.com> 0.77-1
724 - add generic framebuffer to Cards
725
726 * Mon Mar 17 2003 Mike A. Harris <mharris@redhat.com> 0.76-1
727 - Updated MonitorsDb for Dell monitors (#86072)
728
729 * Tue Feb 18 2003 Mike A. Harris <mharris@redhat.com> 0.75-1
730 - Change savage MX and IX driver default back to "savage" for the 1.1.27t
731   driver update
732   
733 * Tue Feb 18 2003 Brent Fox <bfox@redhat.com> 0.74-1
734 - Use full resolution description for Dell laptop screens (bug #80398)
735
736 * Thu Feb 13 2003 Mike A. Harris <mharris@redhat.com> 0.73-1
737 - Updated pcitable and Cards database to fix Savage entries up a bit, and
738   change default Savage/MX driver to 'vesa' as it is hosed and with no sign
739   of working in time for 4.3.0.  Fixes (#72476,80278,80346,80423,82394)
740
741 * Wed Feb 12 2003 Brent Fox <bfox@redhat.com> 0.72-1
742 - slightly alter the sync rates for the Dell 1503FP (bug #84123)
743
744 * Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 0.71-1
745 - large pcitable and pci.ids updates
746 - more tg3, e100
747
748 * Mon Feb 10 2003 Mike A. Harris <mharris@redhat.com> 0.69-1
749 - Updated pcitable and Cards database for new Intel i852/i855/i865 support
750
751 * Mon Feb 10 2003 Mike A. Harris <mharris@redhat.com> 0.68-1
752 - Massive update of all ATI video hardware PCI IDs in pcitable and a fair
753   number of additions and corrections to the Cards database as well
754   
755 * Wed Jan 29 2003 Brent Fox <bfox@redhat.com> 0.67-1
756 - change refresh rates of sny0000 monitors to use a low common denominator
757
758 * Wed Jan 29 2003 Bill Nottingham <notting@redhat.com> 0.66-1
759 - don't force DRI off on R200 (#82957)
760
761 * Fri Jan 24 2003 Mike A. Harris <mharris@redhat.com> 0.65-1
762 - Added Card:S3 Trio64V2 (Unsupported RAMDAC) entry to pcitable, pci.ids, and
763   Cards database to default this particular variant to "vesa" driver (#81659)
764
765 * Thu Jan  2 2003 Bill Nottingham <notting@redhat.com> 0.64-1
766 - pci.ids and associated pcitable updates
767
768 * Sun Dec 29 2002 Mike A. Harris <mharris@redhat.com> 0.63-1
769 - Updates for GeForce 2 Go, GeForce 4 (#80209)
770
771 * Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.62-2
772 - fix Cards for NatSemi Geode
773
774 * Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.62-1
775 - use e100 instead of eepro100 for pcmcia
776
777 * Mon Nov 25 2002 Mike A. Harris <mharris@redhat.com>
778 - Complete reconstruction of all Neomagic hardware entries in Cards
779   database to reflect current XFree86, as well as pcitable update,
780   and submitted cleaned up entries to sourceforge
781
782 * Mon Nov  4 2002 Bill Nottingham <notting@redhat.com> 0.61-1
783 - move pcmcia config file here
784 - sort MonitorsDB, add some entries, remove dups
785 - switch some network driver mappings
786
787 * Tue Sep 24 2002 Bill Nottingham <notting@redhat.com> 0.48-1
788 - broadcom 5704 mapping
789 - aic79xx (#73781)
790
791 * Thu Sep  5 2002 Bill Nottingham <notting@redhat.com> 0.47-1
792 - pci.ids updates
793 - add msw's wireless card
794
795 * Tue Sep  3 2002 Jeremy Katz <katzj@redhat.com> 0.46-1
796 - Card entries in pcitable need matching in Cards
797
798 * Sun Sep  1 2002 Mike A. Harris <mharris@redhat.com> 0.45-1
799 - Update G450 entry in Cards
800
801 * Tue Aug 13 2002 Bill Nottingham <notting@redhat.com> 0.44-1
802 - fix some of the Dell entries
803 - add cardbus controller id (#71198)
804 - add audigy mapping
805 - add NEC monitor (#71320)
806
807 * Tue Aug 13 2002 Preston Brown <pbrown@redhat.com> 0.43-1
808 - pci.id for SMC wireless PCI card (#67346)
809
810 * Sat Aug 10 2002 Mike A. Harris <mharris@redhat.com> 0.42-1
811 - Change default driver for old S3 based "Miro" card for bug (#70743)
812
813 * Fri Aug  9 2002 Preston Brown <pbrown@redhat.com> 0.41-1
814 - fix tabs in pci.ids
815 - Change pci ids for the PowerEdge 4 series again...
816
817 * Tue Aug  6 2002 Preston Brown <pbrown@redhat.com> 0.39-1
818 - Dell PERC and SCSI pci.id additions
819
820 * Tue Aug  6 2002 Mike A. Harris <mharris@redhat.com> 0.38-1
821 - Removed and/or invalid entries from Cards database BLOCKER (#70802)
822
823 * Mon Aug  5 2002 Mike A. Harris <mharris@redhat.com> 0.37-1
824 - Changed Matrox G450 driver default options to fix bug (#66697)
825 - Corrected S3 Trio64V2 bug in Cards file (#66492)
826
827 * Tue Jul 30 2002 Bill Nottingham <notting@redhat.com> 0.36-1
828 - tweaks for Dell Remote Assisstant cards (#60376)
829
830 * Fri Jul 26 2002 Mike A. Harris <mharris@redhat.com> 0.35-1
831 - Updated Cards db for CT69000
832 - Various ATI cleanups and additions to Cards and pcitable
833 - Updated S3 Trio3D to default to "vesa" driver (#59956)
834
835 * Tue Jul 23 2002 Bill Nottingham <notting@redhat.com> 0.33-1
836 - Eizo monitor updates (#56080, <triad@df.lth.se>)
837 - pci.ids updates, corresponding pcitable updates
838 - pcilint for pcitable 
839
840 * Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 0.32-1
841 - switch de4x5 back to tulip
842
843 * Mon Jun 24 2002 Mike A. Harris <mharris@redhat.com> 0.31-1
844 - Modified ATI entries in pcitable to be able to autodetect the FireGL 8700
845   and FireGL 8800 which both have the same ID, but different subdevice ID's.
846   Added entries to Cards database for the 8700/8800 as well.
847
848 * Tue May 28 2002 Mike A. Harris <mharris@redhat.com> 0.30-1
849 - Reconfigured Cards database to default to XFree86 4.x for ALL video
850   hardware, since 3.3.6 support is being removed.  Video cards not
851   supported natively by 4.x will be changed to use the vesa or vga
852   driver, or completely removed as unsupported.
853
854 * Wed Apr 17 2002 Michael Fulbright <msf@redhat.com> 0.14-1
855 - another megaraid variant
856
857 * Mon Apr 15 2002 Michael Fulbright <msf@redhat.com> 0.13-1
858 - fix monitor entry for Dell 1600X Laptop Display Panel
859
860 * Fri Apr 12 2002 Bill Nottingham <notting@redhat.com> 0.13-1
861 - more aacraid
862
863 * Tue Apr  9 2002 Bill Nottingham <notting@redhat.com> 0.12-1
864 - another 3ware, another megaraid
865
866 * Fri Apr  5 2002 Mike A. Harris <mharris@redhat.com> 0.11-1
867 - Added commented out line for some Radeon 7500 cards to Cards database.
868
869 * Tue Apr  2 2002 Mike A. Harris <mharris@redhat.com> 0.10-1
870 - Fixed i830 entry to use driver "i810" not "i830" which doesn't exist
871
872 * Mon Apr  1 2002 Bill Nottingham <notting@redhat.com> 0.9-1
873 - fix rebuild (#62459)
874 - SuperSavage ids (#62101)
875 - updates from pci.ids
876
877 * Mon Mar 18 2002 Bill Nottingham <notting@redhat.com> 0.8-2
878 - fix errant space (#61363)
879
880 * Thu Mar 14 2002 Bill Nottingham <notting@redhat.com> 0.8-1
881 - nVidia updates
882
883 * Wed Mar 13 2002 Bill Nottingham <notting@redhat.com> 0.7-1
884 - lots of pcitable updates
885
886 * Tue Mar  5 2002 Mike A. Harris <mharris@redhat.com> 0.6-1
887 - Updated Cards database
888
889 * Mon Mar  4 2002 Mike A. Harris <mharris@redhat.com> 0.5-1
890 - Built new package with updated database files for rawhide.
891
892 * Fri Feb 22 2002 Bill Nottingham <notting@redhat.com> 0.3-1
893 - return of XFree86-3.3.x
894
895 * Wed Jan 30 2002 Bill Nottingham <notting@redhat.com> 0.1-1
896 - initial build