kernel: make kmod-i2c-mux selected by dependent modules
[oweals/openwrt.git] / target / linux / omap / Makefile
index 91b9d9b20a2c4c1018465e83bbb47eb3ed69185b..f61696fe8bf8130123077f23d177595a10d27105 100644 (file)
@@ -4,16 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=omap
 BOARDNAME:=TI OMAP3/4/AM33xx
-FEATURES:=usb usbgadget ext4 targz fpu audio display nand ubifs
-CPU_TYPE:=cortex-a9
+FEATURES:=usb usbgadget ext4 targz fpu audio display nand squashfs
+CPU_TYPE:=cortex-a8
 CPU_SUBTYPE:=vfpv3
 
-KERNEL_PATCHVER:=4.4
+KERNEL_PATCHVER:=4.19
 
 MAINTAINER:=Alexander Couzens <lynxis@fe80.eu>
 
@@ -25,6 +26,6 @@ endef
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
 
 $(eval $(call BuildTarget))