kernel: make kmod-i2c-mux selected by dependent modules
authorSungbo Eo <mans0n@gorani.run>
Mon, 16 Mar 2020 05:55:40 +0000 (14:55 +0900)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 16 Mar 2020 15:26:29 +0000 (16:26 +0100)
Currently kmod-i2c-mux-* will not get into images unless kmod-i2c-mux is added
to DEVICE_PACKAGES as well. By changing the dependencies from "depends on" to
"select", we do not have the issue anymore.

Furthermore, we can remove most occurrences of the package from DEVICE_PACKAGES
and similar variables, as it is now pulled by dependent modules such as:
- kmod-i2c-mux-pca954x

Signed-off-by: Sungbo Eo <mans0n@gorani.run>
package/kernel/linux/modules/i2c.mk
target/linux/layerscape/image/armv8_64b.mk
target/linux/mvebu/image/cortexa72.mk
target/linux/mvebu/image/cortexa9.mk

index 90eee8b8f5cdec74a3ad4a47301b9b899a64a415..6690384a89f7af43a60c699864bc2f5abc892b42 100644 (file)
@@ -147,7 +147,7 @@ I2C_MUX_GPIO_MODULES:= \
 define KernelPackage/i2c-mux-gpio
   $(call i2c_defaults,$(I2C_MUX_GPIO_MODULES),51)
   TITLE:=GPIO-based I2C mux/switches
-  DEPENDS:=kmod-i2c-mux
+  DEPENDS:=+kmod-i2c-mux
 endef
 
 define KernelPackage/i2c-mux-gpio/description
@@ -163,7 +163,7 @@ I2C_MUX_PCA9541_MODULES:= \
 define KernelPackage/i2c-mux-pca9541
   $(call i2c_defaults,$(I2C_MUX_PCA9541_MODULES),51)
   TITLE:=Philips PCA9541 I2C mux/switches
-  DEPENDS:=kmod-i2c-mux
+  DEPENDS:=+kmod-i2c-mux
 endef
 
 define KernelPackage/i2c-mux-pca9541/description
@@ -178,7 +178,7 @@ I2C_MUX_PCA954x_MODULES:= \
 define KernelPackage/i2c-mux-pca954x
   $(call i2c_defaults,$(I2C_MUX_PCA954x_MODULES),51)
   TITLE:=Philips PCA954x I2C mux/switches
-  DEPENDS:=kmod-i2c-mux
+  DEPENDS:=+kmod-i2c-mux
 endef
 
 define KernelPackage/i2c-mux-pca954x/description
index 280a07168ac71f0ae40168a0c860e4a709d71c61..e84ee5bd32fe406d0ffe134d2f8bd7ad2e19c240 100644 (file)
@@ -275,7 +275,7 @@ define Device/traverse-ls1043
   DEVICE_PACKAGES += \
     layerscape-fman-ls1043ardb \
     uboot-envtools \
-    kmod-i2c-mux kmod-i2c-mux-pca954x \
+    kmod-i2c-mux-pca954x \
     kmod-hwmon-core \
     kmod-gpio-pca953x kmod-input-gpio-keys-polled \
     kmod-rtc-isl1208
index 014f46c9522c2ea768b11a959312e3b7f595e842..50233540ed2e77948c8675ab9cc9352c4593540e 100644 (file)
@@ -22,7 +22,7 @@ define Device/marvell_macchiatobin
   DEVICE_MODEL := MACCHIATObin
   DEVICE_ALT0_VENDOR := SolidRun
   DEVICE_ALT0_MODEL := Armada 8040 Community Board
-  DEVICE_PACKAGES += kmod-i2c-mux kmod-i2c-mux-pca954x
+  DEVICE_PACKAGES += kmod-i2c-mux-pca954x
   DEVICE_DTS := armada-8040-mcbin
   SUPPORTED_DEVICES := marvell,armada8040-mcbin
 endef
index a215536bf8386b66cc4d7cd1c930b7f114d6bcfb..85bfa94dbd3ebd090375cd1e0506d4a5c80fcaf9 100644 (file)
@@ -15,7 +15,7 @@ define Device/cznic_turris-omnia
   DEVICE_PACKAGES :=  \
     mkf2fs e2fsprogs kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
     wpad-basic kmod-ath9k kmod-ath10k-ct ath10k-firmware-qca988x-ct \
-    partx-utils kmod-i2c-mux kmod-i2c-mux-pca954x
+    partx-utils kmod-i2c-mux-pca954x
   IMAGES := $$(IMAGE_PREFIX)-sysupgrade.img.gz omnia-medkit-$$(IMAGE_PREFIX)-initramfs.tar.gz
   IMAGE/$$(IMAGE_PREFIX)-sysupgrade.img.gz := boot-img | sdcard-img | gzip | append-metadata
   IMAGE/omnia-medkit-$$(IMAGE_PREFIX)-initramfs.tar.gz := omnia-medkit-initramfs | gzip