kernel: make kmod-i2c-mux selected by dependent modules
[oweals/openwrt.git] / target / linux / omap / Makefile
index 08003d5fd24aa5fc501628a2b1a77da79fb5f26a..f61696fe8bf8130123077f23d177595a10d27105 100644 (file)
@@ -1,32 +1,31 @@
 #
-# Copyright (C) 2012-2013 OpenWrt.org
+# Copyright (C) 2012-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=omap
 BOARDNAME:=TI OMAP3/4/AM33xx
-FEATURES:=usb usbgadget ext4 targz fpu audio display ubifs
-CPU_TYPE:=cortex-a9
+FEATURES:=usb usbgadget ext4 targz fpu audio display nand squashfs
+CPU_TYPE:=cortex-a8
 CPU_SUBTYPE:=vfpv3
 
-LINUX_VERSION:=3.13.2
-
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-
-KERNELNAME:="zImage dtbs"
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.19
 
-DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
+MAINTAINER:=Alexander Couzens <lynxis@fe80.eu>
 
-DEVICE_TYPE=developerboard
+KERNELNAME:=zImage dtbs
 
 define Target/Description
        TI OMAP boards
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))