Disable all code related to libXp
[oweals/cde.git] / cde / programs / dtinfo / DtMmdb / StyleSheet / online.feature.spec
1
2 #
3 # online feature set specification
4 #  qfc 12-6-94
5 # modified for dtinfo
6 #  cso 12-7-95
7 # modified to support tables (especially CALS tables)
8 #  cso 3-21-96
9 # removed activecharset
10 #  stevew 6-28-96
11 # modified to support vjustify in row
12 #  kamiya 7-12-96
13 # modified to support colsep and rowsep in table features
14 #  kamiya 7-31-96
15 # table renamed as tgroup
16 #  kamiya 8-19-96
17 # add *real* table
18 #  kamiya 8-20-96
19 # removed graphic, add charalign to tgroup
20 #  kamiya 8-28-96
21 # removed cols of colformat, add colstart/colend in cell
22 #  kamiya 8-29-96
23 #
24
25 border {
26         display   : string;
27         thickness : integer;
28 }
29
30 cell {
31         charalign : string;
32         colref    : string;
33         colstart  : string;
34         colend    : string;
35         colsep    : integer;
36         rowsep    : integer;
37         morerows  : integer;
38         justify   : string;
39         vjustify  : string;
40 }
41
42 colformat {
43         charalign : string;
44         colsep    : integer;
45         justify   : string ("left", "right", "center", "char");
46         name      : string;
47         rowsep    : integer;
48         width     : integer;
49 }
50
51 font    {
52         fallback : string;
53         position : string ("sub", "super", "baseline", "subscript",
54                                 "superscript");
55         size : integer, dimension_pixel;
56         slant: string ("roman", "italic");
57         spacing : string ("char", "prop");
58         style : string;
59         weight : string ("medium", "bold");
60         width : string ("narrow", "normal");
61         family {
62                 name : string;
63                 charset : string;
64                 foundry : string;
65         }
66 }
67
68 highlight {
69         bgcolor : string;
70         fgcolor : string;
71         overline: boolean;
72         strikethrough: boolean;
73         underline: boolean;
74 }
75
76 ignore : boolean;
77
78 layout {
79         aspace  : integer;
80         bspace  : integer;
81         leading : integer;
82         findent : integer;
83         lindent : integer;
84         rindent : integer;
85         flow    : string ("verbatim", "filled");
86         justify : string ("left", "right", "center");
87         wrap    : string ("block", "join", "none");
88 }
89
90 linebreak : string ("before", "after", "both");
91
92 margin  {
93         left : integer;
94         right : integer;
95         top : integer;
96         bottom : integer;
97 }
98
99 position {
100         horiz : string ("lcorner", "left", "lmargin", "rcorner", "right",
101                         "rmargin", "center");
102         vert : string ("top", "bottom", "middle");
103 }
104
105 prefix{
106         content : string;
107         *;
108 }
109
110 row {
111         rowsep   : integer;
112         vjustify : string;
113 }
114
115 suffix{
116         content : string;
117         *;
118 }
119
120 table {
121         colsep : integer;
122         rowsep : integer;
123         frame  : string;
124 }
125
126 tgroup  {
127         charalign : string;
128         cols      : integer;
129         colsep    : integer;
130         justify   : string;
131         rowsep    : integer;
132         vjustify  : string;
133 }
134
135