Disable all code related to libXp
[oweals/cde.git] / cde / programs / dtinfo / DtMmdb / StyleSheet / hardcopy.feature.spec
1 #
2 # hardcopy feature set specification
3 #  qfc 12-6-94
4 # modified for dtinfo
5 #  cso 12-7-95
6 # modified to support tables (especially CALS tables)
7 #  cso 3-21-96
8 # removed activecharset
9 #  stevew 6-28-96
10 # modified to support vjustify in row
11 #  kamiya 7-12-96
12 # modified to support colsep and rowsep in table features
13 #  kamiya 7-31-96
14 # table renamed as tgroup
15 #  kamiya 8-19-96
16 # add *real* table
17 #  kamiya 8-20-96
18 # removed graphic, add charalign to tgroup
19 #  kamiya 8-28-96
20 # removed cols of colformat, add colstart/colend in cell
21 #  kamiya 8-29-96
22 #
23
24 border {
25         display   : string;
26         thickness : integer;
27 }
28
29 cell {
30         charalign : string;
31         colref    : string;
32         colstart  : string;
33         colend    : string;
34         colsep    : integer;
35         rowsep    : integer;
36         morerows  : integer;
37         justify   : string;
38         vjustify  : string;
39 }
40
41 colformat {
42         charalign : string;
43         colsep    : integer;
44         justify   : string ("left", "right", "center", "char");
45         name      : string;
46         rowsep    : integer;
47         width     : integer;
48 }
49
50 font    {
51         fallback : string;
52         position : string ("sub", "super", "baseline", "subscript",
53                                 "superscript");
54         size : integer, dimension_pixel;
55         slant: string ("roman", "italic");
56         spacing : string ("char", "prop");
57         style : string;
58         weight : string ("medium", "bold");
59         width : string ("narrow", "normal");
60         family {
61                 name : string;
62                 charset : string;
63                 foundry : string;
64         }
65 }
66
67 footer {
68         content : string;
69         *;
70 }
71
72 header {
73         content : string;
74         *;
75 }
76
77 highlight {
78         bgcolor : string;
79         fgcolor : string;
80         overline: boolean;
81         strikethrough: boolean;
82         underline: boolean;
83 }
84
85 ignore : boolean;
86
87 layout {
88         aspace  : integer;
89         bspace  : integer;
90         leading : integer;
91         findent : integer;
92         lindent : integer;
93         rindent : integer;
94         flow    : string ("verbatim", "filled");
95         justify : string ("left", "right", "center");
96         wrap    : string ("block", "join", "none");
97 }
98
99 linebreak : string ("before", "after", "both");
100
101 margin  {
102         left : integer;
103         right : integer;
104         top : integer;
105         bottom : integer;
106 }
107
108 medium {
109         orientation : string ("landscape", "portrait");
110         size  : string ("letter", "legal", "tabloid", "ledger", "statement",
111                         "executive", "a3", "a4", "a5", "b4", "b5", "folio",
112                         "quarto");
113 }
114
115 pagebreak : string ("before", "after", "both");
116
117 position {
118         horiz : string ("lcorner", "left", "lmargin", "rcorner", "right",
119                         "rmargin", "center");
120         vert : string ("top", "bottom", "middle");
121 }
122
123 prefix{
124         content : string;
125         *;
126 }
127
128 row {
129         rowsep   : integer;
130         vjustify : string;
131 }
132
133 suffix{
134         content : string;
135         *;
136 }
137
138 table {
139         colsep : integer;
140         rowsep : integer;
141         frame  : string;
142 }
143
144 tgroup  {
145         charalign : string;
146         cols      : integer;
147         colsep    : integer;
148         justify   : string;
149         rowsep    : integer;
150         vjustify  : string;
151 }
152
153