Add a test for invite and join commands.
[oweals/tinc.git] / test / Makefile.am
index 69042ac86035902e41ceee1249a5e47bbb5c13ff..4766004880406b4d5382999d6f27b9e2648ff74f 100644 (file)
@@ -1,9 +1,13 @@
 TESTS = \
-       executables.test \
        basic.test \
-       sptps_basic.test
+       executables.test \
+       import-export.test \
+       invite-join.test \
+       sptps-basic.test
 
 EXTRA_DIST = testlib.sh
 
 clean-local:
+       -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done
+       -killall ../src/sptps_test
        -rm -rf *.test.?