Add support for multicast communication with UML/QEMU/KVM.
[oweals/tinc.git] / src / Makefile.am
index 5616c572bd86e956510156956d25696a9c73e2a1..cd44eb64adce99dc2a493613ff1670450c237962 100644 (file)
@@ -1,13 +1,25 @@
 ## Produce this file with automake to get Makefile.in
-# $Id: Makefile.am,v 1.13 2003/08/24 20:38:23 guus Exp $
 
 sbin_PROGRAMS = tincd
 
-EXTRA_DIST = linux/device.c freebsd/device.c openbsd/device.c solaris/device.c netbsd/device.c darwin/device.c cygwin/device.c mingw/device.c raw_socket/device.c
+EXTRA_DIST = linux/device.c bsd/device.c solaris/device.c cygwin/device.c mingw/device.c mingw/common.h
 
 tincd_SOURCES = conf.c connection.c edge.c event.c graph.c logger.c meta.c net.c net_packet.c net_setup.c      \
        net_socket.c netutl.c node.c process.c protocol.c protocol_auth.c protocol_edge.c protocol_misc.c       \
-       protocol_key.c protocol_subnet.c route.c subnet.c tincd.c
+       protocol_key.c protocol_subnet.c route.c subnet.c tincd.c \
+       dummy_device.c raw_socket_device.c multicast_device.c
+       
+if UML
+tincd_SOURCES += uml_device.c
+endif
+
+if VDE
+tincd_SOURCES += vde_device.c
+endif
+
+if TUNEMU
+tincd_SOURCES += bsd/tunemu.c
+endif
 
 nodist_tincd_SOURCES = device.c
 
@@ -16,16 +28,18 @@ DEFAULT_INCLUDES =
 INCLUDES = @INCLUDES@ -I$(top_builddir) -I$(top_srcdir)/lib
 
 noinst_HEADERS = conf.h connection.h device.h edge.h event.h graph.h logger.h meta.h net.h netutl.h node.h process.h   \
-       protocol.h route.h subnet.h
+       protocol.h route.h subnet.h bsd/tunemu.h
 
-LIBS = @LIBS@ @LIBINTL@
+LIBS = @LIBS@
+
+if TUNEMU
+LIBS += -lpcap
+endif
 
 tincd_LDADD = \
        $(top_builddir)/lib/libvpn.a
 
-localedir = $(datadir)/locale
-
-AM_CFLAGS = @CFLAGS@ -DCONFDIR=\"$(sysconfdir)\" -DLOCALEDIR=\"$(localedir)\" -DLOCALSTATEDIR=\"$(localstatedir)\"
+AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\"
 
 dist-hook:
        rm -f `find . -type l`