Add UPnP support to tincd.
[oweals/tinc.git] / src / Makefile.am
index 63af709cdb77024897f8d47ea69631080984eeed..c3e746f62535df2a5bebd295fbd60cbf630de2ef 100644 (file)
@@ -251,6 +251,12 @@ sptps_speed_SOURCES += \
 endif
 endif
 
+if MINIUPNPC
+tincd_SOURCES += upnp.c
+tincd_LDADD = $(MINIUPNPC_LIBS)
+tincd_LDFLAGS = -pthread
+endif
+
 tinc_LDADD = $(READLINE_LIBS) $(CURSES_LIBS)
 sptps_speed_LDADD = -lrt