Include ../intl in the include path, and add @INTLLIBS@ to the list of libraries.
[oweals/tinc.git] / src / Makefile.am
index 863e660bf2e0feb365cbea3049b1c407372666ac..a76194b11b8318f63cac25e7729978066e8b6708 100644 (file)
@@ -1,19 +1,22 @@
 ## Produce this file with automake to get Makefile.in
+# $Id: Makefile.am,v 1.4.4.1 2000/06/06 10:24:33 zarq Exp $
 
 sbin_PROGRAMS = tincd genauth
 
 genauth_SOURCES = genauth.c
 tincd_SOURCES = conf.c encr.c net.c netutl.c protocol.c tincd.c
 
-INCLUDES = -I$(top_builddir) -I$(top_srcdir)/cipher -I$(top_srcdir)/lib
+INCLUDES = -I$(top_builddir) -I$(top_srcdir)/cipher -I$(top_srcdir)/lib -I$(top_srcdir)/intl
 
 noinst_HEADERS = conf.h encr.h net.h netutl.h protocol.h
 
-LIBS = @LIBS@
+LIBS = @LIBS@ @INTLLIBS@
 
 tincd_LDADD = $(top_builddir)/cipher/libcipher.la \
-       $(top_builddir)/lib/libvpn.a -ldl
+       $(top_builddir)/lib/libvpn.a
 
 genauth_LDADD = $(top_builddir)/lib/libvpn.a
 
-CFLAGS = @CFLAGS@ -DPKGLIBDIR=$(pkglibdir) -DCONFDIR=\"@sysconfdir@\"
+localedir = $(datadir)/locale
+
+CFLAGS = @CFLAGS@ -DPKGLIBDIR=$(pkglibdir) -DCONFDIR=\"@sysconfdir@\" -DLOCALEDIR=\"$(localedir)\"