Make rule for sample-config.tar.gz.
[oweals/tinc.git] / doc / Makefile.am
index b62feb7e0c9052bbda0018360ea20c99a078b926..f1aa7fb58738a0359d15b00f89ac2d5e87d02dfd 100644 (file)
@@ -1,20 +1,12 @@
 ## Process this file with automake to get Makefile.in
 
-SUBDIRS = es
-
 info_TEXINFOS = tinc.texi
 
-dyn_MANS =
-man_aux = $(dyn_MANS:.8=.x)
-
-man_MANS = tincd.8 tinc.conf.5 $(dyn_MANS)
+man_MANS = tincd.8 tinc.conf.5
 
-PERL = @PERL@
-HELP2MAN = help2man
-MAINTAINERCLEANFILES = $(dyn_MANS)
+EXTRA_DIST = tincinclude.texi.in tincd.8.in tinc.conf.5.in sample-config.tar.gz
 
-EXTRA_DIST = $(man_MANS) $(HELP2MAN) $(man_aux) \
-  Makefile.maint GNUmakefile Makefile.summ sample-config.tar.gz
+CLEANFILES = *.html
 
 # Use `ginstall' in the definition of man_MANS to avoid
 # confusion with the `install' target.  The install rule transforms `ginstall'
@@ -23,3 +15,12 @@ transform = s/ginstall/install/; @program_transform_name@
 
 # For additional rules usually of interest only to the maintainer,
 # see GNUmakefile and Makefile.maint.
+
+sample-config.tar.gz: sample-config
+       GZIP=$(GZIP_ENV) $(AMTAR) chozf sample-config.tar.gz sample-config
+
+texi2html: tinc.texi
+       texi2html -split=chapter tinc.texi
+
+%.html: $(man_MANS)
+       w3mman2html $< > $@