Enable silent builds by default.
[oweals/tinc.git] / doc / Makefile.am
index f1aa7fb58738a0359d15b00f89ac2d5e87d02dfd..91b5b8d33382410a418912837e58e3d4cc80af79 100644 (file)
@@ -6,7 +6,7 @@ man_MANS = tincd.8 tinc.conf.5
 
 EXTRA_DIST = tincinclude.texi.in tincd.8.in tinc.conf.5.in sample-config.tar.gz
 
-CLEANFILES = *.html
+CLEANFILES = *.html tincd.8 tinc.conf.5 tincinclude.texi
 
 # Use `ginstall' in the definition of man_MANS to avoid
 # confusion with the `install' target.  The install rule transforms `ginstall'
@@ -17,10 +17,30 @@ transform = s/ginstall/install/; @program_transform_name@
 # see GNUmakefile and Makefile.maint.
 
 sample-config.tar.gz: sample-config
-       GZIP=$(GZIP_ENV) $(AMTAR) chozf sample-config.tar.gz sample-config
+       $(AM_V_GEN)GZIP=$(GZIP_ENV) $(AMTAR) chozf sample-config.tar.gz --exclude .svn sample-config
 
 texi2html: tinc.texi
-       texi2html -split=chapter tinc.texi
+       $(AM_V_GEN)texi2html -split=chapter tinc.texi
 
-%.html: $(man_MANS)
-       w3mman2html $< > $@
+tincd.8.html: tincd.8
+       $(AM_V_GEN)w3mman2html $< > $@
+
+tinc.conf.5.html: tinc.conf.5
+       $(AM_V_GEN)w3mman2html $< > $@
+
+substitute = sed \
+       -e s,'@PACKAGE\@',"$(PACKAGE)",g \
+       -e s,'@VERSION\@',"$(VERSION)",g \
+       -e s,'@sysconfdir\@',"$(sysconfdir)",g \
+       -e s,'@localstatedir\@',"$(localstatedir)",g
+
+tincd.8: tincd.8.in
+       $(AM_V_GEN)$(substitute) tincd.8.in > tincd.8
+
+tinc.conf.5: tinc.conf.5.in
+       $(AM_V_GEN)$(substitute) tinc.conf.5.in > tinc.conf.5
+
+tincinclude.texi: tincinclude.texi.in
+       $(AM_V_GEN)$(substitute) tincinclude.texi.in > tincinclude.texi
+       
+tinc.texi: tincinclude.texi