Update documentation and remove stuff that's too outdated.
[oweals/tinc.git] / doc / Makefile.am
index b62feb7e0c9052bbda0018360ea20c99a078b926..6714dbae087184c6608ad53df77ca18f890e6251 100644 (file)
@@ -23,3 +23,14 @@ transform = s/ginstall/install/; @program_transform_name@
 
 # For additional rules usually of interest only to the maintainer,
 # see GNUmakefile and Makefile.maint.
 
 # For additional rules usually of interest only to the maintainer,
 # see GNUmakefile and Makefile.maint.
+
+tinc.pdf: tinc.texi
+       texi2pdf -o tinc.pdf tinc.texi
+
+texi2html: tinc.texi
+       mkdir -p html
+       rm -f html/*.html
+       cd html && texi2html -split=chapter ../tinc.texi
+
+%.html: %
+       w3mman2html $< > $@