Rename distro/ to systemd/.
[oweals/tinc.git] / doc / Makefile.am
index 91b5b8d33382410a418912837e58e3d4cc80af79..60afb12e170dea8c83f66b76a99ef4c6de799624 100644 (file)
@@ -4,23 +4,12 @@ info_TEXINFOS = tinc.texi
 
 man_MANS = tincd.8 tinc.conf.5
 
-EXTRA_DIST = tincinclude.texi.in tincd.8.in tinc.conf.5.in sample-config.tar.gz
+EXTRA_DIST = tincinclude.texi.in tincd.8.in tinc.conf.5.in sample-config
 
-CLEANFILES = *.html tincd.8 tinc.conf.5 tincinclude.texi
-
-# Use `ginstall' in the definition of man_MANS to avoid
-# confusion with the `install' target.  The install rule transforms `ginstall'
-# to install before applying any user-specified name transformations.
-transform = s/ginstall/install/; @program_transform_name@
-
-# For additional rules usually of interest only to the maintainer,
-# see GNUmakefile and Makefile.maint.
-
-sample-config.tar.gz: sample-config
-       $(AM_V_GEN)GZIP=$(GZIP_ENV) $(AMTAR) chozf sample-config.tar.gz --exclude .svn sample-config
+CLEANFILES = *.html tincd.8 tinc.conf.5 tincinclude.texi tinc.info
 
 texi2html: tinc.texi
-       $(AM_V_GEN)texi2html -split=chapter tinc.texi
+       $(AM_V_GEN)texi2html -split=chapter $<
 
 tincd.8.html: tincd.8
        $(AM_V_GEN)w3mman2html $< > $@
@@ -32,15 +21,16 @@ substitute = sed \
        -e s,'@PACKAGE\@',"$(PACKAGE)",g \
        -e s,'@VERSION\@',"$(VERSION)",g \
        -e s,'@sysconfdir\@',"$(sysconfdir)",g \
+       -e s,'@runstatedir\@',"$(runstatedir)",g \
        -e s,'@localstatedir\@',"$(localstatedir)",g
 
-tincd.8: tincd.8.in
-       $(AM_V_GEN)$(substitute) tincd.8.in > tincd.8
+tincd.8: $(srcdir)/tincd.8.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tincd.8.in > $@
+
+tinc.conf.5: $(srcdir)/tinc.conf.5.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tinc.conf.5.in > $@
 
-tinc.conf.5: tinc.conf.5.in
-       $(AM_V_GEN)$(substitute) tinc.conf.5.in > tinc.conf.5
+tincinclude.texi: $(srcdir)/tincinclude.texi.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tincinclude.texi.in > $@
 
-tincinclude.texi: tincinclude.texi.in
-       $(AM_V_GEN)$(substitute) tincinclude.texi.in > tincinclude.texi
-       
 tinc.texi: tincinclude.texi