Install a file in /etc/modutils/tinc, containing all necessary aliases
[oweals/tinc.git] / debian / rules
index f52e8910e3c90e5684d59af47f1dbdbbc4463968..6a543ec7d54c90f84c9df0d2669cba866bf17fe5 100644 (file)
@@ -12,7 +12,16 @@ build: build-stamp
 build-stamp:
        dh_testdir
 
-       ./configure --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info --sysconfdir=/etc
+#      # If the Makefile.in.in file in po/ already contains DESTDIR support, skip the patching.
+       cd `pwd`/po ; ( \
+         if ! grep DESTDIR Makefile.in.in > /dev/null ; then \
+           patch -Ns -p0 < `pwd`/../debian/po-Makefile.in.in.diff || true ;\
+         fi ;\
+       )
+
+       env CFLAGS='-O2 -Wall' ./autogen.sh --prefix=/usr --mandir=\$${prefix}/share/man \
+               --infodir=\$${prefix}/share/info --sysconfdir=/etc --localstatedir=/var
+
        $(MAKE)
 
        touch build-stamp
@@ -22,7 +31,7 @@ clean:
        dh_testroot
        rm -f build-stamp
 
-       -$(MAKE) distclean
+       -$(MAKE) cvs-clean
 
        dh_clean
 
@@ -32,10 +41,13 @@ install: build
        dh_clean -k
        dh_installdirs
 
-       $(MAKE) install prefix=`pwd`/debian/tmp/usr
-       mkdir -p `pwd`/debian/tmp/etc/tinc
-       cp doc/tinc.conf.sample `pwd`/debian/tmp/etc/tinc/tinc.conf
-       rm -f `pwd`/debian/tmp/usr/lib/tinc/libblowfish.so
+       $(MAKE) install DESTDIR=`pwd`/debian/tmp
+       mkdir -p `pwd`/debian/tmp/etc/tinc/example
+       cp doc/tinc.conf.sample `pwd`/debian/tmp/etc/tinc/example/tinc.conf
+       ln -s /usr/share/doc/tinc/README.Debian `pwd`/debian/tmp/etc/tinc/example/README
+       cp debian/tinc-up debian/tmp/etc/tinc/example
+       cp debian/tinc-down debian/tmp/etc/tinc/example
+       chmod 700 debian/tmp/etc/tinc/example/tinc-up debian/tmp/etc/tinc/example/tinc-down
 
 
 # Build architecture-independent files here.
@@ -44,30 +56,21 @@ binary-indep: build install
 
 # Build architecture-dependent files here.
 binary-arch: build install
-#      dh_testversion
        dh_testdir
        dh_testroot
-#      dh_installdebconf       
        dh_installdocs
        dh_installexamples
-#      dh_installmenu
-#      dh_installemacsen
-#      dh_installpam
        dh_installinit
-#      dh_installcron
        dh_installmanpages
+       dh_installmodules
        dh_installinfo
-#      dh_undocumented
        dh_installchangelogs ChangeLog
        dh_link
        dh_strip
        dh_compress
        dh_fixperms
-#      # You may want to make some executables suid here.
-#      dh_suidregister
-#      dh_makeshlibs
        dh_installdeb
-#      dh_perl
+       dh_perl
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums