libopkg: introduce SF_NEED_DETAIL flag
authorJo-Philipp Wich <jo@mein.io>
Wed, 15 Feb 2017 22:47:53 +0000 (23:47 +0100)
committerJo-Philipp Wich <jo@mein.io>
Thu, 16 Feb 2017 16:02:29 +0000 (17:02 +0100)
Introduce a new pkt_t state_flag value SF_NEED_DETAIL which will be used
to mark packages for which we require details.

When parsing the feed lists, we'll only keep information about packages
marked with SF_NEED_DETAIL and packages related to them through Provides,
Suggests, Conflicts, Depends etc.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
libopkg/pkg.h

index eeb75e6..3237f83 100644 (file)
@@ -60,6 +60,7 @@ enum pkg_state_flag {
        SF_MARKED = 64,         /* temporary mark */
        SF_FILELIST_CHANGED = 128,      /* needs filelist written */
        SF_USER = 256,
+       SF_NEED_DETAIL = 512,
        SF_LAST_STATE_FLAG
 };
 typedef enum pkg_state_flag pkg_state_flag_t;
@@ -144,7 +145,7 @@ struct pkg {
        pkg_src_t *src;
        pkg_dest_t *dest;
        pkg_state_want_t state_want:3;
-       pkg_state_flag_t state_flag:10;
+       pkg_state_flag_t state_flag:11;
        pkg_state_status_t state_status:4;
 
        abstract_pkg_t *parent;