opkg: fix gpg enabled builds and fix one compiler warning
authorticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>
Mon, 15 Dec 2008 04:21:48 +0000 (04:21 +0000)
committerticktock35 <ticktock35@e8e0d7a0-c8d9-11dd-a880-a1081c7ac358>
Mon, 15 Dec 2008 04:21:48 +0000 (04:21 +0000)
git-svn-id: http://opkg.googlecode.com/svn/trunk@30 e8e0d7a0-c8d9-11dd-a880-a1081c7ac358

opkg_download.c
opkg_state.h

index 2c2bc57..bbd6efe 100644 (file)
@@ -16,7 +16,7 @@
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
    General Public License for more details.
 */
-
+#include "config.h"
 #include <curl/curl.h>
 #ifdef HAVE_GPGME
 #include <gpgme.h>
index 36dd28e..2718569 100644 (file)
@@ -29,4 +29,8 @@ typedef enum _opkg_state {
   OPKG_STATE_VERIFYING_REPOSITORY_SIGNATURE
 } opkg_state_t;
 
+
+void opkg_set_current_state (opkg_state_t state, const char *data);
+
+
 #endif /* OPKG_STATE_H */