pkg: use a blob buffer in pkg_t to store variable fields
[oweals/opkg-lede.git] / tests / Makefile.am
index a11af3c98ed9ff41acbcb8cf839f7dfc1d4fe375..d1d26f76dea20915d8e795f7a57d69c7fb082b02 100644 (file)
@@ -1,17 +1,23 @@
+AM_CFLAGS = $(ALL_CFLAGS) -Wall -g -O3 -I${top_srcdir}/libopkg
 
 #noinst_PROGRAMS = opkg_hash_test opkg_extract_test
 
 #noinst_PROGRAMS = opkg_hash_test opkg_extract_test
+#noinst_PROGRAMS = libopkg_test opkg_active_list_test
 noinst_PROGRAMS = libopkg_test
 
 noinst_PROGRAMS = libopkg_test
 
-#opkg_hash_test_LDADD = $(top_builddir)/libbb/libbb.la $(top_builddir)/libopkg/libopkg.la
+#opkg_hash_test_LDADD = $(top_builddir)/libbb/libbb.a $(top_builddir)/libopkg/libopkg.a
 #opkg_hash_test_SOURCES = opkg_hash_test.c
 #opkg_hash_test_CFLAGS = $(ALL_CFLAGS) -I$(top_srcdir)
 
 #opkg_hash_test_SOURCES = opkg_hash_test.c
 #opkg_hash_test_CFLAGS = $(ALL_CFLAGS) -I$(top_srcdir)
 
-#opkg_extract_test_LDADD = $(top_builddir)/libbb/libbb.la $(top_builddir)/libopkg/libopkg.la
+#opkg_extract_test_LDADD = $(top_builddir)/libbb/libbb.a $(top_builddir)/libopkg/libopkg.a
 #opkg_extract_test_SOURCES = opkg_extract_test.c
 #opkg_extract_test_CFLAGS = $(ALL_CFLAGS) -I$(top_srcdir)
 
 #opkg_extract_test_SOURCES = opkg_extract_test.c
 #opkg_extract_test_CFLAGS = $(ALL_CFLAGS) -I$(top_srcdir)
 
-libopkg_test_LDADD = $(top_builddir)/libopkg/libopkg.la
+#opkg_active_list_test_LDADD = $(top_builddir)/libopkg/active_list.o
+#opkg_active_list_test_SOURCES = opkg_active_list_test.c
+#opkg_active_list_test_CFLAGS = $(ALL_CFLAGS) -I$(top_srcdir)
+
+libopkg_test_LDADD = $(top_builddir)/libopkg/libopkg.a $(top_builddir)/libbb/libbb.a $(CURL_LIBS) $(GPGME_LIBS) $(OPENSSL_LIBS) $(PATHFINDER_LIBS) -lpthread -lubox
 libopkg_test_SOURCE = libopkg_test.c
 libopkg_test_SOURCE = libopkg_test.c
-libopkg_test_CFLAGS = $(ALL_CFLAGS)
+libopkg_test_LDFLAGS = -static