opkg: fix distcheck issues
[oweals/opkg-lede.git] / tests / Makefile.am
index f7be7ff7979e88f9154d966fffe29a07251ebcbf..0d8c5ce0441200e9f344cc7d5144696770d1c931 100644 (file)
@@ -1,12 +1,17 @@
+AM_CFLAGS = $(ALL_CFLAGS) -I${top_srcdir}/libopkg
 
-noinst_PROGRAMS = opkg_hash_test opkg_extract_test
+#noinst_PROGRAMS = opkg_hash_test opkg_extract_test
+noinst_PROGRAMS = libopkg_test
 
-opkg_hash_test_LDADD = $(top_builddir)/libbb/libbb.la $(top_builddir)/libopkg/libopkg.la
-opkg_hash_test_SOURCES = opkg_hash_test.c
-opkg_hash_test_CFLAGS = $(ALL_CFLAGS) -I$(top_builddir)
+#opkg_hash_test_LDADD = $(top_builddir)/libbb/libbb.la $(top_builddir)/libopkg/libopkg.la
+#opkg_hash_test_SOURCES = opkg_hash_test.c
+#opkg_hash_test_CFLAGS = $(ALL_CFLAGS) -I$(top_srcdir)
 
-opkg_extract_test_LDADD = $(top_builddir)/libbb/libbb.la $(top_builddir)/libopkg/libopkg.la
-opkg_extract_test_SOURCES = opkg_extract_test.c
-opkg_extract_test_CFLAGS = $(ALL_CFLAGS) -I$(top_builddir)
+#opkg_extract_test_LDADD = $(top_builddir)/libbb/libbb.la $(top_builddir)/libopkg/libopkg.la
+#opkg_extract_test_SOURCES = opkg_extract_test.c
+#opkg_extract_test_CFLAGS = $(ALL_CFLAGS) -I$(top_srcdir)
+
+libopkg_test_LDADD = $(top_builddir)/libopkg/libopkg.la
+libopkg_test_SOURCE = libopkg_test.c