libopkg: stop exporting random symbols into the wild
[oweals/opkg-lede.git] / libopkg / Makefile.am
index e3548a7934d98ce0bbffa9a91cfee2c1fffa6878..f751195dbad138cf7c153cae15c2f9c0533c6bd6 100644 (file)
@@ -11,7 +11,6 @@ libopkg_include_HEADERS= \
        hash_table.h \
        includes.h \
        opkg_conf.h \
        hash_table.h \
        includes.h \
        opkg_conf.h \
-       opkg.h \
        opkg_message.h \
        opkg_state.h \
        nv_pair.h \
        opkg_message.h \
        opkg_state.h \
        nv_pair.h \
@@ -30,9 +29,12 @@ libopkg_include_HEADERS= \
 
 libopkg_la_LIBADD = $(top_builddir)/libbb/libbb.la $(CURL_LIBS) $(GPGME_LIBS)
 
 
 libopkg_la_LIBADD = $(top_builddir)/libbb/libbb.la $(CURL_LIBS) $(GPGME_LIBS)
 
+# make sure we only export symbols that are for public use
+libopkg_la_LDFLAGS = -export-symbols-regex "^opkg_.*"
+
 opkg_core_sources = args.c args.h \
                    user.c user.h 
 opkg_core_sources = args.c args.h \
                    user.c user.h 
-opkg_libcore_sources = args.c args.h libopkg.c libopkg.h opkg.h\
+opkg_libcore_sources = args.c args.h libopkg.c libopkg.h\
                    user.c user.h opkg_state.c opkg_state.h
 opkg_cmd_sources = opkg_cmd.c opkg_cmd.h \
                   opkg_configure.c opkg_configure.h \
                    user.c user.h opkg_state.c opkg_state.h
 opkg_cmd_sources = opkg_cmd.c opkg_cmd.h \
                   opkg_configure.c opkg_configure.h \