Remove -Werror from libopkg CFLAGS.
[oweals/opkg-lede.git] / libopkg / Makefile.am
index e3548a7934d98ce0bbffa9a91cfee2c1fffa6878..d860be73ed6bd64e13c0c6fbf8fef51535b783c9 100644 (file)
@@ -1,39 +1,14 @@
 
-ALL_CFLAGS=-g -O -Wall -Werror -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir)
+AM_CFLAGS=-Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DOPKGETCDIR=\"@opkgetcdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS) $(PATHFINDER_CFLAGS)
 
 libopkg_includedir=$(includedir)/libopkg
+libopkg_include_HEADERS= opkg.h
 
-libopkg_include_HEADERS= \
-       args.h \
-       conffile.h \
-       conffile_list.h \
-       config.h \
-       hash_table.h \
-       includes.h \
-       opkg_conf.h \
-       opkg.h \
-       opkg_message.h \
-       opkg_state.h \
-       nv_pair.h \
-       nv_pair_list.h \
-       pkg_depends.h \
-       pkg_dest.h \
-       pkg_dest_list.h \
-       pkg.h \
-       pkg_hash.h \
-       pkg_src.h \
-       pkg_src_list.h \
-       pkg_vec.h \
-       str_list.h \
-       void_list.h \
-       libopkg.h 
 
-libopkg_la_LIBADD = $(top_builddir)/libbb/libbb.la $(CURL_LIBS) $(GPGME_LIBS)
-
-opkg_core_sources = args.c args.h \
-                   user.c user.h 
-opkg_libcore_sources = args.c args.h libopkg.c libopkg.h opkg.h\
-                   user.c user.h opkg_state.c opkg_state.h
+opkg_libcore_sources = args.c args.h libopkg.c libopkg.h\
+                   user.c user.h \
+                   opkg.c opkg.h includes.h \
+                   opkg_error.h opkg_defines.h
 opkg_cmd_sources = opkg_cmd.c opkg_cmd.h \
                   opkg_configure.c opkg_configure.h \
                   opkg_download.c opkg_download.h \
@@ -49,17 +24,28 @@ opkg_list_sources = conffile.c conffile.h conffile_list.c conffile_list.h \
                    nv_pair.c nv_pair.h nv_pair_list.c nv_pair_list.h \
                    pkg_dest.c pkg_dest.h pkg_dest_list.c pkg_dest_list.h \
                    pkg_src.c pkg_src.h pkg_src_list.c pkg_src_list.h \
-                   str_list.c str_list.h void_list.c void_list.h
+                   str_list.c str_list.h void_list.c void_list.h \
+                   active_list.c active_list.h list.h 
 opkg_util_sources = file_util.c file_util.h opkg_message.h opkg_message.c md5.c md5.h \
-                   sprintf_alloc.c sprintf_alloc.h str_util.c str_util.h \
+                   sprintf_alloc.c sprintf_alloc.h \
                    xregex.c xregex.h xsystem.c xsystem.h
+if HAVE_PATHFINDER
+opkg_util_sources += opkg_pathfinder.c opkg_pathfinder.h
+endif
+if HAVE_SHA256
+opkg_util_sources += sha256.c sha256.h
+endif
 
+lib_LTLIBRARIES = libopkg.la
 libopkg_la_SOURCES = \
        $(opkg_libcore_sources) \
        $(opkg_cmd_sources) $(opkg_db_sources) \
        $(opkg_util_sources) $(opkg_list_sources)
 
-libopkg_la_CFLAGS = $(ALL_CFLAGS) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
-lib_LTLIBRARIES = libopkg.la
+libopkg_la_LIBADD = $(top_builddir)/libbb/libbb.la $(CURL_LIBS) $(GPGME_LIBS) $(OPENSSL_LIBS) $(PATHFINDER_LIBS)
+
+# make sure we only export symbols that are for public use
+libopkg_la_LDFLAGS = -export-symbols-regex "^opkg_.*"
+