libopkg: drop support for Release files
[oweals/opkg-lede.git] / libopkg / Makefile.am
index 5e713dda152d241f7b8363d0eb4d4695e28f14e6..851cc8e2ee5b55a930227bec1ef3fcf67d912a0e 100644 (file)
@@ -1,20 +1,13 @@
-
-ALL_CFLAGS=-g -O -Wall -Werror -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir)
+HOST_CPU=@host_cpu@
+AM_CFLAGS=-Wall -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DOPKGETCDIR=\"@opkgetcdir@\" -DOPKGLOCKFILE=\"@opkglockfile@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS) $(PATHFINDER_CFLAGS)
 
 libopkg_includedir=$(includedir)/libopkg
+libopkg_include_HEADERS= *.h
 
-libopkg_include_HEADERS= opkg.h
-
-libopkg_la_LIBADD = $(top_builddir)/libbb/libbb.la $(CURL_LIBS) $(GPGME_LIBS)
-
-# make sure we only export symbols that are for public use
-libopkg_la_LDFLAGS = -export-symbols-regex "^opkg_.*"
 
-opkg_core_sources = args.c args.h \
-                   user.c user.h 
-opkg_libcore_sources = args.c args.h libopkg.c libopkg.h\
-                   user.c user.h opkg_state.c opkg_state.h \
-                   opkg.c opkg.h
+opkg_libcore_sources = \
+                   opkg.c opkg.h \
+                   opkg_defines.h
 opkg_cmd_sources = opkg_cmd.c opkg_cmd.h \
                   opkg_configure.c opkg_configure.h \
                   opkg_download.c opkg_download.h \
@@ -30,17 +23,23 @@ opkg_list_sources = conffile.c conffile.h conffile_list.c conffile_list.h \
                    nv_pair.c nv_pair.h nv_pair_list.c nv_pair_list.h \
                    pkg_dest.c pkg_dest.h pkg_dest_list.c pkg_dest_list.h \
                    pkg_src.c pkg_src.h pkg_src_list.c pkg_src_list.h \
-                   str_list.c str_list.h void_list.c void_list.h
+                   str_list.c str_list.h void_list.c void_list.h \
+                   active_list.c active_list.h list.h 
 opkg_util_sources = file_util.c file_util.h opkg_message.h opkg_message.c md5.c md5.h \
-                   sprintf_alloc.c sprintf_alloc.h str_util.c str_util.h \
+                   parse_util.c parse_util.h \
+                   sprintf_alloc.c sprintf_alloc.h \
                    xregex.c xregex.h xsystem.c xsystem.h
-
-libopkg_la_SOURCES = \
+if HAVE_PATHFINDER
+opkg_util_sources += opkg_pathfinder.c opkg_pathfinder.h
+endif
+if HAVE_SHA256
+opkg_util_sources += sha256.c sha256.h
+endif
+
+noinst_LIBRARIES = libopkg.a
+libopkg_a_SOURCES = \
        $(opkg_libcore_sources) \
        $(opkg_cmd_sources) $(opkg_db_sources) \
        $(opkg_util_sources) $(opkg_list_sources)
 
-libopkg_la_CFLAGS = $(ALL_CFLAGS) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
-lib_LTLIBRARIES = libopkg.la
-
-
+libopkg_a_LIBADD = $(top_builddir)/libbb/libbb.a