Print the package name corresponding to a failed script.
[oweals/opkg-lede.git] / libopkg / Makefile.am
index c7a0a9eb10e0c32b072694a4a17725c2814db430..6be44adaec6693d719c7e9f0c0f3c0b2cab9d1c9 100644 (file)
@@ -1,14 +1,13 @@
 
-AM_CFLAGS=-Wall -Werror -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DOPKGETCDIR=\"@opkgetcdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS) $(PATHFINDER_CFLAGS)
+AM_CFLAGS=-Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DOPKGETCDIR=\"@opkgetcdir@\" -DOPKGLOCKFILE=\"@opkglockfile@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS) $(PATHFINDER_CFLAGS)
 
 libopkg_includedir=$(includedir)/libopkg
-libopkg_include_HEADERS= opkg.h
+libopkg_include_HEADERS= *.h
 
 
-opkg_libcore_sources = args.c args.h libopkg.c libopkg.h\
-                   user.c user.h \
-                   opkg.c opkg.h includes.h \
-                   opkg_error.h opkg_defines.h
+opkg_libcore_sources = \
+                   opkg.c opkg.h \
+                   opkg_defines.h
 opkg_cmd_sources = opkg_cmd.c opkg_cmd.h \
                   opkg_configure.c opkg_configure.h \
                   opkg_download.c opkg_download.h \
@@ -25,7 +24,7 @@ opkg_list_sources = conffile.c conffile.h conffile_list.c conffile_list.h \
                    pkg_dest.c pkg_dest.h pkg_dest_list.c pkg_dest_list.h \
                    pkg_src.c pkg_src.h pkg_src_list.c pkg_src_list.h \
                    str_list.c str_list.h void_list.c void_list.h \
-                   active_list.c active.list.h list.h 
+                   active_list.c active_list.h list.h 
 opkg_util_sources = file_util.c file_util.h opkg_message.h opkg_message.c md5.c md5.h \
                    sprintf_alloc.c sprintf_alloc.h \
                    xregex.c xregex.h xsystem.c xsystem.h
@@ -45,7 +44,7 @@ libopkg_la_SOURCES = \
 libopkg_la_LIBADD = $(top_builddir)/libbb/libbb.la $(CURL_LIBS) $(GPGME_LIBS) $(OPENSSL_LIBS) $(PATHFINDER_LIBS)
 
 # make sure we only export symbols that are for public use
-libopkg_la_LDFLAGS = -export-symbols-regex "^opkg_.*"
+#libopkg_la_LDFLAGS = -export-symbols-regex "^opkg_.*"