libopkg: make MD5 support optional
[oweals/opkg-lede.git] / libopkg / Makefile.am
index 851cc8e2ee5b55a930227bec1ef3fcf67d912a0e..2953ec4b28e687d699d6ac1cfe02022587cf3b85 100644 (file)
@@ -25,13 +25,16 @@ opkg_list_sources = conffile.c conffile.h conffile_list.c conffile_list.h \
                    pkg_src.c pkg_src.h pkg_src_list.c pkg_src_list.h \
                    str_list.c str_list.h void_list.c void_list.h \
                    active_list.c active_list.h list.h 
-opkg_util_sources = file_util.c file_util.h opkg_message.h opkg_message.c md5.c md5.h \
+opkg_util_sources = file_util.c file_util.h opkg_message.h opkg_message.c \
                    parse_util.c parse_util.h \
                    sprintf_alloc.c sprintf_alloc.h \
                    xregex.c xregex.h xsystem.c xsystem.h
 if HAVE_PATHFINDER
 opkg_util_sources += opkg_pathfinder.c opkg_pathfinder.h
 endif
+if HAVE_MD5
+opkg_util_sources += md5.c md5.h
+endif
 if HAVE_SHA256
 opkg_util_sources += sha256.c sha256.h
 endif