tests: fix build of opkg_extract_test
[oweals/opkg-lede.git] / libbb / Makefile.am
index 1f2dd12f05d5570b5279b0d548e17af1254bf4e9..c60cc6d28ac7ac678f55d777e89a775ff1681c01 100644 (file)
@@ -1,30 +1,26 @@
 HOST_CPU=@host_cpu@
 BUILD_CPU=@build_cpu@
-ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@
+ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@
 
-noinst_LTLIBRARIES = libbb.la
+noinst_LIBRARIES = libbb.a
 
-libbb_la_SOURCES = gz_open.c \
+libbb_a_SOURCES = \
        libbb.h \
-       unzip.c \
        wfopen.c \
        unarchive.c \
        copy_file.c \
        copy_file_chunk.c \
-       error_msg.c error_msg_and_die.c \
-       perror_msg.c perror_msg_and_die.c \
        xreadlink.c \
        concat_path_file.c \
-       ask_confirmation.c \
-       verror_msg.c vperror_msg.c \
-       xfuncs.c messages.c \
+       xfuncs.c \
        last_char_is.c \
        make_directory.c \
        safe_strncpy.c \
        parse_mode.c \
        time_string.c \
        all_read.c \
-       mode_string.c
+       mode_string.c \
+       gzip.c
 
 libbb_la_CFLAGS = $(ALL_CFLAGS)
 #libbb_la_LDFLAGS = -static