branding: add LEDE branding
authorJohn Crispin <blogic@openwrt.org>
Thu, 24 Mar 2016 21:40:13 +0000 (22:40 +0100)
committerJohn Crispin <blogic@openwrt.org>
Thu, 24 Mar 2016 21:40:13 +0000 (22:40 +0100)
Signed-off-by: John Crispin <blogic@openwrt.org>
40 files changed:
Config.in
Makefile
README
include/image.mk
include/prereq-build.mk
include/version.mk
package/base-files/Makefile
package/base-files/files/etc/banner
package/base-files/files/etc/config/system
package/base-files/files/etc/init.d/system
package/base-files/files/lib/preinit/10_indicate_preinit
package/base-files/image-config.in
package/kernel/broadcom-wl/files/lib/wifi/broadcom.sh
package/kernel/hostap-driver/files/lib/wifi/hostap.sh
package/kernel/mac80211/files/lib/wifi/mac80211.sh
package/libs/openssl/Makefile
package/network/services/dnsmasq/files/dnsmasq.init
package/network/services/hostapd/files/hostapd.sh
package/network/services/hostapd/files/netifd.sh
package/network/services/lldpd/files/lldpd.config
package/network/services/lldpd/files/lldpd.init
package/network/services/samba36/files/samba.config
package/network/services/samba36/files/samba.init
package/network/services/uhttpd/files/uhttpd.config
package/network/services/uhttpd/files/uhttpd.init
package/network/utils/iproute2/Makefile
scripts/brcmImage.pl
scripts/checkpatch.pl
scripts/config/mconf.c
scripts/get_source_date_epoch.sh
scripts/getver.sh
scripts/make-ipkg-dir.sh
scripts/openbsd.sh
target/linux/imx6/image/Makefile
target/linux/mcs814x/image/Makefile
target/linux/omap24xx/base-files/etc/config/wireless
target/linux/x86/image/grub-iso.cfg
target/linux/x86/image/grub.cfg
toolchain/Config.in
toolchain/gcc/common.mk

index d30c04839e949ca06942e8a41912fb19a2657305..ddbc4e2ea40946454e547f906d5859334d93226b 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -4,7 +4,7 @@
 # See /LICENSE for more information.
 #
 
-mainmenu "OpenWrt Configuration"
+mainmenu "LEDE Configuration"
 
 config MODULES
        option modules
index 8ba2bfc2cc79544a371b21630ff3c8f67c0d63b0..74a878c61d0a6754b1a039ca1cab5c715859af9a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ export TOPDIR LC_ALL LANG TZ
 
 empty:=
 space:= $(empty) $(empty)
-$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
+$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the LEDE directory must not include any spaces))
 
 world:
 
diff --git a/README b/README
index 4cbe56343cfa8ef21a50370ee94a3326cd283c69..b8466fc2d920b152647b9473fa089f97e2b2832a 100644 (file)
--- a/README
+++ b/README
@@ -1,4 +1,4 @@
-This is the buildsystem for the OpenWrt Linux distribution.
+This is the buildsystem for the LEDE Linux distribution.
 
 Please use "make menuconfig" to configure your appreciated
 configuration for the toolchain and firmware.
@@ -20,7 +20,7 @@ the kernel and all choosen applications.
 You can use "scripts/flashing/flash.sh" for remotely updating your embedded
 system via tftp.
 
-The OpenWrt system is documented in docs/. You will need a LaTeX distribution
+The LEDE system is documented in docs/. You will need a LaTeX distribution
 and the tex4ht package to build the documentation. Type "make -C docs/" to build it.
 
 To build your own firmware you need to have access to a Linux, BSD or MacOSX system
@@ -29,7 +29,7 @@ the lack of case sensitiveness in the file system.
 
 
 Sunshine!
-       Your OpenWrt Project
-       http://openwrt.org
+       Your LEDE Community
+       http://www.lede-project.org
 
 
index bc383e6ba81c783518fe4bb24308e8942b90e64d..a868afc0d695b7c06b1c84edf3ab8773ee5e859e 100644 (file)
@@ -120,7 +120,7 @@ endef
 
 define Image/BuildKernel/MkuImage
        mkimage -A $(ARCH) -O linux -T kernel -C $(1) -a $(2) -e $(3) \
-               -n '$(call toupper,$(ARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $(4) $(5)
+               -n '$(call toupper,$(ARCH)) LEDE Linux-$(LINUX_VERSION)' -d $(4) $(5)
 endef
 
 define Image/BuildKernel/MkFIT
@@ -303,7 +303,7 @@ define Build/uImage
        mkimage -A $(LINUX_KARCH) \
                -O linux -T kernel \
                -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
-               -n '$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $@ $@.new
+               -n '$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION)' -d $@ $@.new
        @mv $@.new $@
 endef
 
@@ -318,7 +318,7 @@ endef
 
 define Build/netgear-dni
        $(STAGING_DIR_HOST)/bin/mkdniimg \
-               -B $(NETGEAR_BOARD_ID) -v OpenWrt.$(REVISION) \
+               -B $(NETGEAR_BOARD_ID) -v LEDE.$(REVISION) \
                $(if $(NETGEAR_HW_ID),-H $(NETGEAR_HW_ID)) \
                -r "$(1)" \
                -i $@ -o $@.new
index a53065576cc9c15295fb3e12d541053d45907ac2..0e145c939b03295dd8ea02768ba89fb000750e97 100644 (file)
@@ -20,7 +20,7 @@ $(eval $(call TestHostCommand,working-make, \
        $(MAKE) -v | grep -E 'Make (3\.8[1-9]|3\.9[0-9]|[4-9]\.)'))
 
 $(eval $(call TestHostCommand,case-sensitive-fs, \
-       OpenWrt can only be built on a case-sensitive filesystem, \
+       LEDE can only be built on a case-sensitive filesystem, \
        rm -f $(TMP_DIR)/test.*; touch $(TMP_DIR)/test.fs; \
                test ! -f $(TMP_DIR)/test.FS))
 
index 4bce0965ca2389753bb83b242c0d942f96b2d5f5..d8da358d696912bad879d48edf9b57d652fe4c91 100644 (file)
@@ -25,22 +25,22 @@ VERSION_NUMBER:=$(call qstrip_escape,$(CONFIG_VERSION_NUMBER))
 VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),$(REVISION))
 
 VERSION_CODE:=$(call qstrip_escape,$(CONFIG_VERSION_NUMBER))
-VERSION_CODE:=$(if $(VERSION_CODE),$(VERSION_CODE),Bleeding Edge)
+VERSION_CODE:=$(if $(VERSION_CODE),$(VERSION_CODE),HEAD)
 
 VERSION_NICK:=$(call qstrip_escape,$(CONFIG_VERSION_NICK))
 VERSION_NICK:=$(if $(VERSION_NICK),$(VERSION_NICK),$(RELEASE))
 
 VERSION_REPO:=$(call qstrip_escape,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%S/packages)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.lede-project.org/snapshots/trunk/%S/packages)
 
 VERSION_DIST:=$(call qstrip_escape,$(CONFIG_VERSION_DIST))
-VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
+VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),LEDE)
 
 VERSION_MANUFACTURER:=$(call qstrip_escape,$(CONFIG_VERSION_MANUFACTURER))
-VERSION_MANUFACTURER:=$(if $(VERSION_MANUFACTURER),$(VERSION_MANUFACTURER),OpenWrt)
+VERSION_MANUFACTURER:=$(if $(VERSION_MANUFACTURER),$(VERSION_MANUFACTURER),LEDE)
 
 VERSION_MANUFACTURER_URL:=$(call qstrip_escape,$(CONFIG_VERSION_MANUFACTURER_URL))
-VERSION_MANUFACTURER_URL:=$(if $(VERSION_MANUFACTURER_URL),$(VERSION_MANUFACTURER_URL),http://www.openwrt.org/)
+VERSION_MANUFACTURER_URL:=$(if $(VERSION_MANUFACTURER_URL),$(VERSION_MANUFACTURER_URL),http://www.lede-project.org/)
 
 VERSION_PRODUCT:=$(call qstrip_escape,$(CONFIG_VERSION_PRODUCT))
 VERSION_PRODUCT:=$(if $(VERSION_PRODUCT),$(VERSION_PRODUCT),Generic)
index 8bb622552747dc184fdca779adb3e2bc1f4240a3..691ad517a73921965630a3ec3cc13292e84d684f 100644 (file)
@@ -33,7 +33,7 @@ define Package/base-files
   SECTION:=base
   CATEGORY:=Base system
   DEPENDS:=+netifd +libc +procd +jsonfilter +SIGNED_PACKAGES:usign +fstools
-  TITLE:=Base filesystem for OpenWrt
+  TITLE:=Base filesystem for Lede
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)-$(REVISION)
 endef
index af51b5a8a8cce6410dcd57bc50610bd0c873fced..ae2f16f5139b46e14bc4aed690ec05cd08a338de 100644 (file)
@@ -1,13 +1,10 @@
-  _______                     ________        __
- |       |.-----.-----.-----.|  |  |  |.----.|  |_
- |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
- |_______||   __|_____|__|__||________||__|  |____|
-          |__| W I R E L E S S   F R E E D O M
- -----------------------------------------------------
- DESIGNATED DRIVER (%C, %R)
- -----------------------------------------------------
-  * 2 oz. Orange Juice         Combine all juices in a
-  * 2 oz. Pineapple Juice      tall glass filled with
-  * 2 oz. Grapefruit Juice     ice, stir well.
-  * 2 oz. Cranberry Juice
- -----------------------------------------------------
+     _________
+    /        /\      _    ___ ___  ___
+   /  LE    /  \    | |  | __|   \| __|
+  /    DE  /    \   | |__| _|| |) | _|
+ /________/  LE  \  |____|___|___/|___|                      lede-project.org
+ \        \   DE /
+  \    LE  \    /  -----------------------------------------------------------
+   \  DE    \  /    Reboot (%C, %R)
+    \________\/    -----------------------------------------------------------
+
index 3dfbfc4fc8a5a8fd6cd5eb814f84430ddc390250..20517f9a530b020833996f3ef50c7fd0ad966a5b 100644 (file)
@@ -1,5 +1,5 @@
 config system
-       option hostname OpenWrt
+       option hostname lede
        option timezone UTC
 
 config timeserver ntp
index 531aa8cbc548743371eba0232d6cee5d67c4e20e..8c5f6772996775839f372b0140259e5ac77ee7f6 100755 (executable)
@@ -7,7 +7,7 @@ USE_PROCD=1
 validate_system_section()
 {
        uci_validate_section system system "${1}" \
-               'hostname:string:OpenWrt' \
+               'hostname:string:lede' \
                'conloglevel:uinteger' \
                'buffersize:uinteger' \
                'timezone:string:UTC' \
index 1fab8a20ad99044b96600350e5e12f59dc4e37b5..717d35cc30ae4177c318ff51928401c52150c069 100644 (file)
@@ -39,7 +39,7 @@ preinit_echo() {
 }
 
 pi_indicate_preinit() {
-       preinit_net_echo "Doing OpenWrt Preinit\n"
+       preinit_net_echo "Doing Lede Preinit\n"
        set_state preinit
 }
 
index 3dfbedcfe590f15a0faa7766eb4af03429ec1534..5f84d115e53f7a02f8944e0fb19b5eba7b2157b6 100644 (file)
@@ -147,7 +147,7 @@ if VERSIONOPT
        config VERSION_DIST
                string
                prompt "Release distribution"
-               default "OpenWrt"
+               default "Lede"
                help
                        This is the name of the release distribution.
                        If unspecified, it defaults to OpenWrt.
@@ -170,23 +170,23 @@ if VERSIONOPT
        config VERSION_REPO
                string
                prompt "Release repository"
-               default "http://downloads.openwrt.org/snapshots/trunk/%S/packages"
+               default "http://downloads.lede-project.org/snapshots/trunk/%S/packages"
                help
                        This is the repository address embedded in the image, it defaults
                        to the trunk snapshot repo; the url may contain the following placeholders:
                         %R .. Revision number
                         %V .. Release version or revision number, uppercase
                         %v .. Release version or revision number, lowercase
-                        %C .. Release version or "Bleeding Edge", uppercase
-                        %c .. Release version or "bleeding_edge", lowercase
+                        %C .. Release version or "HEAD", uppercase
+                        %c .. Release version or "head", lowercase
                         %N .. Release name, uppercase
                         %n .. Release name, lowercase
-                        %D .. Distribution name or "OpenWrt", uppercase
-                        %d .. Distribution name or "openwrt", lowercase
+                        %D .. Distribution name or "Lede", uppercase
+                        %d .. Distribution name or "lede", lowercase
                         %T .. Target name
                         %S .. Target/Subtarget name
                         %t .. Build taint flags, e.g. "no-all busybox"
-                        %M .. Manufacturer name or "OpenWrt"
+                        %M .. Manufacturer name or "Lede"
                         %P .. Product name or "Generic"
                         %h .. Hardware revision or "v0"
 
index a9c4de22e9f47de5e0d5b423e9622d8a298e6fa3..deb4ddf1d2dd3413f154d11edcfdaf339f33c616 100644 (file)
@@ -469,7 +469,7 @@ config wifi-iface
        option device   wl${i}
        option network  lan
        option mode     ap
-       option ssid     OpenWrt${i#0}
+       option ssid     Lede${i#0}
        option encryption none
 
 EOF
index e35b76c0fd37b4be5881a95a63ea735e5cd69be1..74e30fb7c50ccab5c42405a6c8a8b742b19a946b 100755 (executable)
@@ -261,7 +261,7 @@ config wifi-iface
        option device   radio$devidx
        option network  lan
        option mode     ap
-       option ssid     OpenWrt
+       option ssid     Lede
        option encryption none
 
 EOF
index 06f3b8b449fbf482d42123fd3d21f8c5b0d315bf..77247cb3993a18f62b1b87f8f889a7f2f39d2d80 100644 (file)
@@ -123,7 +123,7 @@ config wifi-iface
        option device   radio$devidx
        option network  lan
        option mode     ap
-       option ssid     OpenWrt
+       option ssid     Lede
        option encryption none
 
 EOF
index d5dfe6cb08f6022663921e07fb60bdf56507a3dc..f53275e6f8366279b043d38032428b661697ed53 100644 (file)
@@ -121,16 +121,16 @@ ifndef CONFIG_OPENSSL_HARDWARE_SUPPORT
 endif
 
 ifeq ($(CONFIG_x86_64),y)
-  OPENSSL_TARGET:=linux-x86_64-openwrt
+  OPENSSL_TARGET:=linux-x86_64-lede
   OPENSSL_MAKEFLAGS += LIBDIR=lib
 else
   OPENSSL_OPTIONS+=no-sse2
   ifeq ($(CONFIG_mips)$(CONFIG_mipsel),y)
-    OPENSSL_TARGET:=linux-mips-openwrt
+    OPENSSL_TARGET:=linux-mips-lede
 #  else ifeq ($(CONFIG_arm)$(CONFIG_armeb),y)
 #    OPENSSL_TARGET:=linux-armv4-openwrt
   else
-    OPENSSL_TARGET:=linux-generic-openwrt
+    OPENSSL_TARGET:=linux-generic-lede
     OPENSSL_OPTIONS+=no-perlasm
   endif
 endif
index 7f90b8fa3e2744d9cb685671b67057e221006ff0..bb675ad73f11ff8e08bdc8090472c801f789be59 100644 (file)
@@ -625,7 +625,7 @@ start_service() {
        [ $ADD_LOCAL_HOSTNAME -eq 1 ] && {
                local lanaddr lanaddr6
                local ulaprefix="$(uci_get network @globals[0] ula_prefix)"
-               local hostname="$(uci_get system @system[0] hostname OpenWrt)"
+               local hostname="$(uci_get system @system[0] hostname Lede)"
 
                network_get_ipaddr lanaddr "lan" && {
                        dhcp_domain_add "" "$hostname" "$lanaddr"
index 393233b8b46c689f522664bf7a2e1be42c77d040..9c1ba0fa134a2b10d1d47d9a16dc603e148326e7 100644 (file)
@@ -195,8 +195,8 @@ hostapd_set_bss_options() {
 
        [ -n "$wps_possible" -a -n "$config_methods" ] && {
                config_get device_type "$vif" wps_device_type "6-0050F204-1"
-               config_get device_name "$vif" wps_device_name "OpenWrt AP"
-               config_get manufacturer "$vif" wps_manufacturer "openwrt.org"
+               config_get device_name "$vif" wps_device_name "Lede AP"
+               config_get manufacturer "$vif" wps_manufacturer "www.lede-project.org"
                config_get wps_pin "$vif" wps_pin
 
                config_get_bool ext_registrar "$vif" ext_registrar 0
index 005112d828e4865a1010bea37ef36cc549b43d38..af72e7a6d723da3102819f02b360d0ebe4b8ea19 100644 (file)
@@ -331,8 +331,8 @@ hostapd_set_bss_options() {
        [ -n "$wps_possible" -a -n "$config_methods" ] && {
                set_default ext_registrar 0
                set_default wps_device_type "6-0050F204-1"
-               set_default wps_device_name "OpenWrt AP"
-               set_default wps_manufacturer "openwrt.org"
+               set_default wps_device_name "Lede AP"
+               set_default wps_manufacturer "www.lede-project.org"
 
                wps_state=2
                [ -n "$wps_configured" ] && wps_state=1
index 48728e0e11bc787852297dd9abdaf108d64434ac..92ab42116b530b76436c82dfcf61c3e7a1fe22ae 100644 (file)
@@ -8,7 +8,7 @@ config lldpd config
        option lldp_location "2:FR:6:Commercial Rd:3:Roseville:19:4"
 
        # if empty, the distribution description is sent
-       #option lldp_description "OpenWrt System"
+       #option lldp_description "Lede System"
 
        # interfaces to listen on
        list interface "loopback"
index 696518902f421c8e9a3dd8971035cd05f69d20ff..633a8fbc073973111c60c2d9e61fdac9549e7625 100644 (file)
@@ -14,7 +14,7 @@ find_release_info()
        [ -z "$DISTRIB_DESCRIPTION" ] && [ -s /etc/openwrt_version ] && \
                DISTRIB_DESCRIPTION="$(cat /etc/openwrt_version)"
 
-       echo "${DISTRIB_DESCRIPTION:-Unknown OpenWrt release} @ $(cat /proc/sys/kernel/hostname)"
+       echo "${DISTRIB_DESCRIPTION:-Unknown Lede release} @ $(cat /proc/sys/kernel/hostname)"
 }
 
 start_service() {
index c79db0d322ef3a10551b5e9ea54c366983d15637..b34a8dcaac00bd2f3e2ad535c66948c6cdeb81ef 100644 (file)
@@ -1,6 +1,6 @@
 config samba
-       option 'name'                   'OpenWrt'
+       option 'name'                   'Lede'
        option 'workgroup'              'WORKGROUP'
-       option 'description'            'OpenWrt'
+       option 'description'            'Lede'
        option 'homes'                  '1'
 
index 376ae89988ea01589eea42be5aa7de444121b89e..bc1dbf82b6a8119432addecfe385dda212bf302f 100755 (executable)
@@ -28,9 +28,9 @@ smb_header() {
        local name workgroup description charset
        local hostname="$(uci_get system.@system[0].hostname)"
 
-       config_get name        $1 name        "${hostname:-OpenWrt}"
-       config_get workgroup   $1 workgroup   "${hostname:-OpenWrt}"
-       config_get description $1 description "Samba on ${hostname:-OpenWrt}"
+       config_get name        $1 name        "${hostname:-Lede}"
+       config_get workgroup   $1 workgroup   "${hostname:-Lede}"
+       config_get description $1 description "Samba on ${hostname:-Lede}"
        config_get charset     $1 charset     "UTF-8"
 
        mkdir -p /var/etc
index e14b9fefd74ebe88e6c9c12b92396993705532c0..f8df4cdecbe2f9c47dc3ec4f0cae311bdd31fc71 100644 (file)
@@ -83,7 +83,7 @@ config uhttpd main
        option tcp_keepalive    1
 
        # Basic auth realm, defaults to local hostname
-#      option realm    OpenWrt
+#      option realm    Lede
 
        # Configuration file in busybox httpd format
 #      option config   /etc/httpd.conf
@@ -119,4 +119,4 @@ config cert px5g
        option location         Unknown
 
        # Common name
-       option commonname       OpenWrt
+       option commonname       Lede
index 4ca6c8d62655b0e54bf1e5931dc24812aff12370..1b457a2b37ab8a2beb5168dbc6eaf37a97a9c567 100755 (executable)
@@ -46,7 +46,7 @@ generate_keys() {
        [ -x "$PX5G_BIN" ] && {
                $PX5G_BIN selfsigned -der \
                        -days ${days:-730} -newkey rsa:${bits:-2048} -keyout "${UHTTPD_KEY}.new" -out "${UHTTPD_CERT}.new" \
-                       -subj /C="${country:-DE}"/ST="${state:-Saxony}"/L="${location:-Leipzig}"/CN="${commonname:-OpenWrt}"
+                       -subj /C="${country:-DE}"/ST="${state:-Saxony}"/L="${location:-Leipzig}"/CN="${commonname:-Lede}"
                sync
                mv "${UHTTPD_KEY}.new" "${UHTTPD_KEY}"
                mv "${UHTTPD_CERT}.new" "${UHTTPD_CERT}"
index cb9730e683b7a3bd4fa81264afdac680302aff3a..89fb2e62e537912c88240a996b909d5760f225c4 100644 (file)
@@ -70,7 +70,7 @@ define Build/Configure
                $(PKG_BUILD_DIR)/Makefile
        $(SED) "s,^LIBC_INCLUDE.*,LIBC_INCLUDE=$(STAGING_DIR)/include," \
                $(PKG_BUILD_DIR)/Makefile
-       echo "static const char SNAPSHOT[] = \"$(PKG_VERSION)-$(PKG_RELEASE)-openwrt\";" \
+       echo "static const char SNAPSHOT[] = \"$(PKG_VERSION)-$(PKG_RELEASE)-lede\";" \
                > $(PKG_BUILD_DIR)/include/SNAPSHOT.h
 endef
 
index 9a3acb43a4dbad1b32d0b58b6857e29c915fd9e1..265c1744bfdcdb24c63bd8ad0df3a906120e1f61 100755 (executable)
@@ -33,7 +33,7 @@ use Compress::Zlib;
 my $version = "0.1";
 my %arg = (
        o => 'bcm963xx_fs_kernel',
-       b => 'OpenWrt',
+       b => 'LEDE',
        c => '6348',
        s => 64,
        f => 0xbfc00000,
index 78053338c034f11242b9e5724e5b7e3e8e74d83d..9858e62fbbd41b920020a79de6c8b8aff1101d51 100755 (executable)
@@ -173,7 +173,7 @@ if ($tree) {
        }
 
        if (!defined $root) {
-               print "Must be run from the top-level dir. of a OpenWrt tree\n";
+               print "Must be run from the top-level dir. of a LEDE tree\n";
                exit(2);
        }
 }
index 961c1cd4571c9dcc87a591210f7d2b0d572b50ed..f437dd7176400c816534a565570678705e117a0b 100644 (file)
@@ -25,7 +25,7 @@
 static const char mconf_readme[] = N_(
 "Overview\n"
 "--------\n"
-"Some OpenWrt features may be built directly into the image.\n"
+"Some LEDE features may be built directly into the image.\n"
 "Some may be made into installable ipkg packages. Some features\n"
 "may be completely removed altogether.\n"
 "\n"
index 436df9d064a7e28b82b6065f1f2670394b4c5a89..ea8d930109ad00e2cbff2054e2369745993008b6 100755 (executable)
@@ -9,12 +9,6 @@ try_version() {
        [ -n "$SOURCE_DATE_EPOCH" ]
 }
 
-try_svn() {
-       [ -d .svn ] || return 1
-       SOURCE_DATE_EPOCH="$(./scripts/portable_date.sh "$(LC_ALL=C svn info | sed -ne 's/^Last Changed Date: //p')" +%s)"
-       [ -n "$SOURCE_DATE_EPOCH" ]
-}
-
 try_git() {
        [ -e .git ] || return 1
        SOURCE_DATE_EPOCH="$(git log -1 --format=format:%ct)"
@@ -27,5 +21,5 @@ try_hg() {
        [ -n "$SOURCE_DATE_EPOCH" ]
 }
 
-try_version || try_svn || try_git || try_hg || SOURCE_DATE_EPOCH=""
+try_version || try_git || try_hg || SOURCE_DATE_EPOCH=""
 echo "$SOURCE_DATE_EPOCH"
index d3b68c86347d0801f61fda20f114eea7058d8a87..60adc42e9244a7ae0e963baf8280b4401dc4aa4d 100755 (executable)
@@ -11,7 +11,7 @@ try_version() {
 
 try_git() {
        git rev-parse --git-dir >/dev/null 2>&1 || return 1
-       REV="$(git describe | sed "s/reboot-\([0-9]*\)-.*/\1/g")"
+       REV="$(git describe --match reboot | sed "s/reboot-\([0-9]*\)-.*/\1/g")"
        [ -n "$REV" ]
 }
 
index 902a4b526b00a2d81139dc530bc187c28ce9c66b..529e430ad9462318a0818c5fef3bd1cf066f17c2 100755 (executable)
@@ -10,7 +10,7 @@ WD=$(pwd)
 mkdir -p "$TARGET/CONTROL"
 grep '^[^(Version|Architecture)]' "$CONTROL" > "$TARGET/CONTROL/control"
 grep '^Maintainer' "$CONTROL" 2>&1 >/dev/null || \
-        echo "Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>" >> "$TARGET/CONTROL/control"
+        echo "Maintainer: LEDE Community <lede-dev@lists.infradead.org>" >> "$TARGET/CONTROL/control"
 grep '^Source' "$CONTROL" 2>&1 >/dev/null || {
         pkgbase=$(echo "$WD" | sed -e "s|^$TOPDIR/||g")
         [ "$pkgbase" = "$WD" ] && src="N/A" || src="$BASE/$pkgbase"
index dc9f4f778063560b1b9b8a7ffedae0123c63b836..dc88d28ed741d7c782bab161aa1e822eba33f18e 100644 (file)
@@ -1,7 +1,7 @@
 #!/bin/sh
 ver=$(uname -r)
 arch=$(uname -m)
-echo "Preparing OpenBSD $arch $ver for OpenWrt"
+echo "Preparing OpenBSD $arch $ver for LEDE"
 PKG_PATH="http://ftp.openbsd.org/pub/OpenBSD/${ver}/packages/${arch}/"
 export PKG_PATH
 pkg_add -v gmake
index 910f88cf5163cd8b09ee117278abf18486c90170..584ac7a060f99e707deb528b2a7c42e0405e6794 100644 (file)
@@ -39,7 +39,7 @@ define Build/ubi-boot-overlay
                        $(TARGET_ROOTFS_DIR)/boot-$(DEVICE_NAME)_$(word 1, $(1))/$(dts).dtb; \
        )
        mkimage -A arm -O linux -T script -C none -a 0 -e 0 \
-               -n '$(DEVICE_ID) OpenWrt bootscript' \
+               -n '$(DEVICE_ID) LEDE bootscript' \
                -d ./bootscript-$(DEVICE_NAME) \
                $(TARGET_ROOTFS_DIR)/boot-$(DEVICE_NAME)_$(word 1, $(1))/6x_bootscript-$(DEVICE_NAME)
        $(STAGING_DIR_HOST)/bin/mkfs.ubifs \
index 3afd660c14ffb875c124730cd8f5ceb21b3e2093..7be7f8cd991cf953baf41c305d930064a14375ad 100644 (file)
@@ -20,7 +20,7 @@ UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage
 
 define Image/Build/MkuImage
        mkimage -A arm -O linux -T kernel -a $(LOADADDR) -C none -e $(LOADADDR) \
-       -n 'ARM OpenWrt Linux-$(LINUX_VERSION)' -d $(1) $(2);
+       -n 'ARM LEDE Linux-$(LINUX_VERSION)' -d $(1) $(2);
 endef
 
 define Image/Build/DTB
index b640ce6c26abd1b6621458ea8c81c7f7dd3b2b6d..f61721e5183a04aa9ed304b9f8c2b5e82e896af8 100644 (file)
@@ -15,6 +15,6 @@ config wifi-iface
        option powersave 1
        option network  lan
        option mode     sta
-       option ssid     OpenWrt
+       option ssid     LEDE
 #      option encryption psk2
 #      option key      "foobar"
index 3d47a95a4b8209b61c8e0f38165b38b929fdaf08..32ee687c688338f63625fec7cd4a5343e0763928 100644 (file)
@@ -5,6 +5,6 @@ set default="0"
 set timeout="@TIMEOUT@"
 set root='(cd)'
 
-menuentry "OpenWrt" {
+menuentry "LEDE" {
        linux /boot/vmlinuz @CMDLINE@ noinitrd
 }
index 33b9d0b1aad180f4a65e83c227e637bb664f879e..f1a577cdd7ca418f9b822efbebc2b2ac27d46e32 100644 (file)
@@ -5,9 +5,9 @@ set default="0"
 set timeout="@TIMEOUT@"
 set root='(hd0,msdos1)'
 
-menuentry "OpenWrt" {
+menuentry "LEDE" {
        linux /boot/vmlinuz @CMDLINE@ noinitrd
 }
-menuentry "OpenWrt (failsafe)" {
+menuentry "LEDE (failsafe)" {
        linux /boot/vmlinuz failsafe=true @CMDLINE@ noinitrd
 }
index 49c3461a1bb647504af7a095db31d9ed4048f003..a6aa84db75a40f9cefd4db839326066c60140a26 100644 (file)
@@ -42,7 +42,7 @@ menuconfig EXTERNAL_TOOLCHAIN
        bool
        prompt "Use external toolchain"  if DEVEL
        help
-         If enabled, OpenWrt will compile using an existing toolchain instead of
+         If enabled, LEDE will compile using an existing toolchain instead of
          compiling one.
 
        config NATIVE_TOOLCHAIN
@@ -51,7 +51,7 @@ menuconfig EXTERNAL_TOOLCHAIN
                depends on EXTERNAL_TOOLCHAIN
                select NO_STRIP
                help
-                 If enabled, OpenWrt will compile using the native toolchain for your
+                 If enabled, LEDE will compile using the native toolchain for your
                  host instead of compiling one.
 
        config TARGET_NAME
index e1580cf8c503fecbc9093aecd9c1adb6f2d5e0b5..e6b5c8ea4be7caccf7a6c8e2dee083093f2ff9e7 100644 (file)
@@ -44,11 +44,11 @@ endif
 
 PATCH_DIR=../patches/$(GCC_VERSION)
 
-BUGURL=https://dev.openwrt.org/
+BUGURL=http://www.lede-project.org/bugs/
 ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
-  PKGVERSION=OpenWrt/Linaro GCC $(PKG_REV) $(REVISION)
+  PKGVERSION=LEDE/Linaro GCC $(PKG_REV) $(REVISION)
 else
-  PKGVERSION=OpenWrt GCC $(PKG_VERSION) $(REVISION)
+  PKGVERSION=LEDE GCC $(PKG_VERSION) $(REVISION)
 endif
 
 HOST_BUILD_PARALLEL:=1