kernel: bump 4.14 to 4.14.171
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 21 Feb 2020 14:04:52 +0000 (15:04 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 24 Feb 2020 13:18:59 +0000 (14:18 +0100)
Refreshed all patches.

Fixes:
- CVE-2013-1798

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
27 files changed:
include/kernel-version.mk
target/linux/ar71xx/patches-4.14/450-gpio-nxp-74hc153-gpio-chip-driver.patch
target/linux/ar71xx/patches-4.14/451-gpio-74x164-improve-platform-device-support.patch
target/linux/ar71xx/patches-4.14/452-gpio-add-gpio-latch-driver.patch
target/linux/ar71xx/patches-4.14/910-unaligned_access_hacks.patch
target/linux/ath25/patches-4.14/130-watchdog.patch
target/linux/ath79/patches-4.14/910-unaligned_access_hacks.patch
target/linux/bcm47xx/patches-4.14/209-b44-register-adm-switch.patch
target/linux/bcm47xx/patches-4.14/210-b44_phy_fix.patch
target/linux/bcm47xx/patches-4.14/831-old_gpio_wdt.patch
target/linux/bcm53xx/patches-4.14/400-mtd-spi-nor-detect-JEDEC-incompatible-w25q128-using-.patch
target/linux/generic/hack-4.14/204-module_strip.patch
target/linux/ipq40xx/patches-4.14/303-spi-nor-enable-4B-opcodes-for-mx25l25635f.patch
target/linux/ipq806x/patches-4.14/105-mtd-nor-add-mx25l25635f.patch
target/linux/layerscape/patches-4.14/807-usb-support-layerscape.patch
target/linux/layerscape/patches-4.14/810-kvm-support-layerscape.patch
target/linux/layerscape/patches-4.14/812-flexspi-support-layerscape.patch
target/linux/layerscape/patches-4.14/816-pcie-support-layerscape.patch
target/linux/layerscape/patches-4.14/817-platform-security-support-layerscape.patch
target/linux/layerscape/patches-4.14/818-qspi-support-layerscape.patch
target/linux/mpc85xx/patches-4.14/102-powerpc-add-cmdline-override.patch
target/linux/pistachio/patches-4.14/401-mtd-nor-support-mtd-name-from-device-tree.patch
target/linux/ramips/patches-4.14/0031-uvc-add-iPassion-iP2970-support.patch
target/linux/ramips/patches-4.14/0053-mtd-spi-nor-add-w25q256-3b-mode-switch.patch
target/linux/ramips/patches-4.14/0054-mtd-spi-nor-w25q256-respect-default-mode.patch
target/linux/ramips/patches-4.14/302-spi-nor-add-gd25q512.patch
target/linux/ramips/patches-4.14/304-spi-nor-enable-4B-opcodes-for-mx25l25635f.patch

index 30b8ab7df9aa4eeeec2fe8f309705717ee857bc5..54f3c3a6c37ac8b1e49003e116dce0963fad12b5 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .169
+LINUX_VERSION-4.14 = .171
 LINUX_VERSION-4.19 = .101
 
-LINUX_KERNEL_HASH-4.14.169 = d88ea97993c56b1fa0b0a05061bcde476c6be4fc3bb2de8bd97a8f8ff7278249
+LINUX_KERNEL_HASH-4.14.171 = 4fe02489e4b4a187eccf0ef87df6100534c9d485e76d876b1fa247c7635332a0
 LINUX_KERNEL_HASH-4.19.101 = be26156abdb38ac0576a34a235ef456bb8ca67fbbe56fc6649b8d069159f8bc4
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 0902773ff4523ff0492c7cd5a5a4b62185439a57..48a36cc4ecd0da4b33430917b18c6ba4fd1332e7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -1299,4 +1299,12 @@ config GPIO_VIPERBOARD
+@@ -1300,4 +1300,12 @@ config GPIO_VIPERBOARD
  
  endmenu
  
index 8039a71689016fa795ae9cdbd0746dc19320b789..b3c990ccec4d5fe97b0808b4ba4c83e17953e124 100644 (file)
 +#endif
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -1251,7 +1251,6 @@ menu "SPI GPIO expanders"
+@@ -1252,7 +1252,6 @@ menu "SPI GPIO expanders"
  
  config GPIO_74X164
        tristate "74x164 serial-in/parallel-out 8-bits shift register"
index 13c5781deec97ea1c9e8327cb185a6d31de5afd5..98e9123ce7bb152a0e423249342a0402781fc6ab 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -1306,4 +1306,9 @@ config GPIO_NXP_74HC153
+@@ -1307,4 +1307,9 @@ config GPIO_NXP_74HC153
          Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
          provides a GPIO interface supporting input mode only.
  
index f2732ebb20bacc82561cce1ee3251eb85087fb9a..6c216712b1edebc5bec7ee6e6caa5d8ec954f46e 100644 (file)
   * No flags defined yet.
 --- a/net/core/utils.c
 +++ b/net/core/utils.c
-@@ -424,8 +424,14 @@ void inet_proto_csum_replace16(__sum16 *
+@@ -441,8 +441,14 @@ void inet_proto_csum_replace16(__sum16 *
                               bool pseudohdr)
  {
        __be32 diff[] = {
index 890d7ad4913c10bf119c4822d05bf43793fa9006..01904d69a54e77a2991c43148484ecdcc9184f35 100644 (file)
 +MODULE_ALIAS("platform:" DRIVER_NAME);
 --- a/drivers/watchdog/Kconfig
 +++ b/drivers/watchdog/Kconfig
-@@ -1646,6 +1646,13 @@ config PIC32_DMT
+@@ -1647,6 +1647,13 @@ config PIC32_DMT
          To compile this driver as a loadable module, choose M here.
          The module will be called pic32-dmt.
  
index 6234ba4703429110cee89553c17a91a8a7b8254b..cff52e5add0bbb635cd14e1e19e389f301f69518 100644 (file)
   * No flags defined yet.
 --- a/net/core/utils.c
 +++ b/net/core/utils.c
-@@ -424,8 +424,14 @@ void inet_proto_csum_replace16(__sum16 *
+@@ -441,8 +441,14 @@ void inet_proto_csum_replace16(__sum16 *
                               bool pseudohdr)
  {
        __be32 diff[] = {
index 6e655ac802c2ac8d72999c64948c61bc5c98ff51..cdeb1f96e927e7c886cce12135855447d433491a 100644 (file)
@@ -19,7 +19,7 @@ Subject: [PATCH 210/210] b44: register adm switch
  
  #include <linux/uaccess.h>
  #include <asm/io.h>
-@@ -2248,6 +2250,69 @@ static void b44_adjust_link(struct net_d
+@@ -2251,6 +2253,69 @@ static void b44_adjust_link(struct net_d
        }
  }
  
@@ -89,7 +89,7 @@ Subject: [PATCH 210/210] b44: register adm switch
  static int b44_register_phy_one(struct b44 *bp)
  {
        struct mii_bus *mii_bus;
-@@ -2283,6 +2348,9 @@ static int b44_register_phy_one(struct b
+@@ -2286,6 +2351,9 @@ static int b44_register_phy_one(struct b
        if (!mdiobus_is_registered_device(bp->mii_bus, bp->phy_addr) &&
            (sprom->boardflags_lo & (B44_BOARDFLAG_ROBO | B44_BOARDFLAG_ADM))) {
  
@@ -99,7 +99,7 @@ Subject: [PATCH 210/210] b44: register adm switch
                dev_info(sdev->dev,
                         "could not find PHY at %i, use fixed one\n",
                         bp->phy_addr);
-@@ -2477,6 +2545,7 @@ static void b44_remove_one(struct ssb_de
+@@ -2480,6 +2548,7 @@ static void b44_remove_one(struct ssb_de
        unregister_netdev(dev);
        if (bp->flags & B44_FLAG_EXTERNAL_PHY)
                b44_unregister_phy_one(bp);
index 5620d5cd5f2e04db098ba79fc21afba57984d967..bff60521089848b42251948789fb467101519fb2 100644 (file)
@@ -43,7 +43,7 @@
  
        if (bp->flags & B44_FLAG_EXTERNAL_PHY)
                return 0;
-@@ -2178,6 +2203,8 @@ static int b44_get_invariants(struct b44
+@@ -2181,6 +2206,8 @@ static int b44_get_invariants(struct b44
         * valid PHY address. */
        bp->phy_addr &= 0x1F;
  
index c2becac712cbd41a5bae62194bb855484312dd2d..42478d475ac0ae6e88aeb4701c1d39a4a5877ddb 100644 (file)
@@ -4,7 +4,7 @@ Signed-off-by: Mathias Adam <m.adam--openwrt@adamis.de>
 
 --- a/drivers/watchdog/Kconfig
 +++ b/drivers/watchdog/Kconfig
-@@ -1472,6 +1472,15 @@ config WDT_MTX1
+@@ -1473,6 +1473,15 @@ config WDT_MTX1
          Hardware driver for the MTX-1 boards. This is a watchdog timer that
          will reboot the machine after a 100 seconds timer expired.
  
index d79b2d0b706c0b9dbf2424a624ce47fb3d627e01..446ba6cdcdb98c1dfb2f519bc232fe25ecc8639a 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
 
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -1226,6 +1226,18 @@ static const struct flash_info *spi_nor_
+@@ -1230,6 +1230,18 @@ static const struct flash_info *spi_nor_
        }
        dev_err(nor->dev, "unrecognized JEDEC id bytes: %02x, %02x, %02x\n",
                id[0], id[1], id[2]);
index 81a672b0fd83613582db5c33c3fd8c816357fd02..c53963c5304f5cb305bd141fac42a778f5754253 100644 (file)
@@ -114,7 +114,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  config MODULES_TREE_LOOKUP
 --- a/kernel/module.c
 +++ b/kernel/module.c
-@@ -3022,9 +3022,11 @@ static struct module *setup_load_info(st
+@@ -3024,9 +3024,11 @@ static struct module *setup_load_info(st
  
  static int check_modinfo(struct module *mod, struct load_info *info, int flags)
  {
@@ -127,7 +127,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (flags & MODULE_INIT_IGNORE_VERMAGIC)
                modmagic = NULL;
  
-@@ -3045,6 +3047,7 @@ static int check_modinfo(struct module *
+@@ -3047,6 +3049,7 @@ static int check_modinfo(struct module *
                                mod->name);
                add_taint_module(mod, TAINT_OOT_MODULE, LOCKDEP_STILL_OK);
        }
index b77ab89e666e5dae330a605a875cf3786e131b4b..3b219f46b2eae387d78f740810913585acebe613 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -1032,6 +1032,7 @@ static const struct flash_info spi_nor_i
+@@ -1037,6 +1037,7 @@ static const struct flash_info spi_nor_i
        { "mx25l12805d", INFO(0xc22018, 0, 64 * 1024, 256, 0) },
        { "mx25l12855e", INFO(0xc22618, 0, 64 * 1024, 256, 0) },
        { "mx25l25635e", INFO(0xc22019, 0, 64 * 1024, 512, SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ) },
@@ -8,7 +8,7 @@
        { "mx25u25635f", INFO(0xc22539, 0, 64 * 1024, 512, SECT_4K | SPI_NOR_4B_OPCODES) },
        { "mx25l25655e", INFO(0xc22619, 0, 64 * 1024, 512, 0) },
        { "mx66l51235l", INFO(0xc2201a, 0, 64 * 1024, 1024, SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ | SPI_NOR_4B_OPCODES) },
-@@ -1205,11 +1206,12 @@ static const struct flash_info spi_nor_i
+@@ -1209,11 +1210,12 @@ static const struct flash_info spi_nor_i
        { },
  };
  
@@ -23,7 +23,7 @@
  
        tmp = nor->read_reg(nor, SPINOR_OP_RDID, id, SPI_NOR_MAX_ID_LEN);
        if (tmp < 0) {
-@@ -1220,10 +1222,16 @@ static const struct flash_info *spi_nor_
+@@ -1224,10 +1226,16 @@ static const struct flash_info *spi_nor_
        for (tmp = 0; tmp < ARRAY_SIZE(spi_nor_ids) - 1; tmp++) {
                info = &spi_nor_ids[tmp];
                if (info->id_len) {
@@ -42,7 +42,7 @@
        dev_err(nor->dev, "unrecognized JEDEC id bytes: %02x, %02x, %02x\n",
                id[0], id[1], id[2]);
        return ERR_PTR(-ENODEV);
-@@ -2683,7 +2691,7 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -2687,7 +2695,7 @@ int spi_nor_scan(struct spi_nor *nor, co
                info = spi_nor_match_id(name);
        /* Try to auto-detect if chip name wasn't specified or not found */
        if (!info)
@@ -51,7 +51,7 @@
        if (IS_ERR_OR_NULL(info))
                return -ENOENT;
  
-@@ -2694,7 +2702,7 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -2698,7 +2706,7 @@ int spi_nor_scan(struct spi_nor *nor, co
        if (name && info->id_len) {
                const struct flash_info *jinfo;
  
index 0986d99074b95f2177c1ef58136858c62f271da6..2bd18ffa193e6fe912ce8ea027b99677a39c266f 100644 (file)
@@ -11,7 +11,7 @@ the ubi volume created by the other.
 ---
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -1031,7 +1031,7 @@ static const struct flash_info spi_nor_i
+@@ -1036,7 +1036,7 @@ static const struct flash_info spi_nor_i
        { "mx25u6435f",  INFO(0xc22537, 0, 64 * 1024, 128, SECT_4K) },
        { "mx25l12805d", INFO(0xc22018, 0, 64 * 1024, 256, 0) },
        { "mx25l12855e", INFO(0xc22618, 0, 64 * 1024, 256, 0) },
index a569dff7d60ddb4422dbd70e69b219d560f22bd6..2aa77f1a303970f6a211c63656f314f2dd40a2a3 100644 (file)
@@ -346,7 +346,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
        return 0;
  
  err4:
-@@ -1073,6 +1225,8 @@ static void dwc3_get_properties(struct d
+@@ -1076,6 +1228,8 @@ static void dwc3_get_properties(struct d
                                &hird_threshold);
        dwc->usb3_lpm_capable = device_property_read_bool(dev,
                                "snps,usb3_lpm_capable");
@@ -355,7 +355,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
  
        dwc->disable_scramble_quirk = device_property_read_bool(dev,
                                "snps,disable_scramble_quirk");
-@@ -1105,8 +1259,16 @@ static void dwc3_get_properties(struct d
+@@ -1108,8 +1262,16 @@ static void dwc3_get_properties(struct d
        dwc->dis_tx_ipgap_linecheck_quirk = device_property_read_bool(dev,
                                "snps,dis-tx-ipgap-linecheck-quirk");
  
@@ -372,7 +372,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
        device_property_read_u8(dev, "snps,tx_de_emphasis",
                                &tx_de_emphasis);
        device_property_read_string(dev, "snps,hsphy_interface",
-@@ -1117,6 +1279,9 @@ static void dwc3_get_properties(struct d
+@@ -1120,6 +1282,9 @@ static void dwc3_get_properties(struct d
        dwc->dis_metastability_quirk = device_property_read_bool(dev,
                                "snps,dis_metastability_quirk");
  
@@ -382,7 +382,7 @@ Signed-off-by: Zhao Chenhui <chenhui.zhao@freescale.com>
        dwc->lpm_nyet_threshold = lpm_nyet_threshold;
        dwc->tx_de_emphasis = tx_de_emphasis;
  
-@@ -1368,12 +1533,14 @@ static int dwc3_resume_common(struct dwc
+@@ -1371,12 +1536,14 @@ static int dwc3_resume_common(struct dwc
  
        switch (dwc->dr_mode) {
        case USB_DR_MODE_PERIPHERAL:
index 470aa683fabe5994025ba5d1d978ce83f453ca0b..5c8cd44182dde31f1cb25c85537de62c2fb68a38 100644 (file)
@@ -158,7 +158,7 @@ Signed-off-by: Signed-off-by: Biwen Li <biwen.li@nxp.com>
        if (kvm_is_device_pfn(pfn)) {
                mem_type = PAGE_S2_DEVICE;
                flags |= KVM_S2PTE_FLAG_IS_IOMAP;
-@@ -1918,6 +1961,9 @@ int kvm_arch_prepare_memory_region(struc
+@@ -1919,6 +1962,9 @@ int kvm_arch_prepare_memory_region(struc
                        gpa_t gpa = mem->guest_phys_addr +
                                    (vm_start - mem->userspace_addr);
                        phys_addr_t pa;
@@ -168,7 +168,7 @@ Signed-off-by: Signed-off-by: Biwen Li <biwen.li@nxp.com>
  
                        pa = (phys_addr_t)vma->vm_pgoff << PAGE_SHIFT;
                        pa += vm_start - vma->vm_start;
-@@ -1928,9 +1974,13 @@ int kvm_arch_prepare_memory_region(struc
+@@ -1929,9 +1975,13 @@ int kvm_arch_prepare_memory_region(struc
                                goto out;
                        }
  
index fa1cdf075acd17f8299973df89b44595554506a1..e3561016838bbff83f81259de60fe79e068fc941 100644 (file)
@@ -1512,7 +1512,7 @@ Signed-off-by: Yogesh Gaur <yogeshnarayan.gaur@nxp.com>
        case SNOR_MFR_MICRON:
                /* Some Micron need WREN command; all will accept it */
                need_wren = true;
-@@ -1039,7 +1040,7 @@ static const struct flash_info spi_nor_i
+@@ -1044,7 +1045,7 @@ static const struct flash_info spi_nor_i
        { "mx66l1g45g",  INFO(0xc2201b, 0, 64 * 1024, 2048, SECT_4K | SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ) },
        { "mx66l1g55g",  INFO(0xc2261b, 0, 64 * 1024, 2048, SPI_NOR_QUAD_READ) },
  
@@ -1521,7 +1521,7 @@ Signed-off-by: Yogesh Gaur <yogeshnarayan.gaur@nxp.com>
        { "n25q016a",    INFO(0x20bb15, 0, 64 * 1024,   32, SECT_4K | SPI_NOR_QUAD_READ) },
        { "n25q032",     INFO(0x20ba16, 0, 64 * 1024,   64, SPI_NOR_QUAD_READ) },
        { "n25q032a",    INFO(0x20bb16, 0, 64 * 1024,   64, SPI_NOR_QUAD_READ) },
-@@ -1054,6 +1055,12 @@ static const struct flash_info spi_nor_i
+@@ -1059,6 +1060,12 @@ static const struct flash_info spi_nor_i
        { "n25q00",      INFO(0x20ba21, 0, 64 * 1024, 2048, SECT_4K | USE_FSR | SPI_NOR_QUAD_READ | NO_CHIP_ERASE) },
        { "n25q00a",     INFO(0x20bb21, 0, 64 * 1024, 2048, SECT_4K | USE_FSR | SPI_NOR_QUAD_READ | NO_CHIP_ERASE) },
  
@@ -1534,7 +1534,7 @@ Signed-off-by: Yogesh Gaur <yogeshnarayan.gaur@nxp.com>
        /* PMC */
        { "pm25lv512",   INFO(0,        0, 32 * 1024,    2, SECT_4K_PMC) },
        { "pm25lv010",   INFO(0,        0, 32 * 1024,    4, SECT_4K_PMC) },
-@@ -2435,6 +2442,7 @@ static int spi_nor_init_params(struct sp
+@@ -2439,6 +2446,7 @@ static int spi_nor_init_params(struct sp
                        params->quad_enable = macronix_quad_enable;
                        break;
  
@@ -1542,7 +1542,7 @@ Signed-off-by: Yogesh Gaur <yogeshnarayan.gaur@nxp.com>
                case SNOR_MFR_MICRON:
                        break;
  
-@@ -2753,7 +2761,8 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -2757,7 +2765,8 @@ int spi_nor_scan(struct spi_nor *nor, co
        mtd->_read = spi_nor_read;
  
        /* NOR protection support for STmicro/Micron chips and similar */
index 216bef0c3fd2dad622fbcb1609bc4e779c1b95a0..6cfc43423a72b6a2cb5c342aa32cd14c0305a7a9 100644 (file)
@@ -5618,7 +5618,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  static void quirk_no_pm_reset(struct pci_dev *dev)
  {
        /*
-@@ -4884,3 +4891,11 @@ static void quirk_no_ats(struct pci_dev
+@@ -4918,3 +4925,11 @@ static void quirk_no_ats(struct pci_dev
  DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_ATI, 0x98e4, quirk_no_ats);
  DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_ATI, 0x6900, quirk_no_ats);
  #endif /* CONFIG_PCI_ATS */
index a9728cc05b01c20853d31cc703c9f013c9e34dd6..55e7209ce37e5633da1a61b21a4f4d669d73fc9d 100644 (file)
@@ -124,7 +124,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  L:    keyrings@vger.kernel.org
 --- a/drivers/tee/optee/Kconfig
 +++ b/drivers/tee/optee/Kconfig
-@@ -5,3 +5,11 @@ config OPTEE
+@@ -6,3 +6,11 @@ config OPTEE
        help
          This implements the OP-TEE Trusted Execution Environment (TEE)
          driver.
index 744245499f9b2c2a9d379c979f269b98efb19ada..1546e4b6a77d519c0c5637229aa4e079e122498f 100644 (file)
@@ -718,7 +718,7 @@ Signed-off-by: Yogesh Gaur <yogeshnarayan.gaur@nxp.com>
  
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -1154,6 +1154,11 @@ static const struct flash_info spi_nor_i
+@@ -1159,6 +1159,11 @@ static const struct flash_info spi_nor_i
        { "w25x40", INFO(0xef3013, 0, 64 * 1024,  8,  SECT_4K) },
        { "w25x80", INFO(0xef3014, 0, 64 * 1024,  16, SECT_4K) },
        { "w25x16", INFO(0xef3015, 0, 64 * 1024,  32, SECT_4K) },
index 69dd1305d74ef4e0d264073619626969af21b4ed..087798e3d813ed3c878348de6dae64add7e51106 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/Kconfig
 +++ b/arch/powerpc/Kconfig
-@@ -836,6 +836,14 @@ config CMDLINE_FORCE
+@@ -837,6 +837,14 @@ config CMDLINE_FORCE
          This is useful if you cannot or don't want to change the
          command-line options your boot loader passes to the kernel.
  
index f35b3901e0f355650cea1306b3d09068c5bb22c0..065a0b77bcd931766a53c76dffcf2621304c47d7 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Abhimanyu Vishwakarma <Abhimanyu.Vishwakarma@imgtec.com>
 
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -2667,6 +2667,7 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -2671,6 +2671,7 @@ int spi_nor_scan(struct spi_nor *nor, co
        struct device *dev = nor->dev;
        struct mtd_info *mtd = &nor->mtd;
        struct device_node *np = spi_nor_get_flash_node(nor);
@@ -18,7 +18,7 @@ Signed-off-by: Abhimanyu Vishwakarma <Abhimanyu.Vishwakarma@imgtec.com>
        int ret;
        int i;
  
-@@ -2742,7 +2743,12 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -2746,7 +2747,12 @@ int spi_nor_scan(struct spi_nor *nor, co
                spi_nor_wait_till_ready(nor);
        }
  
index 0b305a8105d7ed721f11871eef717acf73be81ba..7ed1a616f617e5f1fb67b3d1173bd73129096423 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/media/usb/uvc/uvc_driver.c
 +++ b/drivers/media/usb/uvc/uvc_driver.c
-@@ -2737,6 +2737,18 @@ static const struct usb_device_id uvc_id
+@@ -2749,6 +2749,18 @@ static const struct usb_device_id uvc_id
          .bInterfaceSubClass   = 1,
          .bInterfaceProtocol   = 0,
          .driver_info          = UVC_QUIRK_FORCE_Y8 },
index dee65a839426e336e608d1d5796cc9b575545796..aa2fb60a2b8dbd21351a988f89cd35354e725bde 100644 (file)
@@ -116,7 +116,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        spi_nor_unlock_and_unprep(nor, SPI_NOR_OPS_LOCK);
        return ret;
-@@ -1177,7 +1229,7 @@ static const struct flash_info spi_nor_i
+@@ -1182,7 +1234,7 @@ static const struct flash_info spi_nor_i
        { "w25q80", INFO(0xef5014, 0, 64 * 1024,  16, SECT_4K) },
        { "w25q80bl", INFO(0xef4014, 0, 64 * 1024,  16, SECT_4K) },
        { "w25q128", INFO(0xef4018, 0, 64 * 1024, 256, SECT_4K) },
@@ -125,7 +125,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        { "w25m512jv", INFO(0xef7119, 0, 64 * 1024, 1024,
                        SECT_4K | SPI_NOR_QUAD_READ | SPI_NOR_DUAL_READ) },
  
-@@ -1241,6 +1293,9 @@ static int spi_nor_read(struct mtd_info
+@@ -1245,6 +1297,9 @@ static int spi_nor_read(struct mtd_info
        if (ret)
                return ret;
  
@@ -135,7 +135,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        while (len) {
                loff_t addr = from;
  
-@@ -1265,6 +1320,18 @@ static int spi_nor_read(struct mtd_info
+@@ -1269,6 +1324,18 @@ static int spi_nor_read(struct mtd_info
        ret = 0;
  
  read_err:
@@ -154,7 +154,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        spi_nor_unlock_and_unprep(nor, SPI_NOR_OPS_READ);
        return ret;
  }
-@@ -1366,6 +1433,10 @@ static int spi_nor_write(struct mtd_info
+@@ -1370,6 +1437,10 @@ static int spi_nor_write(struct mtd_info
        if (ret)
                return ret;
  
@@ -165,7 +165,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        for (i = 0; i < len; ) {
                ssize_t written;
                loff_t addr = to + i;
-@@ -1406,6 +1477,7 @@ static int spi_nor_write(struct mtd_info
+@@ -1410,6 +1481,7 @@ static int spi_nor_write(struct mtd_info
        }
  
  write_err:
@@ -173,7 +173,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        spi_nor_unlock_and_unprep(nor, SPI_NOR_OPS_WRITE);
        return ret;
  }
-@@ -2822,8 +2894,10 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -2826,8 +2898,10 @@ int spi_nor_scan(struct spi_nor *nor, co
        } else if (mtd->size > 0x1000000) {
                /* enable 4-byte addressing if the device exceeds 16MiB */
                nor->addr_width = 4;
index 9ea2a11354d09bb6891b78beb490dd1ecc54e29a..a68693798978cfa67f4f82beedbb9c3d8477f0f7 100644 (file)
@@ -33,7 +33,7 @@
  /*
   * Write status register 1 byte
   * Returns negative if error occurred.
-@@ -2894,9 +2903,16 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -2898,9 +2907,16 @@ int spi_nor_scan(struct spi_nor *nor, co
        } else if (mtd->size > 0x1000000) {
                /* enable 4-byte addressing if the device exceeds 16MiB */
                nor->addr_width = 4;
index e21fd7c2bc415d595a8457053015982a3264249d..0a3a65d70a76e02309d2d7d4d61a99d103f12eb9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -1061,6 +1061,11 @@ static const struct flash_info spi_nor_i
+@@ -1066,6 +1066,11 @@ static const struct flash_info spi_nor_i
                        SECT_4K | SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ |
                        SPI_NOR_HAS_LOCK | SPI_NOR_HAS_TB)
        },
index 831350546dcd5d0cf2adba4928ea673043a7c6c2..8b59a106e1b215b951de3516c15de10b8a9b2474 100644 (file)
@@ -10,7 +10,7 @@ For reference see:
 
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -1098,6 +1098,7 @@ static const struct flash_info spi_nor_i
+@@ -1103,6 +1103,7 @@ static const struct flash_info spi_nor_i
        { "mx25l12805d", INFO(0xc22018, 0, 64 * 1024, 256, 0) },
        { "mx25l12855e", INFO(0xc22618, 0, 64 * 1024, 256, 0) },
        { "mx25l25635e", INFO(0xc22019, 0, 64 * 1024, 512, SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ) },
@@ -18,7 +18,7 @@ For reference see:
        { "mx25u25635f", INFO(0xc22539, 0, 64 * 1024, 512, SECT_4K | SPI_NOR_4B_OPCODES) },
        { "mx25l25655e", INFO(0xc22619, 0, 64 * 1024, 512, 0) },
        { "mx66l51235l", INFO(0xc2201a, 0, 64 * 1024, 1024, SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ | SPI_NOR_4B_OPCODES) },
-@@ -1271,11 +1272,12 @@ static const struct flash_info spi_nor_i
+@@ -1275,11 +1276,12 @@ static const struct flash_info spi_nor_i
        { },
  };
  
@@ -33,7 +33,7 @@ For reference see:
  
        tmp = nor->read_reg(nor, SPINOR_OP_RDID, id, SPI_NOR_MAX_ID_LEN);
        if (tmp < 0) {
-@@ -1286,10 +1288,16 @@ static const struct flash_info *spi_nor_
+@@ -1290,10 +1292,16 @@ static const struct flash_info *spi_nor_
        for (tmp = 0; tmp < ARRAY_SIZE(spi_nor_ids) - 1; tmp++) {
                info = &spi_nor_ids[tmp];
                if (info->id_len) {
@@ -52,7 +52,7 @@ For reference see:
        dev_err(nor->dev, "unrecognized JEDEC id bytes: %02x, %02x, %02x\n",
                id[0], id[1], id[2]);
        return ERR_PTR(-ENODEV);
-@@ -2769,7 +2777,7 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -2773,7 +2781,7 @@ int spi_nor_scan(struct spi_nor *nor, co
                info = spi_nor_match_id(name);
        /* Try to auto-detect if chip name wasn't specified or not found */
        if (!info)
@@ -61,7 +61,7 @@ For reference see:
        if (IS_ERR_OR_NULL(info))
                return -ENOENT;
  
-@@ -2780,7 +2788,7 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -2784,7 +2792,7 @@ int spi_nor_scan(struct spi_nor *nor, co
        if (name && info->id_len) {
                const struct flash_info *jinfo;