add a feature flag for device tree support
authorImre Kaloz <kaloz@openwrt.org>
Fri, 22 Nov 2013 12:01:01 +0000 (12:01 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 22 Nov 2013 12:01:01 +0000 (12:01 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 38893

Config.in
include/target.mk
scripts/metadata.pl
target/Config.in

index bf1e139f2e666d4b1de31a76ecf846c1f233b019..5607e55d4d1979f7421eb35bf7c1d15b47ec75fd 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -204,7 +204,7 @@ menu "Target Images"
 
        config TARGET_ROOTFS_INCLUDE_DTB
                bool "Include DTB in root filesystem"
-               depends on TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS
+               depends on USES_DEVICETREE && (TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS)
                default n if USES_UBIFS
                help
                  Include the device tree blob file(s) in the rootfs. Typically the DTBs
index 467ef357666f4bedd6f1b84d4d586bc1c7c4b0cc..acb9adf584e27690a232b1a01a930dd48306609f 100644 (file)
@@ -167,6 +167,9 @@ ifeq ($(DUMP),1)
     .SILENT: $(TMP_CONFIG)
     .PRECIOUS: $(TMP_CONFIG)
 
+    ifneq ($(CONFIG_OF),)
+      FEATURES += dt
+    endif
     ifneq ($(CONFIG_GENERIC_GPIO)$(CONFIG_GPIOLIB),)
       FEATURES += gpio
     endif
index ddcf50bf32a3b9a1e0ab4770b4a97443787e109e..135ec9a9389c00f185ed7424767f203d08a3a7fb 100755 (executable)
@@ -158,6 +158,7 @@ sub target_config_features(@) {
                /broken/ and $ret .= "\tdepends on BROKEN\n";
                /audio/ and $ret .= "\tselect AUDIO_SUPPORT\n";
                /display/ and $ret .= "\tselect DISPLAY_SUPPORT\n";
+               /dt/ and $ret .= "\tselect USES_DEVICETREE\n";
                /gpio/ and $ret .= "\tselect GPIO_SUPPORT\n";
                /pci/ and $ret .= "\tselect PCI_SUPPORT\n";
                /pcie/ and $ret .= "\tselect PCIE_SUPPORT\n";
index 7f694e4c8badc436bc76d4d124322d9cecee9818..bb442025f54e71d407ac87499d3e9ffec4a161f6 100644 (file)
@@ -39,6 +39,9 @@ config RTC_SUPPORT
 config BIG_ENDIAN
        bool
 
+config USES_DEVICETREE
+       bool
+
 config USES_INITRAMFS
        bool