build: Add KBUILD_HOSTLDLIBS
authorHauke Mehrtens <hauke.mehrtens@intel.com>
Fri, 17 Jan 2020 17:47:33 +0000 (18:47 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 26 Jan 2020 18:20:08 +0000 (19:20 +0100)
In Linux kernel commit 8377bd2b9ee1 ("kbuild: Rename HOST_LOADLIBES to
KBUILD_HOSTLDLIBS") HOST_LOADLIBES was renamed to KBUILD_HOSTLDLIBS.
This patch adapts the OpenWrt kernel build to this new variable. Without
this change the kernel host tools would not link against the libraries
found in the staging directory.

Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
include/kernel.mk

index 439e910ebf0c173a97ca35ea9d6fef91fb350714..02d0949a7210f0c0b8b72a1ffdad746b88b893d2 100644 (file)
@@ -114,6 +114,7 @@ KERNEL_MAKE_FLAGS = \
        KBUILD_BUILD_TIMESTAMP="$(KBUILD_BUILD_TIMESTAMP)" \
        KBUILD_BUILD_VERSION="0" \
        HOST_LOADLIBES="-L$(STAGING_DIR_HOST)/lib" \
+       KBUILD_HOSTLDLIBS="-L$(STAGING_DIR_HOST)/lib" \
        CONFIG_SHELL="$(BASH)" \
        $(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
        $(if $(PKG_BUILD_ID),LDFLAGS_MODULE=--build-id=0x$(PKG_BUILD_ID)) \