toolchain/nasm: force ar and ranlib only on macOSX
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 8 Jul 2018 10:48:13 +0000 (12:48 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 8 Jul 2018 12:22:54 +0000 (14:22 +0200)
On Debian 9 nasm does not build when we force it to use ranlib, for
macOSX this is needed. Only force this on macOSX and not on any other
OS, this should fix the build of nasm on Linux systems. On my Debian
system the nasm configure script selects  gcc-ranlib and gcc-ar instead.

Fixes: d3a7587eb95 ("toolchain/nasm: fix missing AR/RANLIB variables")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
toolchain/nasm/Makefile

index 8d071033c7dc5ba08aa50520f1663541a5051035..31166358fd963ec01240bf8a4b97d65b7ce4cbc0 100644 (file)
@@ -24,9 +24,11 @@ HOST_CONFIGURE_ARGS+= \
                --disable-gdb \
                $(SOFT_FLOAT_CONFIG_OPTION) \
 
-HOST_MAKE_FLAGS = \
-       AR=ar \
-       RANLIB=ranlib
+ifeq ($(HOST_OS),Darwin)
+       HOST_MAKE_FLAGS = \
+               AR=ar \
+               RANLIB=ranlib
+endif
 
 define Host/Prepare
        $(call Host/Prepare/Default)