kernel: bump 4.19 to 4.19.123
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 14 May 2020 10:14:24 +0000 (12:14 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 14 May 2020 11:33:40 +0000 (13:33 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/bcm27xx/patches-4.19/950-0029-mm-Remove-the-PFN-busy-warning.patch
target/linux/bcm27xx/patches-4.19/950-0121-hid-Reduce-default-mouse-polling-interval-to-60Hz.patch
target/linux/bcm27xx/patches-4.19/950-0574-usbhid-call-usb_fixup_endpoint-after-mangling-interv.patch
target/linux/generic/pending-4.19/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch

index aea1d1a07566bca65a9b89ac0bd96cd516bfb6ea..2fa08d0532b5d42ce6f612ff2eff1515c6f21ec8 100644 (file)
@@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-4.14 = .180
-LINUX_VERSION-4.19 = .122
+LINUX_VERSION-4.19 = .123
 LINUX_VERSION-5.4 = .40
 
 LINUX_KERNEL_HASH-4.14.180 = 444ef973d9b6a6ea174e4a9086f0aea980d8575d13302e431ad688f22e27ed0e
-LINUX_KERNEL_HASH-4.19.122 = 5050268ec5cf003d96366d1611ecfa4ab6974125d6fa26cea1ccb81dd4df00a5
+LINUX_KERNEL_HASH-4.19.123 = a79914d31a8d8c6b0e2bb0f2b143d615fe8a6c4dd2e0f36e97aa20efd69a993f
 LINUX_KERNEL_HASH-5.4.40 = 83563f027687ecaafb41d0d2d52056f40ec9822f8a9e43592e215349730020ab
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index ada81969b056f2ff24cf190288c4023bd748c7b2..5cc53be0bee497fb72e3c969fa9d334e4b2ca060 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Eric Anholt <eric@anholt.net>
 
 --- a/mm/page_alloc.c
 +++ b/mm/page_alloc.c
-@@ -8007,8 +8007,6 @@ int alloc_contig_range(unsigned long sta
+@@ -8008,8 +8008,6 @@ int alloc_contig_range(unsigned long sta
  
        /* Make sure the range is really isolated. */
        if (test_pages_isolated(outer_start, end, false)) {
index 4851e066acc95c82ff847684bf2b16dd1a233571..794b209d29189c489ec3f38668a7ba2710143ad7 100644 (file)
@@ -19,7 +19,7 @@ Reduces overhead when using X
  module_param_named(mousepoll, hid_mousepoll_interval, uint, 0644);
  MODULE_PARM_DESC(mousepoll, "Polling interval of mice");
  
-@@ -1104,7 +1104,9 @@ static int usbhid_start(struct hid_devic
+@@ -1117,7 +1117,9 @@ static int usbhid_start(struct hid_devic
                 */
                switch (hid->collection->usage) {
                case HID_GD_MOUSE:
index 59263196c879dc37186c495ac38f43f3a9522cf4..71adfaf9b62ca9a5b84d79317a46f2a4b862742a 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
 
 --- a/drivers/hid/usbhid/hid-core.c
 +++ b/drivers/hid/usbhid/hid-core.c
-@@ -1118,6 +1118,7 @@ static int usbhid_start(struct hid_devic
+@@ -1131,6 +1131,7 @@ static int usbhid_start(struct hid_devic
                                interval = hid_kbpoll_interval;
                        break;
                }
index ec541a865c81039bf55075bad4967d6c7eb4ff8b..54ae1829ee04f69be4ca8a26883f4689074df60f 100644 (file)
@@ -71,7 +71,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
 
 --- a/mm/page_alloc.c
 +++ b/mm/page_alloc.c
-@@ -6400,7 +6400,7 @@ static void __ref alloc_node_mem_map(str
+@@ -6401,7 +6401,7 @@ static void __ref alloc_node_mem_map(str
                mem_map = NODE_DATA(0)->node_mem_map;
  #if defined(CONFIG_HAVE_MEMBLOCK_NODE_MAP) || defined(CONFIG_FLATMEM)
                if (page_to_pfn(mem_map) != pgdat->node_start_pfn)