kernel: bump 5.4 to 5.4.39
authorPetr Štetiar <ynezz@true.cz>
Thu, 7 May 2020 07:29:27 +0000 (09:29 +0200)
committerPetr Štetiar <ynezz@true.cz>
Thu, 7 May 2020 10:53:06 +0000 (12:53 +0200)
Refreshed patches.

Run tested: qemu-x86-64
Build tested: x86/64, imx6, sunxi/a53, layerscape/armv7+armv8_64b

Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/kernel-version.mk
target/linux/generic/hack-5.4/904-debloat_dma_buf.patch
target/linux/mediatek/patches-5.4/0999-hnat.patch
target/linux/mediatek/patches-5.4/1000-eth-gdm-config-backport.patch
target/linux/mediatek/patches-5.4/1001-eth-mtk-disable-TBDDONE-support.patch

index eccea839c32bd4d795028997722338e811026495..2e8c663063c25514f2c29384be1d1ec7c2140166 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.14 = .176
 LINUX_VERSION-4.19 = .115
-LINUX_VERSION-5.4 = .38
+LINUX_VERSION-5.4 = .39
 
 LINUX_KERNEL_HASH-4.14.176 = bcae0956baaeb55dab5bad0401873fbc5baaa7fbe957ea6d27a5ab241cec5ca2
 LINUX_KERNEL_HASH-4.19.115 = 11b2d97c8ea5ceb40c5e1d0bb87ad5b2b8c84560181bc60c0d28ec3a3e3801c2
-LINUX_KERNEL_HASH-5.4.38 = e72b9fa4e3a222d42d64dce9915e5b18f1b75ae722d529a1e560ced2e5d0f30e
+LINUX_KERNEL_HASH-5.4.39 = 5141965a61a7b1c538443782ec3ef25fe0c3f9cd4d70c4e9f969d16883f365c8
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 1b103d5e0088056e5ef50a83af56446e5436930e..4221e6a0350f6cdc49890169f7571ef447debe49 100644 (file)
@@ -45,7 +45,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        selftest.o \
 --- a/drivers/dma-buf/dma-buf.c
 +++ b/drivers/dma-buf/dma-buf.c
-@@ -1298,4 +1298,5 @@ static void __exit dma_buf_deinit(void)
+@@ -1299,4 +1299,5 @@ static void __exit dma_buf_deinit(void)
        dma_buf_uninit_debugfs();
        kern_unmount(dma_buf_mnt);
  }
index 66c29cf1c01e428b677a14983b77186dd2a388a5..f0af321fd8bb2f68f1e2c518a2e94331b1acb9a0 100644 (file)
  
  #include "mtk_eth_soc.h"
  
-@@ -1298,8 +1312,16 @@ static int mtk_poll_rx(struct napi_struc
+@@ -1298,8 +1300,16 @@ static int mtk_poll_rx(struct napi_struc
                    (trxd.rxd2 & RX_DMA_VTAG))
                        __vlan_hwaccel_put_tag(skb, htons(ETH_P_8021Q),
                                               RX_DMA_VID(trxd.rxd3));
  
                ring->data[idx] = new_data;
                rxd->rxd1 = (unsigned int)dma_addr;
-@@ -2216,6 +2238,9 @@ static int mtk_open(struct net_device *d
+@@ -2216,6 +2226,9 @@ static int mtk_open(struct net_device *d
                mtk_tx_irq_enable(eth, MTK_TX_DONE_INT);
                mtk_rx_irq_enable(eth, MTK_RX_DONE_INT);
                refcount_set(&eth->dma_refcnt, 1);
        }
        else
                refcount_inc(&eth->dma_refcnt);
-@@ -2274,6 +2299,9 @@ static int mtk_stop(struct net_device *d
+@@ -2274,6 +2287,9 @@ static int mtk_stop(struct net_device *d
  
        mtk_dma_free(eth);
  
        return 0;
  }
  
-@@ -2733,6 +2761,27 @@ static int mtk_set_rxnfc(struct net_devi
+@@ -2733,6 +2749,27 @@ static int mtk_set_rxnfc(struct net_devi
        return ret;
  }
  
  static const struct ethtool_ops mtk_ethtool_ops = {
        .get_link_ksettings     = mtk_get_link_ksettings,
        .set_link_ksettings     = mtk_set_link_ksettings,
-@@ -2764,6 +2813,9 @@ static const struct net_device_ops mtk_n
+@@ -2764,6 +2801,9 @@ static const struct net_device_ops mtk_n
  #ifdef CONFIG_NET_POLL_CONTROLLER
        .ndo_poll_controller    = mtk_poll_controller,
  #endif
  };
  
  static int mtk_add_mac(struct mtk_eth *eth, struct device_node *np)
-@@ -3097,6 +3149,7 @@ static const struct mtk_soc_data mt7622_
+@@ -3097,6 +3137,7 @@ static const struct mtk_soc_data mt7622_
        .hw_features = MTK_HW_FEATURES,
        .required_clks = MT7622_CLKS_BITMAP,
        .required_pctl = false,
index 29b5406baec1f2d5194e16be8c7c7e25a4f230ca..7b8d186aa41b789ab57e2e4010e8832e1e95e0e3 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN a/drivers/net/ethernet/mediatek/mtk_eth_soc.c b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
---- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c      2020-04-21 14:33:05.702816632 +0800
-+++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c      2020-04-21 14:33:19.590328084 +0800
-@@ -2191,6 +2191,31 @@
+--- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c
++++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
+@@ -2201,6 +2201,31 @@ static int mtk_start_dma(struct mtk_eth
        return 0;
  }
  
@@ -33,7 +32,7 @@ diff -urN a/drivers/net/ethernet/mediatek/mtk_eth_soc.c b/drivers/net/ethernet/m
  static int mtk_open(struct net_device *dev)
  {
        struct mtk_mac *mac = netdev_priv(dev);
-@@ -2211,6 +2236,8 @@
+@@ -2221,6 +2246,8 @@ static int mtk_open(struct net_device *d
                if (err)
                        return err;
  
@@ -42,7 +41,7 @@ diff -urN a/drivers/net/ethernet/mediatek/mtk_eth_soc.c b/drivers/net/ethernet/m
                napi_enable(&eth->tx_napi);
                napi_enable(&eth->rx_napi);
                mtk_tx_irq_enable(eth, MTK_TX_DONE_INT);
-@@ -2266,6 +2293,8 @@
+@@ -2276,6 +2303,8 @@ static int mtk_stop(struct net_device *d
        if (!refcount_dec_and_test(&eth->dma_refcnt))
                return 0;
  
@@ -51,7 +50,7 @@ diff -urN a/drivers/net/ethernet/mediatek/mtk_eth_soc.c b/drivers/net/ethernet/m
        mtk_tx_irq_disable(eth, MTK_TX_DONE_INT);
        mtk_rx_irq_disable(eth, MTK_RX_DONE_INT);
        napi_disable(&eth->tx_napi);
-@@ -2392,8 +2421,6 @@
+@@ -2402,8 +2431,6 @@ static int mtk_hw_init(struct mtk_eth *e
        mtk_w32(eth, 0, MTK_QDMA_DELAY_INT);
        mtk_tx_irq_disable(eth, ~0);
        mtk_rx_irq_disable(eth, ~0);
@@ -60,7 +59,7 @@ diff -urN a/drivers/net/ethernet/mediatek/mtk_eth_soc.c b/drivers/net/ethernet/m
  
        /* FE int grouping */
        mtk_w32(eth, MTK_TX_DONE_INT, MTK_PDMA_INT_GRP1);
-@@ -2402,19 +2429,6 @@
+@@ -2412,19 +2439,6 @@ static int mtk_hw_init(struct mtk_eth *e
        mtk_w32(eth, MTK_RX_DONE_INT, MTK_QDMA_INT_GRP2);
        mtk_w32(eth, 0x21021000, MTK_FE_INT_GRP);
  
@@ -80,9 +79,8 @@ diff -urN a/drivers/net/ethernet/mediatek/mtk_eth_soc.c b/drivers/net/ethernet/m
        return 0;
  
  err_disable_pm:
-diff -urN a/drivers/net/ethernet/mediatek/mtk_eth_soc.h b/drivers/net/ethernet/mediatek/mtk_eth_soc.h
---- a/drivers/net/ethernet/mediatek/mtk_eth_soc.h      2020-04-21 14:33:10.702640743 +0800
-+++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.h      2020-04-21 14:33:24.902141220 +0800
+--- a/drivers/net/ethernet/mediatek/mtk_eth_soc.h
++++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.h
 @@ -84,6 +84,8 @@
  #define MTK_GDMA_ICS_EN               BIT(22)
  #define MTK_GDMA_TCS_EN               BIT(21)
index 14c2e12a27aa0be7299e93c648d643f7cc7f42d5..ea1d1dce2e7ea98ae481e1816f5b570fe985eae0 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN a/drivers/net/ethernet/mediatek/mtk_eth_soc.c b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
---- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c       2020-04-21 14:33:05.702816632 +0800
-+++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c       2020-04-21 14:33:19.590328084 +0800
-@@ -1345,10 +1345,11 @@
+--- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c
++++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
+@@ -1355,10 +1355,11 @@ static int mtk_poll_tx_qdma(struct mtk_e
                u32 next_cpu = desc->txd2;
                int mac = 0;
  
@@ -14,7 +13,7 @@ diff -urN a/drivers/net/ethernet/mediatek/mtk_eth_soc.c b/drivers/net/ethernet/m
                tx_buf = mtk_desc_to_tx_buf(ring, desc);
                if (tx_buf->flags & MTK_TX_FLAGS_FPORT1)
                        mac = 1;
-@@ -2172,7 +2173,7 @@
+@@ -2182,7 +2183,7 @@ static int mtk_start_dma(struct mtk_eth
  
        if (MTK_HAS_CAPS(eth->soc->caps, MTK_QDMA)) {
                mtk_w32(eth,