config: ext4: drop option to set maximum number of inodes
authorJo-Philipp Wich <jo@mein.io>
Sat, 15 Oct 2016 23:59:43 +0000 (01:59 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 27 Oct 2016 17:24:38 +0000 (19:24 +0200)
There is very little practical use to limit the number of available inodes on
an ext4 filesystem and the make_ext4fs utility is able to calculate useful
defaults by itself.

Drop the option to make resulting ext4 filesystems more flexible by default.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Acked-by: Michael Heimpold <mhei@heimpold.de>
config/Config-images.in
include/image.mk

index 05b817bad4c9c2d98f7dc116cae0f897354dc49f..1a6951dfb781499bbe1c00ab5ae500e04d576973 100644 (file)
@@ -73,13 +73,6 @@ menu "Target Images"
                help
                  Build an ext4 root filesystem.
 
-               config TARGET_EXT4_MAXINODE
-                       int "Maximum number of inodes in root filesystem"
-                       depends on TARGET_ROOTFS_EXT4FS
-                       default 6000
-                       help
-                         Select the maximum number of inodes in the root filesystem.
-
                config TARGET_EXT4_RESERVED_PCT
                        int "Percentage of reserved blocks in root filesystem"
                        depends on TARGET_ROOTFS_EXT4FS
index 59dd66fa9c2b2a4e92ccdd90f2bb193c23d266a4..8b183ab58a839bbf936526411f9aafcdc1366ba6 100644 (file)
@@ -244,7 +244,6 @@ E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_PARTSIZE)*1024*1024)))
 define Image/mkfs/ext4
        $(STAGING_DIR_HOST)/bin/make_ext4fs \
                -l $(E2SIZE) -b $(CONFIG_TARGET_EXT4_BLOCKSIZE) \
-               -i $(CONFIG_TARGET_EXT4_MAXINODE) \
                $(if $(CONFIG_TARGET_EXT4_RESERVED_PCT),-m $(CONFIG_TARGET_EXT4_RESERVED_PCT)) \
                $(if $(CONFIG_TARGET_EXT4_JOURNAL),,-J) \
                $(if $(SOURCE_DATE_EPOCH),-T $(SOURCE_DATE_EPOCH)) \