rules.mk: drop `include_mk` build rule
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 24 Jan 2018 10:56:39 +0000 (12:56 +0200)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Fri, 26 Jan 2018 11:55:14 +0000 (12:55 +0100)
The only users of this were the python packages
from the `packages` feed.
The 2 python interpreters would export some mk
files (e.g. python-package.mk) and then other
python packages would include it via this rule.

But there's a few things wrong with this approach,
most of them drawing from the fact that python host
needs to be built first, to export these mk files.

By now all uses of include_mk have been corrected
in the feeds and this can be removed.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
rules.mk

index 9d8b9f8f90d91e2759bd1189c4dcdca56df537b8..84e0aaadc66b9f19e0e4456d8b6d4f181c2557fe 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -355,10 +355,6 @@ define shexport
 export $(call shvar,$(1))=$$(call $(1))
 endef
 
-define include_mk
-$(eval -include $(if $(DUMP),,$(STAGING_DIR)/mk/$(strip $(1))))
-endef
-
 # Execute commands under flock
 # $(1) => The shell expression.
 # $(2) => The lock name. If not given, the global lock will be used.