toolchain/gcc: eliminate uClibc atexit hack
authorRosen Penev <rosenp@gmail.com>
Sat, 18 Apr 2020 23:06:15 +0000 (16:06 -0700)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 26 Apr 2020 19:45:41 +0000 (21:45 +0200)
This seems to be over 10 years old. It doesn't seem to be needed anymore.

Tested on malta with uClibc (selected BROKEN).

Signed-off-by: Rosen Penev <rosenp@gmail.com>
toolchain/gcc/common.mk

index 090aa2447d89984d2c4133c78c5bac72b162ffd7..7fb30285aa80f5b4046e8cdd7bda2a4e92557ab8 100644 (file)
@@ -115,7 +115,8 @@ GCC_CONFIGURE:= \
                --with-mpfr=$(TOPDIR)/staging_dir/host \
                --with-mpc=$(TOPDIR)/staging_dir/host \
                --disable-decimal-float \
-               --with-diagnostics-color=auto-if-env
+               --with-diagnostics-color=auto-if-env \
+               --enable-__cxa_atexit
 ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
   GCC_CONFIGURE += --with-mips-plt
 endif
@@ -150,14 +151,6 @@ ifdef CONFIG_sparc
                --with-long-double-128
 endif
 
-ifeq ($(LIBC),uClibc)
-  GCC_CONFIGURE+= \
-               --disable-__cxa_atexit
-else
-  GCC_CONFIGURE+= \
-               --enable-__cxa_atexit
-endif
-
 ifneq ($(GCC_ARCH),)
   GCC_CONFIGURE+= --with-arch=$(GCC_ARCH)
 endif