rules.mk: MIPS16 builds get a different toolchain
authorFlorian Fainelli <florian@openwrt.org>
Fri, 5 Apr 2013 12:35:56 +0000 (12:35 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 5 Apr 2013 12:35:56 +0000 (12:35 +0000)
To be safe, build "m16" into the toolchain and target architecture the
same way mips32r2 does:

target-mips_r2_m16_uClibc-0.9.33.2
toolchain-mips_r2_m16_gcc-4.6-linaro_uClibc-0.9.33.2

Signed-off-by: Jay Carlson <nop@nop.com>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 36198

rules.mk

index ae7a8407e37564b12aa0186be13de78c9c3b8c8c..59ab50b92262510fbc7fab3d9f64aa3adaa655c0 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -65,6 +65,7 @@ ifneq ($(filter -mips%r2,$(TARGET_OPTIMIZATION)),)
 endif
 ifneq ($(findstring -mips16,$(TARGET_OPTIMIZATION)),)
   TARGET_ASFLAGS_OVERRIDE:=-mno-mips16
+  ARCH_SUFFIX:= $(ARCH_SUFFIX)_m16
 endif
 ifdef CONFIG_HAS_SPE_FPU
   TARGET_SUFFIX:=$(TARGET_SUFFIX)spe