build: fix xconfig target
authorleo chung <gewalalb@gmail.com>
Fri, 20 Sep 2019 05:33:58 +0000 (13:33 +0800)
committerPetr Štetiar <ynezz@true.cz>
Wed, 25 Sep 2019 10:50:24 +0000 (12:50 +0200)
`make xconfig` fails with following linking error of qconf binary:

 g++ -lQt5Widgets -lQt5Gui -lQt5Core -o qconf qconf.o zconf.tab.o
 /usr/bin/ld: qconf.o: in function ConfigList::metaObject() const': qconf.cc:(.text+0x3eb): undefined reference to QObjectData::dynamicMetaObject() const'
 /usr/bin/ld: qconf.o: in function `ConfigList::qt_metacast(char const*)': link error.

which is caused by the wrong order of the linked objects/libraries so
this patch reorders the linker's arguments which makes the qconf compile
again.

Signed-off-by: leo chung <gewalalb@gmail.com>
[commit subject and message tweaks, whitespace fix]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
scripts/config/Makefile

index 8b78d5a6824722ac56830bca63db6a0ff2d8fd95..0eac8edd228717dd45fcfa243193e82813d7ff8f 100644 (file)
@@ -40,7 +40,7 @@ mconf: $(mconf-objs) $(lxdialog-objs)
        $(CC) -o $@ $^ $(call check_lxdialog,ldflags $(CC))
 qconf: $(qconf-cxxobjs) $(qconf-objs)
 ifneq ($(DISTRO-PKG-CONFIG),)
-       $(CXX) $(HOSTLOADLIBES_qconf) -o $@ $^
+       $(CXX) -o $@ $^ $(HOSTLOADLIBES_qconf)
 else
        echo "You don't have 'pkg-config' installed. Cannot continue"
        echo "For now, you may use 'make menuconfig' instead of 'make xconfig'"