package/ncurses: change AR options to fix reproducible builds
authorAlexander Couzens <lynxis@fe80.eu>
Thu, 28 Feb 2019 17:43:38 +0000 (18:43 +0100)
committerAlexander Couzens <lynxis@fe80.eu>
Thu, 28 Feb 2019 18:09:35 +0000 (19:09 +0100)
ar has a deterministic (-D) and non-deterministic (-U) mode.
OpenWrt is already using the deterministic mode by default,
but ncurses' configure script force this to be non-deterministic.
Since autoreconf fails to generate a new configure, the configure script
is directly modified.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
package/libs/ncurses/Makefile
package/libs/ncurses/patches/103-ncurses-ar-determinism.patch [new file with mode: 0644]

index 604a02db52de5d4811a569c379a081c433138da1..8c961f30b23d863ef71bebd629c3c3f25741df91 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ncurses
 PKG_VERSION:=6.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/package/libs/ncurses/patches/103-ncurses-ar-determinism.patch b/package/libs/ncurses/patches/103-ncurses-ar-determinism.patch
new file mode 100644 (file)
index 0000000..d4c8f11
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/aclocal.m4
++++ b/aclocal.m4
+@@ -451,7 +451,7 @@ AC_REQUIRE([CF_PROG_AR])
+ AC_CACHE_CHECK(for options to update archives, cf_cv_ar_flags,[
+       cf_cv_ar_flags=unknown
+-      for cf_ar_flags in -curvU -curv curv -crv crv -cqv cqv -rv rv
++      for cf_ar_flags in -curvD -curv curv -crv crv -cqv cqv -rv rv
+       do
+               # check if $ARFLAGS already contains this choice
+--- a/configure
++++ b/configure
+@@ -4503,7 +4503,7 @@ if test "${cf_cv_ar_flags+set}" = set; t
+ else
+       cf_cv_ar_flags=unknown
+-      for cf_ar_flags in -curvU -curv curv -crv crv -cqv cqv -rv rv
++      for cf_ar_flags in -curvD -curv curv -crv crv -cqv cqv -rv rv
+       do
+               # check if $ARFLAGS already contains this choice