kernel: bump 4.14 to 4.14.166
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 20 Jan 2020 11:23:38 +0000 (12:23 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 20 Jan 2020 12:41:49 +0000 (13:41 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/layerscape/patches-4.14/301-arch-support-layerscape.patch
target/linux/layerscape/patches-4.14/821-smmu-support-layerscape.patch

index 63a6503cf547fdc555e23c702b3a800e316d22c7..07d5efe8bbe1911aa798ab851d0c272f4ab124a9 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .165
+LINUX_VERSION-4.14 = .166
 LINUX_VERSION-4.19 = .96
 
-LINUX_KERNEL_HASH-4.14.165 = b0aeb52386404f4e3546f93cf63c857025fc3117ff1b56e3499aa1eae6e088c7
+LINUX_KERNEL_HASH-4.14.166 = 8bb2bf811a2092933a2386a4e679cd0c88de979c10fbb463d8142add4e577c00
 LINUX_KERNEL_HASH-4.19.96 = 23c1d1d5ba7bc14f9850e5ce78006712fe6c65dedcf67d3c99cec9c16a631d4d
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 099b6031b54fb412c6513e1968e3830b7b57d4d8..59ed130567108948f8bd9b0236c24bd7b05788da 100644 (file)
@@ -285,7 +285,7 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
  #define PAGE_NONE             __pgprot(((_PAGE_DEFAULT) & ~PTE_VALID) | PTE_PROT_NONE | PTE_RDONLY | PTE_NG | PTE_PXN | PTE_UXN)
 --- a/arch/arm64/include/asm/pgtable.h
 +++ b/arch/arm64/include/asm/pgtable.h
-@@ -356,6 +356,11 @@ static inline int pmd_protnone(pmd_t pmd
+@@ -357,6 +357,11 @@ static inline int pmd_protnone(pmd_t pmd
        __pgprot_modify(prot, PTE_ATTRINDX_MASK, PTE_ATTRINDX(MT_DEVICE_nGnRnE) | PTE_PXN | PTE_UXN)
  #define pgprot_writecombine(prot) \
        __pgprot_modify(prot, PTE_ATTRINDX_MASK, PTE_ATTRINDX(MT_NORMAL_NC) | PTE_PXN | PTE_UXN)
index 8b845dd715f059f81161b2b7fc3eaecb51886c0f..931e09a9fa774caa860ff9fea40954e381d4a44d 100644 (file)
@@ -123,7 +123,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  
  static struct kset *iommu_group_kset;
  static DEFINE_IDA(iommu_group_ida);
-@@ -989,6 +990,26 @@ struct iommu_group *pci_device_group(str
+@@ -990,6 +991,26 @@ struct iommu_group *pci_device_group(str
        return iommu_group_alloc();
  }