Config-devel.in: rename symbol KERNEL_GIT_BRANCH -> KERNEL_GIT_REF
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 17 Jan 2018 12:05:57 +0000 (14:05 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 27 Jan 2018 15:46:45 +0000 (16:46 +0100)
The Download/git rule will do a `git checkout <git-ref>`.
So, we can use any ref we want.

No need to limit just to branches.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
config/Config-devel.in
include/kernel-build.mk

index 30fbd6f7a9964e08835a9ec7998e06d4f929c7aa..fd7c3ead1e8e6dcb6176216a4509f12845085c0b 100644 (file)
@@ -90,13 +90,14 @@ menuconfig DEVEL
                  In this instance, the --reference option of git clone will
                  be used thus creating a quick local clone of your repo.
 
-       config KERNEL_GIT_BRANCH
-               string "Enter git branch to clone" if DEVEL
+       config KERNEL_GIT_REF
+               string "Enter git ref at which to checkout" if DEVEL
                depends on (KERNEL_GIT_CLONE_URI != "")
                default ""
                help
-                 Enter the branch name to checkout after cloning the git repository.
-                 In this instance, the --branch option of git clone will be used.
+                 Enter the git ref at which to checkout the git repository
+                 after it is cloned, and before making it a tar-ball.
+                 It can be a git hash or a branch name.
                  If unused, the clone's repository HEAD will be checked-out.
 
        config BUILD_LOG
index 5c58e443df43b815a6b066455f5f5fb6e8ac30ad..c3658c216ae176ed92f621c742a68573eeb57c3a 100644 (file)
@@ -50,14 +50,10 @@ ifneq ($(strip $(CONFIG_KERNEL_GIT_LOCAL_REPOSITORY)),"")
   KERNEL_GIT_OPTS+=--reference $(CONFIG_KERNEL_GIT_LOCAL_REPOSITORY)
 endif
 
-ifneq ($(strip $(CONFIG_KERNEL_GIT_BRANCH)),"")
-  KERNEL_GIT_OPTS+=--branch $(CONFIG_KERNEL_GIT_BRANCH)
-endif
-
 define Download/git-kernel
   URL:=$(call qstrip,$(CONFIG_KERNEL_GIT_CLONE_URI))
   PROTO:=git
-  VERSION:=$(CONFIG_KERNEL_GIT_BRANCH)
+  VERSION:=$(CONFIG_KERNEL_GIT_REF)
   FILE:=$(LINUX_SOURCE)
   SUBDIR:=linux-$(LINUX_VERSION)
   OPTS:=$(KERNEL_GIT_OPTS)