package/uboot-omap: add default uEnv to boot via mmc card
authorAlexander Couzens <lynxis@fe80.eu>
Wed, 19 Apr 2017 02:48:03 +0000 (04:48 +0200)
committerAlexander Couzens <lynxis@fe80.eu>
Mon, 24 Apr 2017 16:03:31 +0000 (18:03 +0200)
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
package/boot/uboot-omap/Makefile
package/boot/uboot-omap/files/uEnv-default.txt [new file with mode: 0644]

index 17a4af42f2d9246fd4ea3ccf7f97dffa511aaa14..d11ced43519a49f3c3f9162934f740f10c9c7dfa 100644 (file)
@@ -19,6 +19,7 @@ include $(INCLUDE_DIR)/package.mk
 define U-Boot/Default
   BUILD_TARGET:=omap
   UBOOT_IMAGE:=u-boot.img MLO
+  UENV:=default
 endef
 
 define U-Boot/omap4_panda
@@ -45,6 +46,7 @@ UBOOT_TARGETS:=omap4_panda am335x_evm omap3_overo omap3_beagle
 define Build/InstallDev
        $(INSTALL_DIR) $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)
        $(CP) $(patsubst %,$(PKG_BUILD_DIR)/%,$(UBOOT_IMAGE)) $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)/
+       $(CP) ./files/uEnv-$(UENV).txt $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)/uEnv.txt
 endef
 
 $(eval $(call BuildPackage/U-Boot))
diff --git a/package/boot/uboot-omap/files/uEnv-default.txt b/package/boot/uboot-omap/files/uEnv-default.txt
new file mode 100644 (file)
index 0000000..3584e43
--- /dev/null
@@ -0,0 +1,8 @@
+bootpart=0:1
+bootdir=/
+bootfile=zImage
+fdtdir=/dtbs
+uenvcmd=run loadfdt; run loadimage; run uenvbootargs ; bootz ${loadaddr} - ${fdtaddr}
+loadfdt=load mmc ${bootpart} ${fdtaddr} ${fdtdir}/${fdtfile}
+devtype=mmc
+uenvbootargs=setenv bootargs console=${console} root=/dev/mmcblk0p2