toolchain: glibc ldd env path fixup
authorChen Minqiang <ptpt52@gmail.com>
Wed, 17 Apr 2019 12:00:49 +0000 (20:00 +0800)
committerJo-Philipp Wich <jo@mein.io>
Thu, 18 Jun 2020 18:08:18 +0000 (20:08 +0200)
This replace the shell script header of ldd
when it install to `/usr/bin/ldd` where
`#! /..../staging_dir/host/bin/bash`
should be
`#!/bin/sh`

Signed-off-by: Chen Minqiang <ptpt52@gmail.com>
package/libs/toolchain/Makefile

index f92a1779da18b9ffa2f321f70698c997c5f3b34d..9851a5f1cde6893360c859ac53686daf64569754 100644 (file)
@@ -614,6 +614,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
   define Package/ldd/install
        $(INSTALL_DIR) $(1)/usr/bin/
        $(CP) $(TOOLCHAIN_DIR)/bin/ldd $(1)/usr/bin/
+       sed -i 's,^#!.*,#!/bin/sh,' $(1)/usr/bin/ldd
   endef
 
   define Package/ldconfig/install