iproute2: update to 5.7.0
authorHans Dedecker <dedeckeh@gmail.com>
Sat, 13 Jun 2020 19:18:57 +0000 (21:18 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Sat, 13 Jun 2020 19:36:27 +0000 (21:36 +0200)
Update iproute2 to latest stable 5.7.0; for the changes see https://lwn.net/Articles/822152/

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/001-devlink-update-include-files.patch [new file with mode: 0644]

index 241ef8d12f68b9116bef16fc8fc2ed97faccc717..a29b26f8172b7042eee147c443f6ace44b95abc5 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=5.6.0
+PKG_VERSION:=5.7.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
-PKG_HASH:=1b5b0e25ce6e23da7526ea1da044e814ad85ba761b10dd29c2b027c056b04692
+PKG_HASH:=725dc7ba94aae54c6f8d4223ca055d9fb4fe89d6994b1c03bfb4411c4dd10f21
 PKG_BUILD_PARALLEL:=1
 PKG_BUILD_DEPENDS:=iptables
 PKG_LICENSE:=GPL-2.0
diff --git a/package/network/utils/iproute2/patches/001-devlink-update-include-files.patch b/package/network/utils/iproute2/patches/001-devlink-update-include-files.patch
new file mode 100644 (file)
index 0000000..ab43fb7
--- /dev/null
@@ -0,0 +1,46 @@
+From 12fafa27c7b306e6c397e858f4d5a8159500f659 Mon Sep 17 00:00:00 2001
+From: Stephen Hemminger <stephen@networkplumber.org>
+Date: Thu, 11 Jun 2020 09:46:46 -0700
+Subject: [PATCH] devlink: update include files
+
+Use the tool iwyu to get more complete list of includes for
+all the bits used by devlink.
+
+This should also fix build with musl libc.
+
+Fixes: c4dfddccef4e ("fix JSON output of mon command")
+Reported-off-by: Dan Robertson <dan@dlrobertson.com>
+Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
+---
+ devlink/devlink.c | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+--- a/devlink/devlink.c
++++ b/devlink/devlink.c
+@@ -19,18 +19,25 @@
+ #include <limits.h>
+ #include <errno.h>
+ #include <inttypes.h>
++#include <signal.h>
++#include <time.h>
++#include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <sys/sysinfo.h>
+ #define _LINUX_SYSINFO_H /* avoid collision with musl header */
+ #include <linux/genetlink.h>
+ #include <linux/devlink.h>
++#include <linux/netlink.h>
+ #include <libmnl/libmnl.h>
+ #include <netinet/ether.h>
++#include <sys/select.h>
++#include <sys/socket.h>
+ #include <sys/types.h>
+ #include "SNAPSHOT.h"
+ #include "list.h"
+ #include "mnlg.h"
+-#include "json_writer.h"
++#include "json_print.h"
+ #include "utils.h"
+ #include "namespace.h"