binutils: remove version 2.27
authorFelix Fietkau <nbd@nbd.name>
Tue, 10 Jul 2018 12:21:13 +0000 (14:21 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 10 Jul 2018 12:26:35 +0000 (14:26 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
toolchain/binutils/Config.in
toolchain/binutils/Config.version
toolchain/binutils/Makefile
toolchain/binutils/patches/2.27/001-MIPS_BFD_Remove_EI_ABIVERSION_5.patch [deleted file]
toolchain/binutils/patches/2.27/300-001_ld_makefile_patch.patch [deleted file]
toolchain/binutils/patches/2.27/300-012_check_ldrunpath_length.patch [deleted file]
toolchain/binutils/patches/2.27/400-mips_no_dynamic_linking_sym.patch [deleted file]
toolchain/binutils/patches/2.27/500-Change-default-emulation-for-mips64-linux.patch [deleted file]

index bcf69058319cde7e82fe9a5f475acb176bde4e4e..8455d843d2806aeb73396fe67649c5b154e76cff 100644 (file)
@@ -7,11 +7,6 @@ choice
        help
          Select the version of binutils you wish to use.
 
-       config BINUTILS_USE_VERSION_2_27
-               depends on !arc
-               bool "Binutils 2.27"
-               select BINUTILS_VERSION_2_27
-
        config BINUTILS_USE_VERSION_2_29_ARC
                depends on arc
                bool "ARC binutils 2.29"
index 23eeebe6a59a5e97c5fda1e0b24b94320bd102b0..95a99069a59248a165a9cfc4d8a009084bf4e6b3 100644 (file)
@@ -1,6 +1,3 @@
-config BINUTILS_VERSION_2_27
-       bool
-
 config BINUTILS_VERSION_2_29_ARC
        default y if (!TOOLCHAINOPTS && arc)
        bool
@@ -14,7 +11,6 @@ config BINUTILS_VERSION_2_30
 
 config BINUTILS_VERSION
        string
-       default "2.27"                 if BINUTILS_VERSION_2_27
        default "2.29.1"               if BINUTILS_VERSION_2_29_1
        default "2.30"                 if BINUTILS_VERSION_2_30
        default "arc-2017.09"          if BINUTILS_VERSION_2_29_ARC
index bb462cbf2cb07f5d772c47566eb64dd4faf8ae7d..6359bd2ecc1787d47cf288e65ff0031d97dde43a 100644 (file)
@@ -15,11 +15,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 
 TAR_OPTIONS += --exclude='*.rej'
 
-ifeq ($(PKG_VERSION),2.27)
-  PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-  PKG_HASH:=369737ce51587f92466041a97ab7d2358c6d9e1b6490b3940eb09fb0a9a6ac88
-endif
-
 ifeq ($(PKG_VERSION),2.29.1)
   PKG_HASH:=e7010a46969f9d3e53b650a518663f98a5dde3c3ae21b7d71e5e6803bc36b577
 endif
diff --git a/toolchain/binutils/patches/2.27/001-MIPS_BFD_Remove_EI_ABIVERSION_5.patch b/toolchain/binutils/patches/2.27/001-MIPS_BFD_Remove_EI_ABIVERSION_5.patch
deleted file mode 100644 (file)
index 36e09b1..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-From 4d4f40e041ce7c8c7c8e50f957e0440b64ab7e95 Mon Sep 17 00:00:00 2001
-From: "Maciej W. Rozycki" <macro@imgtec.com>
-Date: Fri, 23 Dec 2016 20:03:36 +0000
-Subject: [PATCH] MIPS/BFD: Remove EI_ABIVERSION 5 allocation for PT_GNU_STACK
- support
-
-Revert commit 17733f5be961 ("Increment the ABIVERSION to 5 for MIPS
-objects with non-executable stacks.") and remove EI_ABIVERSION 5
-allocation for PT_GNU_STACK support, which has not made it to glibc
-and will be reassigned.
-
-       bfd/
-       * bfd/elfxx-mips.c (_bfd_mips_post_process_headers): Revert
-       2016-02-23 change and remove EI_ABIVERSION 5 support.
----
- bfd/ChangeLog    | 5 +++++
- bfd/elfxx-mips.c | 3 ---
- 2 files changed, 5 insertions(+), 3 deletions(-)
-
-diff --git a/bfd/elfxx-mips.c b/bfd/elfxx-mips.c
-index d649676..486607c 100644
---- a/bfd/elfxx-mips.c
-+++ b/bfd/elfxx-mips.c
-@@ -16358,9 +16358,6 @@ _bfd_mips_post_process_headers (bfd *abfd, struct bfd_link_info *link_info)
-   if (mips_elf_tdata (abfd)->abiflags.fp_abi == Val_GNU_MIPS_ABI_FP_64
-       || mips_elf_tdata (abfd)->abiflags.fp_abi == Val_GNU_MIPS_ABI_FP_64A)
-     i_ehdrp->e_ident[EI_ABIVERSION] = 3;
--
--  if (elf_stack_flags (abfd) && !(elf_stack_flags (abfd) & PF_X))
--    i_ehdrp->e_ident[EI_ABIVERSION] = 5;
- }
- int
--- 
-2.9.3
-
diff --git a/toolchain/binutils/patches/2.27/300-001_ld_makefile_patch.patch b/toolchain/binutils/patches/2.27/300-001_ld_makefile_patch.patch
deleted file mode 100644 (file)
index e4cec7f..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/ld/Makefile.am
-+++ b/ld/Makefile.am
-@@ -57,7 +57,7 @@ endif
- # We put the scripts in the directory $(scriptdir)/ldscripts.
- # We can't put the scripts in $(datadir) because the SEARCH_DIR
- # directives need to be different for native and cross linkers.
--scriptdir = $(tooldir)/lib
-+scriptdir = $(libdir)
- EMUL = @EMUL@
- EMULATION_OFILES = @EMULATION_OFILES@
---- a/ld/Makefile.in
-+++ b/ld/Makefile.in
-@@ -451,7 +451,7 @@ AM_CFLAGS = $(WARN_CFLAGS) $(ELF_CLFAGS)
- # We put the scripts in the directory $(scriptdir)/ldscripts.
- # We can't put the scripts in $(datadir) because the SEARCH_DIR
- # directives need to be different for native and cross linkers.
--scriptdir = $(tooldir)/lib
-+scriptdir = $(libdir)
- BASEDIR = $(srcdir)/..
- BFDDIR = $(BASEDIR)/bfd
- INCDIR = $(BASEDIR)/include
diff --git a/toolchain/binutils/patches/2.27/300-012_check_ldrunpath_length.patch b/toolchain/binutils/patches/2.27/300-012_check_ldrunpath_length.patch
deleted file mode 100644 (file)
index 95d3f75..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/ld/emultempl/elf32.em
-+++ b/ld/emultempl/elf32.em
-@@ -1244,6 +1244,8 @@ fragment <<EOF
-             && command_line.rpath == NULL)
-           {
-             lib_path = (const char *) getenv ("LD_RUN_PATH");
-+            if ((lib_path) && (strlen (lib_path) == 0))
-+              lib_path = NULL;
-             if (gld${EMULATION_NAME}_search_needed (lib_path, &n,
-                                                     force))
-               break;
-@@ -1525,6 +1527,8 @@ gld${EMULATION_NAME}_before_allocation (
-   rpath = command_line.rpath;
-   if (rpath == NULL)
-     rpath = (const char *) getenv ("LD_RUN_PATH");
-+  if ((rpath) && (strlen (rpath) == 0))
-+      rpath = NULL;
-   for (abfd = link_info.input_bfds; abfd; abfd = abfd->link.next)
-     if (bfd_get_flavour (abfd) == bfd_target_elf_flavour)
diff --git a/toolchain/binutils/patches/2.27/400-mips_no_dynamic_linking_sym.patch b/toolchain/binutils/patches/2.27/400-mips_no_dynamic_linking_sym.patch
deleted file mode 100644 (file)
index b7458e5..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/bfd/elfxx-mips.c
-+++ b/bfd/elfxx-mips.c
-@@ -7713,6 +7713,7 @@ _bfd_mips_elf_create_dynamic_sections (b
-       name = SGI_COMPAT (abfd) ? "_DYNAMIC_LINK" : "_DYNAMIC_LINKING";
-       bh = NULL;
-+      if (0) {
-       if (!(_bfd_generic_link_add_one_symbol
-           (info, abfd, name, BSF_GLOBAL, bfd_abs_section_ptr, 0,
-            NULL, FALSE, get_elf_backend_data (abfd)->collect, &bh)))
-@@ -7725,6 +7726,7 @@ _bfd_mips_elf_create_dynamic_sections (b
-       if (! bfd_elf_link_record_dynamic_symbol (info, h))
-       return FALSE;
-+      }
-       if (! mips_elf_hash_table (info)->use_rld_obj_head)
-       {
diff --git a/toolchain/binutils/patches/2.27/500-Change-default-emulation-for-mips64-linux.patch b/toolchain/binutils/patches/2.27/500-Change-default-emulation-for-mips64-linux.patch
deleted file mode 100644 (file)
index 7a8f0ae..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
---- a/bfd/config.bfd
-+++ b/bfd/config.bfd
-@@ -1101,12 +1101,12 @@ case "${targ}" in
-     targ_selvecs="mips_elf32_le_vec mips_elf64_be_vec mips_elf64_le_vec mips_ecoff_be_vec mips_ecoff_le_vec"
-     ;;
-   mips64*el-*-linux*)
--    targ_defvec=mips_elf32_ntrad_le_vec
--    targ_selvecs="mips_elf32_ntrad_be_vec mips_elf32_trad_le_vec mips_elf32_trad_be_vec mips_elf64_trad_le_vec mips_elf64_trad_be_vec"
-+    targ_defvec=mips_elf64_trad_le_vec
-+    targ_selvecs="mips_elf32_ntrad_le_vec mips_elf32_ntrad_be_vec mips_elf32_trad_le_vec mips_elf32_trad_be_vec mips_elf64_trad_be_vec"
-     ;;
-   mips64*-*-linux*)
--    targ_defvec=mips_elf32_ntrad_be_vec
--    targ_selvecs="mips_elf32_ntrad_le_vec mips_elf32_trad_be_vec mips_elf32_trad_le_vec mips_elf64_trad_be_vec mips_elf64_trad_le_vec"
-+    targ_defvec=mips_elf64_trad_be_vec
-+    targ_selvecs="mips_elf32_ntrad_be_vec mips_elf32_ntrad_le_vec mips_elf32_trad_be_vec mips_elf32_trad_le_vec mips_elf64_trad_le_vec"
-     ;;
-   mips*el-*-linux*)
-     targ_defvec=mips_elf32_trad_le_vec
---- a/ld/configure.tgt
-+++ b/ld/configure.tgt
-@@ -513,11 +513,11 @@ mips*el-*-vxworks*)      targ_emul=elf32elmip
- mips*-*-vxworks*)     targ_emul=elf32ebmipvxworks
-                       targ_extra_emuls="elf32elmipvxworks" ;;
- mips*-*-windiss)      targ_emul=elf32mipswindiss ;;
--mips64*el-*-linux-*)  targ_emul=elf32ltsmipn32
--                      targ_extra_emuls="elf32btsmipn32 elf32ltsmip elf32btsmip elf64ltsmip elf64btsmip"
-+mips64*el-*-linux-*)  targ_emul=elf64ltsmip
-+                      targ_extra_emuls="elf32btsmipn32 elf32ltsmipn32 elf32ltsmip elf32btsmip elf64btsmip"
-                       targ_extra_libpath=$targ_extra_emuls ;;
--mips64*-*-linux-*)    targ_emul=elf32btsmipn32
--                      targ_extra_emuls="elf32ltsmipn32 elf32btsmip elf32ltsmip elf64btsmip elf64ltsmip"
-+mips64*-*-linux-*)    targ_emul=elf64btsmip
-+                      targ_extra_emuls="elf32btsmipn32 elf32ltsmipn32 elf32btsmip elf32ltsmip elf64ltsmip"
-                       targ_extra_libpath=$targ_extra_emuls ;;
- mips*el-*-linux-*)    targ_emul=elf32ltsmip
-                       targ_extra_emuls="elf32btsmip elf32ltsmipn32 elf64ltsmip elf32btsmipn32 elf64btsmip"